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CAD6 Release 2018 Service Pack 1 (June 2018)
Important Note: Starting with Release 2018, all licenses for CAD6 will be delivered electronically via e-mail by
default. If you cannot download the installation data from www.CAD6.com, you can order a separate CAD6 Box
with CAD6 DVD containing all installation data in our store.
Version of June 26, 2018:
-

The Parallel Outline (Equidistant), Generate Surface, Check Objects, and Color Handling commands now also
allow you to choose objects from within groups.

-

Circular arcs with extremely small arc angles (below 0.05 degrees), both individual and inside curves or
surfaces, sometimes caused display errors onscreen and during output.

-

With some extended objects created by plug-ins, points in their display data were inadvertently displayed when
displaying definition points.

Version of June 19, 2018:
-

Using the new Scale Set of Points > Linear and Scale Set of Points > Radial commands, you have even more
manifold ways to modify sets of points.

-

The Lettering > Tolerance Datum ISO 1101 command inadvertently drew the triangle symbol rotated by 180
degrees.

Version of June 12, 2018:
-

The Print Section and Export > Bitmap, Section commands have each been split into two separate commands,
one of which still allows entering a rectangular section while the other one now allows entering a polygonal
section.

-

Scenarios for Bitmap Export, PDF Printing, and Block Creation can now also use a polygonal section instead
of a rectangular section.

-

During printer output, line widths can now be globally scaled by an explicit factor.

-

When creating text objects, you can now choose „Current“ as default coordinate system in the settings to have
all new text objects automatically assigned to the current coordinate system.

-

The display of direction arrows is now also available for dimensionings in order to easier detect which end is
defined as starting or end point.

-

When highlighting objects while choosing objects, any displayed definition points, direction arrows, and
object numbers will now also be highlighted.

-

All command descriptions containing meaningless phrases such as „Standard“ or „Arbitrary“ have been replaced
by more meaningful descriptions.

-

The new variables ~%s4~, ~%s5~, and ~%s6~ give direct access to the names of the current length, line, and
angle unit, which is especially useful in dimensionings.

-

The Shape > Group > Create from Block Instances command now also copies any local and global attributes of
the blocks and instances to the groups to keep all references to them valid.

-

The Dynamic Snapping Guide > Parallel / Concentric command now allows direct numeric input of the
distance, in case of a circle also relative to the reference circle’s radius.

-

The Construction > Construction Aid Endless Line > Tangential Append and Perpendicular Append did not
work correctly for some types of circular arcs.

-

The editing pages in classic mode, the insert point’s position could not be changed.

-

The Dynamic Snapping Guide > Parallel, numerical command did not work correctly for the concentric case.
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-

Setting the dynamic reference point in a dynamic compound deleted the unique object ID.

-

Plug-Ins creating extended objects can now choose whether the definitions points in their display data shall
be visible or not. By default, they will be displayed.
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CAD6 Release 2018 (April 2018)
Version of April 10, 2018:
-

Text attributes (variables of the form „~*a(UniqueID)AttributeName~“) can now also be used to access target
values in linked parametric compounds.

-

When editing freedoms in parametric compounds, their unique ID was erased by mistake.

-

The selection of points using a polygonal area sometimes did not deliver any chosen point.

-

When canceling plug-in commands, an interface procedure was by mistake called too often, resulting in some
plug-ins displaying dialogs multiple times.

-

Editing the layer visibility in mappings could cause a program crash.

-

At the Map Model to Page > 3 Points, Aligned command, the scaling option was ignored.

-

During DXF and DWG import, the object reorganization could cause a program crash in some rare cases.

Version of March 20, 2018:
-

The new Parametric Compounds plug-in enables you to create compounds of objects with numerical parameters
and change them later on. Those parameters can access global variables and attributes in blocks and groups to
modify complete assemblies or drawings with a single click.

-

The new Conceal Objects commands let you hide objects of the drawings temporarily, e.g. to easily concentrate
editing on other objects. By design, concealing objects is not covered by Undo / Redo, but works independent
from that.

-

In Drawing References, individual layers of the referenced drawing can now be specifically hidden. Along with
the “Use only elements form referenced file” option, a very precise control of all layers in referenced drawings
in possible.

-

Most Trimming Commands now also work with Construction Aid objects as well as with “normal” objects.

-

When choosing objects and points, you can now either specify a rectangular or a polygonal area to choose
arbitrary subsets.

-

Selecting objects using the “Jutting Into“ mode is now much more accurate, it now uses the actual outlines
of the entities instead of only the surrounding frame.

-

The Centroid calculation has sometimes been inaccurate in extremely huge coordinate ranges.

-

In the Edit Block dialog, the block preview was sometimes not redrawn correctly after changing a block’s
properties.

-

While executing the Create Position Number command, clicking the right mouse button did not call the popup-menu.

-

When pasting Metafile graphics via the clipboards, they were in some cases inserted too large.

-

The import and export filters for DXF and DWG now use a newer library version and fix some problems
especially regarding the object order. In additional, concealed objects are now supported.
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CAD6 Release 2017 Service Pack 1 (October 2017)
Version of October 24, 2017:
-

Starting a second CAD6 window could cause a program failure if the block window was visible at that time and
filled with multiple blocks. Editing a block window entry could also cause a program failure if multiple CAD6
windows were open.

-

When opening the File Selection dialog in Windows 10, parts of the screen could be temporarily painted over
in gray.

-

When exporting to DXF and DWG files, a new warning will inform the user that all objects in the CAD6 layer
“*Standard” will automatically be moved to the layer “0”. Since that layer can be hidden in DXF and DWG, those
objects might become invisible!

Version of October 10, 2017:
-

Scenarios have been extended by the possibility to automatically create blocks. Create drawings as templates
for libraries and read all block definitions contained therein automatically into one or more libraries with a
single command and no more data input.

-

To support huge projects, the maximum number of scenarios has been increased to 1,000. In addition, the
scenario selection is now also possible in a list dialog that allows choosing and executing multiple scenarios at
once.

-

The new Create Block, Anonymous command allows uniting a set of objects into one internal block with an
automatically generated name. This is a convenient replacement for the old-style groups that are no longer
supported.

-

All dialogs used to insert, create, and edit blocks now feature a graphical list in addition to the text-based list
that shows all blocks of the currently active folder as previews. Using this preview list, you can easily find
blocks visually without knowing their names. Furthermore, you can now search for (partial) block names in
these dialogs.

-

The block preview in all dialogs and in the block list is now being generated and stored in the background in
order to not hinder your working.

-

In the classic mode, you can now move multiple pages simultaneously and enter relative coordinates if
desired. In addition, multiple grid-aligned pages can be created at once.

-

The new Scale > Factors, Relative to Point command enables you to easily scale objects by given factors
relative to a specified point (e.g. the origin). This is especially useful for scale adaptations.

-

Using the new Dimension Line > Ellipse Arc command, you can create dimension lines in the shape of ellipse
arc. This is often required in perspective views.

-

The new Text > Resolve Variables and Statements command allows you to resolve all used variables and
statements in texts and dimensionings once and for all to become independent from changes.

-

Using the new text statement ~*a()~ you can display attributes and object properties of linked objects
directly in texts.

-

In the layer and pen editing dialogs, the new folder management offers an easy way to create, rename, and
delete folders.

-

If screen and output properties are set to “Identical” for pens or layers, only one property set will now be
displayed in the respective list dialogs.

-

In many list dialogs that do not display details of the selected entry at the dialog’s bottom, you can now rightclick an entry to display its properties.

-

Drawing and library files now store the name of their creator independent from the name of the last user to
change the file. Access this information using the ~%a0~ and ~%a1~ text statements.
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-

In the Edit Block dialog, you can now move multiple blocks or folders into another folder of the same library
simultaneously.

-

The command Archive Drawing caused some faulty assignments of block components to elements such as layers
and pens.

-

The Clean Up Internal Block List command now also handles “old-style” groups to enable a reliable clean up in
one single step.

-

The Convert External Blocks to Internal command now also works correctly with nested blocks. Furthermore,
all required elements (layers, pens, etc.) will be copied from the libraries to the drawing.

-

Important messages and warnings from the program are now also displayed in the drawing area with the full
text for an easy grasp.

-

The lines in the Toolbox Window can now be swapped at once. This is especially useful when changing the
window’s position.

-

The direct entering of comments when creating groups did not work. Editing those comments afterwards only
worked in some cases.

-

When resolving groups with invisible objects, those objects were selectable afterwards by mistake.

-

Groups consisting of objects in locked layers only could still be chosen.

-

When exporting 1-bit-bitmaps, the resulting bitmap was inverted (black and white reversed).

-

The Resolve Block Instances command sometimes stopped after more than 25 instances handled and displayed
an error messages.

-

When Creating Blocks with the “Resolve Properties” option set, the assignment of line patterns in the library
and later upon inserting the block could be wrong.

-

The Perpendicular Append and Tangential Append commands did not work correctly for endless construction
lines, partially creating ghost lines that changed their orientation after saving and re-opening.

-

When copying dimensionings via the clipboard, the used coordinate system was not correctly copied or
adapted.

-

Position Numbers created without a reference object were by mistake always assigned to the Model Space.

-

Mappings within groups were not printed.

-

Database requests by means of an object ID only worked if that object ID was stored in the first column of the
respective database.

-

The output of large, multi-page layout drawings with many mappings using the CAD6 PDF Printer could take an
extremely long time.

-

The CAD6 PDF Printer now uses a newer library version.

-

The import and export filters for DXF and DWG now use a newer library version also capable of handling
Release 2018 files.
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CAD6 Release 2017 (April 2017)
Version of April 18, 2017:
-

The Archive Drawing did omit some external blocks and some bitmaps from the resulting archive.

-

The Print Preview could cause the program to crash when using the scrollbar extensively.

-

Choosing a group with Layer Management > Select always selected the layer “*Standard”.

-

When selecting or highlighting instances or groups, the surrounding frame will also be highlighted.

-

The display of important screen elements has been further improved for extremely high screen resolution.

-

The Automatic Archive did not do anything at all.

Version of March 21, 2017:
-

Parts Lists can now also be generated for a chosen set of objects.

-

In many cases, the generation of Parts Lists based on position numbers did not work.

-

Position numbers can now also be created without being assigned to any object. In addition, position numbers
can alternatively contain arbitrary texts instead of integer values.

-

Adding Object Data to Databases did not work as expected for Group properties.

-

When applied to curves, commands such as Trimming > Connect Objects left duplicate outlines.

-

When using Trim Object > Automatic Trim / Cut Out to trim against circles or circular arcs, sometimes surplus
intersection points were found.

-

Some dialogs were redesigned to fit completely even on screens with limited height.

Version of March 7, 2017:
-

The Delete Position Number command caused a program crash in some situations.

-

Inside groups, the Check Objects command delivered partially wrong results (false duplicate elements).

-

Changes in Coordinate Systems did not immediately affect dimensionings.

Version of February 28, 2017:
-

For individual lines, Block Line Patterns were displayed either displaced or not at all.

-

The Edit Curve > Bisect Element did not work correctly with individual lines and circular arcs.

-

Renaming a folder in the internal library could cause the program to crash.

-

Linking of texts was only possible with standard objects, not with block instances.

-

The extrusion contour selection for Edit 3D Parts > Edit Extrusion Depth failed in many cases.

-

The position of Pages in the internal coordinate system is now limited to the standard coordinate range of
±1e12 millimeters to avoid senseless results.

Version of February 21, 2017:
-

When Adding Object Data to Databases, attribute of instances and groups were not added correctly. Instead,
sometimes attributes of a local block were added.

-

When Adding Object Data to Databases, area and perimeter values were inadvertently not adapted to the scale
and unit of the current coordinate system, but added in 1:1 using Millimeters.

-

The display of Layer and Pen at the crosshairs now also works for groups.

-

When creating a group, all contained objects were assigned to the Model Space by mistake.

-

If groups contain only objects in hidden layers or assigned to hidden pens, they can no longer be identified to
avoid accidental selection and modification.
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-

The accuracy of the automatic trimming commands has been increased significantly for some situations.

-

The construction cases Circle > Line - Line - Point and Circle > Line - Point - Point have be re-implemented
and now work faster, more reliable and with higher accuracy.

-

The “Circular Arc” options of the Curve and Surface commands did not work correctly.

-

When deleting a page using the Layout Window buttons, the current zoom factors were mixed up.

-

When importing from drawings, it could happen that multiple identical elements named “*Standard” were
created.

-

The file selection dialog sometimes forgot its position.
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Version of February 7, 2017:
-

Groups are now individual objects with comment texts and attributes. They can be nested arbitrarily and are
much easier to use than before. First of all, those new groups can be used in external blocks and be copied via
the clipboard without any limitation. When keeping the ALT key pressed during object selection, you can select
individual objects from within groups in order to modify them along with other object that may also be part of
different groups. Objects can be added to groups later.

-

Points of objects within groups can now be selected directly and be moved along with other points, either
one-by-one or via an area selection.

-

Instances of internal and external blocks can now be converted directly into a nested group that has no
reference to any libraries.

-

A new command allows you to resolve nested block instances completely in one single step. The same applies
to groups.

-

Position numbers are now being realized by means of groups instead of internal blocks. Thus, they benefit
from all advantages of these new groups, especially the direct modification of their individual elements.

-

The new Move Points, Reference Edge, Numerical command enables you to extend and shorten objects by
selecting all points to be moved and stating the desired length of one edge. This, of course, also works with
points in groups.

-

Area and Perimeter Dimensionings are now fully associative, i.e. they now automatically adapt to any change
in the referenced objects and coordinate systems.

-

Texts can be linked to objects to access and display their properties such as area, perimeter, coordinates,
layer, etc. A coordinate system can be chosen to determine the scale and number display mode.

-

New Text Statements use object IDs to determine and display properties of specified objects. You can use
these, for example, to calculate the total surface area of multiple objects, fully associatively.

-

Database Requests can now use the linked object ID implicitly and are thus much more flexible. By means of
the new Database Stamp, multiple of those requests can be inserted automatically into all kinds of texts.

-

The Align Text to Edge command aligns multiple selected texts to any chosen edge.

-

The “Adapt Rotation and Scale” option of texts has been split into two separate options for “Rotation” and
“Scale”. They now are also effective in layout mode for texts in mappings, applying the mapping’s orientation or
the Model Space’s scaling factor to the texts.

-

The selection menus for pages, layers, pens, line types, and coordinate systems have got an alternative in
form of a fully scalable list dialog that allows for fast searching and easy handling even with a huge number of
entries. This new dialog with automatically be used if a given number of entries is reached, but can also be
activated permanently.

-

In the Edit Layers and Edit Pens dialogs, you can now create and use scenarios directly. This makes it easier
to save and switch between different sets of settings.

-

Comment texts for layers and pens are now being displayed directly in their dialog windows. They can easily
be initialized with the respective names and cleared again.
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-

In the Edit Layers, Edit Pens, Edit Line Types, and Edit Coordinate Systems dialogs, you can now determine
and display how often each of those elements is used within the current drawing.

-

The scaling factor that previously only affected the size of dimension texts and arrows in model space while in
layout mode, can now also be applied to reference text arrows and to line types. As a result, this scaling factor
is now set in the new Model Space Options dialog instead of the dimension parameter options dialog.

-

The new „Display Key Feedback“ option tells the application to display any type of user input (mouse button
clicks, key presses) as a small text in a window. This helps you during internal employee trainings, but can also
be used by our technicians during online trainings and for support purposes.

-

The Drawing List with the most recently used drawings now also uses a scalable list dialog that allows for
searching. It now stores the last 100 drawings used.

-

During the initial program start, a dialog will now appear, listing the most important improvements since the
previous update. It can be permanently deactivated and be accessed via the Help menu.

-

The display of the crosshairs and accompanying elements has been significantly improved for higher screen
resolutions.

-

The rulers are now much clearer to read.

-

The form and size of Display Grid Points on the screen can now be chosen.

-

When editing variables, all texts will now automatically be recalculated into order to make texts that were
“empty” before visible again.

-

The position of the File Selection Dialog has been saved and restored even if the monitor situation had
changed. This could cause the dialog to be invisible and unreachable.

-

When copying a block from an external library to the drawing, its layer and pen assignments when sometimes
not adapted correctly.

-

Inadvertently, no object numbers were displayed for area and perimeter dimensionings.

-

A newly created library was initially marked as “locked” by mistake.

-

In the Edit Geometry Data plug-in, relative values sometimes showed the “dy” value instead of the “dx” value.

-

The CAD6 PDF Printer now uses a newer library version.

-

The import and export filters for DXF and DWG now use a newer library versions.

Version History
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CAD6 Release 2016 Service Pack 1 (September 2016)
Version of September 21, 2016:
-

The import of WMF files did not work correctly for line and polylines.

-

3D Construction Points were partially not displayed on the screen.

-

The Trimming > Invert Orientation command did not work correctly with circular arcs in curves and surfaces.

-

The preview of customizable arrows in the “Draw” plug-in was incorrect for rounded elements.

-

The check for News and Updates upon program start has been moved to a parallel process to keep CAD6 from
sometimes idling several seconds before being responsive.

Version of August 9, 2016:
-

The Trim > Surface / Curve > Edit command now also works directly with lines and circular arcs.

-

Independent from the parameters, the Freehand Line was too smooth.

-

The Construction > Multiple Copy > Object command did not work correctly.

-

When editing a hatching, the current scale was applied to the line distances by mistake.

-

For the Shape > Scale > Factors command, the “Proportional” option is now active by default.

-

The Trim > Trim Objects > Cut Out and Trim > Trim Objects > Split commands sometimes combined outlines
inadvertently or created outlines twice.

-

The Shape > Rotate > Center dialog could not be cancelled correctly.

-

The screen display without antialiasing used wrong colors for some objects.

-

When reading manually created MKD or MKL files with explicit “0” values, an error could occur.

-

The CAD6 PDF Printer now uses a newer library version and is partially a lot faster.

-

The import and export filters for DXF and DWG now use a newer library versions.

Version of July 19, 2016:
-

When copying via the clipboard, groups were not copied along.

-

The Drawing Manager was limited to 10,000 entries. Elements beyond that limit were checked, but the result
was not displayed. This could result in an incomplete list of missing elements. The limit has been increased to
100,000 entries and a message is displayed if this new limit is crossed.

-

Untraceable blocks and groups within other blocks and groups were partially not highlighted using the green
notification texts.

-

When resolving texts based on internal font libraries, circular arcs were not handled correctly.

Version of June 30, 2016:
-

When saving a drawing, individual groups or blocks were occasionally not saved.

-

When importing hatching types, previously existing hatching types were sometimes erased.

Version of June 21, 2016:
-

When using unusual regional settings in Windows (e.g. “English” with a comma as decimal separator), CAD6
could display general errors when opening or saving drawings and libraries.

-

The Remove Chamfer / Rounding command can now also remove chamfers and roundings between a line and
circular arc as well as between two circular arcs.

-

Within Drawing References, now only objects belonging to Model Space will be displayed.

Version History

-

The Division > Object and Multiple Copy > Object commands no longer accept non-geometrical objects that
created adverse results.

-

Dynamic Snapping Guide objects were sometimes displayed with wrong line widths and/or patterns.
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Version of June 7, 2016:
-

The hatchings dialog has been redesigned. Line hatchings are now displayed and edited directly in the main
dialog. This way, hatchings can be created and modified much faster.

-

The new text statement {' } allows you to directly output money amounts with digit grouping, such as
“32,768.00 €“.

-

When copying via the clipboard, now only those layers, pens, line types, and coordinate systems actually used
by the selected blocks and objects will be copied.

-

The trimming commands for changing length, radius, and angle now also work with ending lines and circular
arcs in curves and hatchings.

-

The calculation of surface areas was rather inaccurate when using extremely large coordinates; deviations of
several percent were possible. A new computation method fixes this problem.

-

The maximum number of partial lines created when resolving circles, circular arcs, ellipses, elliptical arcs,
and Bézier curves has been increased significantly.

-

When trying to copy an internal block containing groups to an external library, an error message is now
displayed instead of doing nothing.

-

The Draw > Circle > Concentric command did not work correctly in CAD6 Eco.

-

Sometimes, the output of nested embedded blocks did not work correctly.

-

Colors defined in “CMYK (0..255)” mode were not stored correctly in the drawing file and converted to faulty
RGB values when reopening the drawing.

-

The Color Mixer and Color Harmony colors were mixed up when saving the drawing.

-

When editing text in tables created by the „Table“ plug-in, the program could crash in some rare cases.

-

The programming interface has been extended with the possibility to expand a text search to extended objects
(such as “Text on Path”).

Version History
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CAD6 Release 2016 (March 2016)
Important Note: Starting with Release 2016, all editions of CAD6 are offered as 64-bit applications that will
only work on 64-bit editions of Windows and Windows Server. That way, you’ll profit from an up to 20% better
working speed and access to more than 4 GB of RAM. Current 32-bit editions of CAD6 are still available, but
we strongly recommend the 64-bit editions. As of now, CAD6 requires at least Windows 7 or Windows Server
2008 R2 as operating system (either 32-bit or 64-bit).
Version of March 22, 2016:
-

On Windows XP and Windows Vista, the installation program did not display the message stating that CAD6
requires at least Windows 7 or Windows Server 2008 R2.

-

Some screen elements (definition points, direction arrows, markings, etc.) did not scale correctly according to
the user interface scaling determined by the user.

-

When hatching with a block-based hatching type, some circular arcs near the border were omitted. The
resulting hatch objects are now being optimized to reduce the required memory.

-

The surface area value at Add / Update Object Data did not correctly apply the current scale.

-

In the Texture / Color Gradient plug-in, the commands using a generated surface did not work.

-

When exporting to DXF and DWG, blocks located in pages were sometimes assigned to the Model Space.

Version of March 1, 2016:
-

As of now, all editions of CAD6 are now available both as 64-bit and 32-bit applications. All versions require
at least Windows Vista or Windows Server 2008. The 64-bit version can use virtually unlimited memory and is
significantly faster than the 32-bit application.
The installation program automatically chooses the matching application. If you’re already using a 64-bit
operating system, the update process will install the new 64-bit application parallel to the old 32-bit
application. When first started, the 64-bit application will once copy the 32-bit application’s current settings.
Afterwards, both application can be used independently from each other.

-

Three major operations are now significantly faster than before, especially in the 64-bit application: Opening a
drawing file is about 2 times faster, saving a drawing file is about 3 times faster, and a complex drawing’s
screen redraw is up to 8 times faster than before. Overall, the 32-bit application is somewhat slower than the
64-bit application, but still a lot faster than all the previous versions.

-

The “Construction Aid” plug-in features the new Dynamic Snapping Guide. It allows creating temporary
construction lines while executing another command and removes those lines automatically once that command
was finished.

-

New options have been added to the “Edit Properties” dialog windows: Using the “Apply all” and “Apply
none” buttons, all check boxes can be set or cleared at once. If the “Change both property sets simultaneously”
option is active, all changes in the dialog will immediately affect both property sets, e.g. texts and objects will
be changed at the same time. This is especially useful when editing dimensionings.

-

In the “Defaults” dialog for Copy Properties, you can now also define the presets for all known extended
objects such as color gradients or Bézier Splines individually.

-

The dialog for Edit Block now features checks box to select an arbitrary group of blocks and folders within one
library for joint editing (deleting, copying, editing properties).

-

In mappings, you can now assign individual properties to all single layers (in additional to hiding them). This
way, you can colorize specific parts of the drawing or make then partially transparent.
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-

Names for blocks, layers, and pens can now be up to 255 characters long (instead of 63 characters). All block
selection dialogs have been widened accordingly. Names for line patterns and coordinate systems can now be
up to 63 characters long.

-

The screen display quality with antialiasing has been improved significantly.

-

Working with huge and/or numerous external drawing references has been significantly accelerated.

-

The maximum number of pages within a drawing has been increased from 100 to 1,000.

-

The “Draw” plug-in now includes a customizable arrow object with individually chosen graphical arrowheads on
both ends and an arbitrary line width.

-

When using the “Filling only” filling mode, reference texts sometimes displayed the outline, too, or no filling
at all.

-

The dimension text object now has its own set of saved settings.

-

The “Scaling factor for dimension texts in Model Space” did not correctly apply to some dimension texts and
numbers.

-

The printing preview now uses anti-aliasing by default. Furthermore, the preview’s background color will always
be white, even if the work area uses a different color.

-

The printing dialog can now be force-closed by clicking the “Close” button multiple times.

-

Hyperlinks now also work if the link contains an explicit application name followed by a file name of some
parameters (e.g. for direct printing of a drawing or PDF file with a non-standard file name extension).

-

In the “Edit Properties” dialog and in multiple choice dialogs during object and point selection, all bitmap
objects will be displayed along with their bitmap’s file names to allow an easy distinction.

-

When using the Group Parts commands to combine multiple 3D parts in the “3D” plug-in that have been recolorized after their creation, that color information could get lost.

-

The STL and U3D export of complex 3D parts could cause the program to crash.

-

When exporting 3D parts using the CAD6 PDF Printer, there could be gaps between adjacent surfaces,
resulting in file lines where surfaces from the background could shine through.

-

The import and export filters for DXF and DWG have been revised and use the latest library version. They can
create and handle files up to version 2016.

-

All help files have been revised and use a different, more legible font now. Most of the graphics have been
recreated with a higher resolution.
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CAD6 Release 2015 Service Pack 2 (October 2015)
Important Note: After 20 years, the time has come – this is the final 32-bit-only edition of CAD6!
Starting with Release 2016, all future editions of CAD6 will be offered as 64-bit applications that will only
work on 64-bit editions of Windows and Windows Server. That way, you’ll profit from an up to 20% better
working speed and access to more than 4 GB of RAM.
Nevertheless, we'll continue offering all editions of CAD6 as 32-bit applications.
Version of October 27, 2015:
-

The display rate of drawing references and instances of external blocks has been increased by a factor of 2 and
more. Both can now be interrupted.

-

Very fine line patterns were very slow when using both object smoothing and line pattern optimization.

-

Dashed lines in arcs and curves could partially cause “ghost lines” when using the line pattern optimization and
outputting to the CAD6 PDF Printer.

-

When replacing a missing font by another one in the drawing manager while opening a drawing, this could
take extremely long for larger drawing files.

-

The edges of 3D Parts were sometimes displayed with wrong colors when zooming in.

-

When printing to the CAD6 PDF Printer and using the “1 Job per Page” option, the printing terminated after
the first page if multiple pages contained bitmaps.

-

Very large monochrome bitmaps could not be exported using the CAD6 PDF Printer.

-

When importing Shape files, a scaling factor of “0” will now be accepted as valid.

Version of September 29, 2015:
-

When displaying objects with smooth edges on the screen, arrowheads of dimensionings and reference texts
were partially drawn with incorrect properties.

-

When moving the current screen content using the middle mouse button or the Zoom > Section command, the
current object selection of the previously active command was cleared by mistake.

-

In the library management, the opening of libraries used the standard paths for drawings by mistake.

-

When importing points from SHP files as texts or blocks, the scaling was wrong.

Version of September 15, 2015:
-

Printing of multiple pages at once did not work on standard printers and PDF creators.

-

The boundary lines of mappings were partially displayed incorrectly (e.g. using a solid black line).

-

Submenu buttons in the panel and command bar partially left dark lines on the screen when being activated.

-

In the “Dimensioning” plug-in, preselecting a coordinate system via the “Dimension Parameters” did not work
correctly.

-

The text displayed at the crosshairs while hovering over a dimensioning could be useless.

Version of September 8, 2015:
-

Bitmaps in PNG and TIFF format can now be opened with an alpha channel.

-

By means of a new graphics interface for the printer output, transparent objects and bitmaps can now be
output to normal printers and PDF creation tools. The resulting quality largely depends on the printer driver
used.
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-

On the screen and during bitmap export, objects can now optionally be displayed with smooth edges (like fonts
already could before).

-

All “old” icons in dialog windows of the main application and all plug-ins have been replaced by new highdefinition graphics that automatically adapt to the screen resolution.

-

You can now copy scenarios to maintain their complete settings.

-

The calculation of the machine run time in the CAM part now produces more accurate and additional values.

-

The post-processors have been extended by some options and additional variables.

-

The “Simplify Surface / Curve” command left some duplicate points at the transition of two circular arcs.

-

In some cases, set operations for surfaces did not handle short lines near huge circular parts correctly.

-

Sometimes, hatchings with an opacity below 100% were not displayed at all.

-

When importing drawing objects from a file or the clipboard, numerous duplicate layers could be created if the
total number of layers exceeded 100.

-

The “By Layer” option for the opacity did not work correctly for bitmaps.

-

When by chance clicking a .DOCX file in the file selection dialog, an error message from the preview procedure
appeared in some cases.

-

The import and export filters for DXF and DWG have been revised and use the latest library version. They can
create and handle files up to version 2016.

-

The library 121 has been extended. In addition to the previous library “Security Signs DIN 4066, 4844, BGV 8A”
it now contains the new library “Safety Signs DIN 7010, 4844”.
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CAD6 Release 2015 Service Pack 1 (May 2015)
Version of May 26, 2015:
-

In the Determine Values dialogs, a new option allows displaying all values with the maximum possible number
of digits.

-

The settings for converting colors to grayscales or black & white were ignored by mistake when using the
CAD6 PDF Printer for output.

-

The command for loading from a template has been renamed to Template > Import and works as the name
suggests.

-

When importing MKD files, the file options for opening files were used as default values.

-

The preview in the Printing Dialog was sometimes incomplete or not displayed at all.

-

When using the CAD6 PDF Printer, the preview in the Printing Dialog now also displays transparent bitmaps
correctly.

-

The Transform Text to > Standard Text and Transform Text to > Reference Text commands were listed in the
menu of CAD6 Eco by mistake although there were, as intended, not implemented.

Version of May 5, 2015:
-

The selection filter is now also effective when selecting a text object for text editing.

-

Hyperlinks can now contain parameters in addition to a URL. This allows executing special applications with
files names and additional parameters.

-

When creating a new page, the recently chosen values will now be maintained even if the parameter dialog is
displayed once more.

-

The opening, saving, and editing speed of huge databases has been increased by a factor of up to 20.

-

The CAD6 PDF Printer now also allows creating PDF files according to PDF/X-4:2010 (ISO 15930-7, offset
printing).

-

When renaming a block using Edit Block, the corresponding instances will optionally be adapted, too.

-

By mistake, a block’s global attributes were not copied when creating an embedded block instance.

-

The dialog for line pattern editing did not work as intended, this was fixed.

-

In the 3D plug-in, a numeric rotation around the Y-axis was performed in the wrong direction.

-

If the “Extend to Center-point” option was active in a radius dimensioning, the dimension line was sometimes
extended beyond the center-point.

-

When sorting pages, it was impossible to move pages “behind” the last page.

-

A mapping source frame in Model Space could sometimes be identified although it could not be modified.
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CAD6 Release 2015 (March 2015)
Version of March 24, 2015:
-

The two commands Construction Aid > Contour Tracking Curve and Construction Aid > Contour Tracking
Surface had problems with circle and ellipse sections that included the 0-degree-point.

Version of March 17, 2015:
-

The new Construction Aid > In Foreground command offers another display option for Construction Aid
objects.

-

When changing the coordinate system preset of the active page by means of a right-click onto the layout
window’s page button, that new coordinate system will immediately be activated.

-

The Contour Tracking Curve and Contour Tracking Surface commands sometimes ignored intersection points at
the first quadrant point of circles and ellipses.

-

The step number input in the Multiple Copy > Rotation dialog did not work correctly.

-

Objects of the “Text on Path” plug-in that used only lines as path elements could cause the program to crash
during creation or when opening a drawing file.

-

In the CAM part, objects were sometimes displayed twice in the preview Window and exported to the postprocessor twice.

-

The layer and pen visibility was not always correctly evaluated for 3D parts within mappings.

-

When moving mappings, the live preview was sometimes incomplete.

Version of March 3, 2015:
-

In additional to the present perpetual buying licenses of CAD6, we now offer indefinite 1 year licenses of CAD6
Studio (as a single 1 year license named “CAD6 Studio 365”) and of CAD6 Industry (as a 1 year site license
named “CAD6 Company 365” for an unlimited number of seats at one site). Both products offer a maximum of
flexibility in license management and low entry costs.
Perpetual licenses will remain available as they were since they offer lower recurring costs, attractive
additional licenses, and educational licenses. CAD6 Eco and CAD6 Pro will remain available as perpetual licenses
only.

-

The new Backup List shows an overview of the last 100 backup files that were created using the “Autosave”,
“Create Duplicate”, and “Create Backup Now” commands. Using this overview, you can easily locate backup files,
open them in CAD6, or delete them permanently.

-

The set of available Construction Aid objects has been extended significantly. In addition to endless lines,
circles, and ellipses, you can now also create limited lines, circle arcs, ellipse arcs, curves, and surfaces.
Using those, you can easily create much more complex designs. In total, 38 new commands have been added.

-

Furthermore, it is now possible to convert normal objects to Construction Aid objects and vice versa.

-

Pages now offer the option to display automatic page margin and column guidelines. Those can be snapped
as well as switched on and off globally like normal Construction Aid objects.

-

In the page editing dialog, it is now much easier to edit specific properties of multiple pages simultaneously.

-

When working in layout mode, a right-click on the page buttons in the layout windows allows editing pages,
rearranging them, and activating them with specific zoom options.

-

You can now choose whether the display size of dimensioning texts and dimensioning arrows being mapped
from model space into a page shall be adapted automatically or not.

-

In order to make better use this automatic size adaptation, a new “Dimension Text” object has been added. It
can easily be entered without any reference points and behaves like all other dimensions with regard to scaling
and preset pen and layer assignment.
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-

Many commands that previously reported their successful execution using an often annoying dialog now use a
temporary, non-interrupting text display at the crosshairs instead. This applies especially to scenario
commands.

-

When inserting a block from an external library that uses a line type via transmission from a layer, that line
type was not correctly copied to the drawing and consequently displayed wrong.

-

When copying the instance of an embedded internal block via the Clipboard, the embedded instance itself
was copied, but not the referenced block from the internal library.

-

For area and perimeter dimensioning objects, no definition point was displayed.

-

The editing of texts did not work in architectural incremental dimensionings if they were assigned to a page.

-

When trying to print without choosing a valid printer, the program could hang.

-

The import and export filters for DXF and DWG have been revised and use the latest library version. They can
create and handle files up to version 2015.

-

The programming interface Open CAD Interface that allows extending CAD6 by plug-ins has been completely
converted to modern C++ (since the program itself already uses it for several years). In addition, all definitions
for the interface have been made length-unambiguous to prepare for a 64-bit version of CAD6 in the future.
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CAD6 Release 2014 Service Pack 2 (November 2014)
Version of November 18, 2014:
-

When inserting blocks from libraries, their used pens and layers were in part not adapted correctly.

-

In DBF Databases, the maximum length of a data set was needlessly limited to 8000 characters.

-

When creating a backup file of an untitled drawing, the resulting path was incorrect in some cases.

-

Menus could be displayed incorrectly and even cause a program crash if the maximum number of entries was
reached.

-

In some cases, instances of 3D blocks did not display correctly after re-opening the respective drawing.

Version of October 28, 2014:
-

Snapping intersection points between mapping objects and normal objects did not work correctly in some
cases.

-

Menus with too many entries to be displayed in one column were partly not split in time, resulting in “up” and
“down” arrows and thus awkward navigation.

-

When using pen “*Standard” with at least one property “By Layer”, the layer will automatically be fixed, too.

-

Creating 3D Blocks was impossible unless the respective library had already been modified and thus been
loaded into the memory.

-

Likewise, creating a 3D Block Instance only worked if the respective block had already been loaded to memory.

-

When hovering over a 3D Block Instance, the text display at the crosshairs stating the unit’s description could
be erroneous or even cause a program crash.

-

The file selection dialogs in some few plug-ins did not work correctly.

Version of October 14, 2014:
-

The handling of libraries has been revised completely. From now on, libraries will not be loaded into memory
upon program start, but automatically once they are about to be changed. This reduces the time required for
program start and the amount of required memory significantly. Furthermore, libraries can now be modified in
multiple alternating CAD6 windows without having to change settings in the library management
Despite this new procedure, individual libraries can still be marked as “read-only” to avoid any inadvertent
changes to those libraries.

-

In order to use the new library handling even more comfortably, the new Save and Unload all Changed
Libraries command has been added.

-

Some object properties (line type, line width, line color, line opacity, fill color, and fill opacity) now offer the
additional option “By Layer” which simply copies the respective property from the assigned layer.

-

As in previous versions, each newly opened drawing will automatically be checked for broken or incomplete
links that will be displayed in the Drawing Manager. However, this check is now much more thorough and
shows the results with much more detail.
Most of those errors (such as links to relocated bitmap files or missing libraries and blocks) can now be fixed
directly by right-clicking onto the drawing manager’s entries.

-

The commands Replace Block Name and Replace Library Name now offer the option to perform the
replacement also in all blocks of the current drawing or even in all blocks of all currently opened libraries.

-

Mappings are now also visible in Model Space in form of a mapping outline that indicates which source area of
the model space is being mapped to a page by means of this mapping.

-

The Filter and Find Properties commands now include the “Line Opacity” and “Fill Opacity” properties.
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-

The former Configuration menu has been replaced by the View menu. During this rearrangement, some
commands (options, mappings) have been moved to other, better matching locations in the menu structure.

-

When deleting pages that still contain objects, those objects can automatically be deleted along with the
pages.

-

Using the Text > Resolve command, you can now also resolve reference texts into their components.

-

The buttons in the Layout Window (being visible below the drawing area in page display mode “Layout”) are
now automatically scaled horizontally to fit as many usable buttons into the window as possible.

-

If more than one scenario is defined, the “Delete” submenu now offers an additional option to delete all
scenarios.

-

The “Format” submenu in text editing dialogs now directly offers the previously missing text formatting
options for text styles (<h1> ... </h1>), tabulators (<tab X>), and both left and right margin (<lmargin X> an
<rmargin X>).

-

The import and export filters for DXF and DWG have been revised and use the latest library version. They can
now create and handle files up to version 2015.
In addition, they now all support the “By Layer” property option.

-

The “Erase Text Background” option now also works with coordinate dimensionings.

-

When displaying object numbers, block instance will now always be handled as one object (with one number).

-

In property dialogs, more predefined line widths from 0.01 to 2.11 mm are available now.

-

In dialogs, the presentation of line and fill colors is now differentiated optically (wide line vs. rectangular).

-

The Partial Area Mode has been renamed into Area Mode »Jutting Into«.

-

The Offset (Equidistant) command has been renamed into Parallel Outline (Equidistant).

-

When creating reference texts and coordinate dimensionings, the preview was wrong using mode “Horizontal”
/ “Vertical”.

-

All icons for opening, saving, importing, and exporting files have been revised. They no longer use the
outdated symbol of a 3.5” diskette.

-

The Open CAD Interface now offers almost 100 new, length-safe commands for text handling to the plug-ins.

-

All interface commands of the Open CAD6 Interface have been made length-safe, i.e. they assure that no
adjacent memory areas will be overwritten accidentally.
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CAD6 Release 2014 Service Pack 1 (June 2014)
Version of June 3, 2014:
-

The installation program for CAD6 has been revised completely:
- The installation process requires much less user input.
- During installation and update, there is no more differentiation between CAD6 Pro, CAD6 Studio, and CAD6
Industry. As a result, there is only one common download file for these three editions.
- After the installation of a single trial version of CAD6, you can alternately test the three editions CAD6 Pro,
CAD6 Studio, and CAD6 Industry.
- A supplementary installation of single plug-ins is no longer required.
- Libraries will no longer be delivered on DVD, but only as separate files via e-mail.

-

When creating mappings starting in Model Space, you can now optionally enter the scaling and/or rotation
using the mouse. The scale can automatically be round towards standard scales (2:1, 1:1, 1:5, 1:1000 etc.).

-

The Zoom > Switch between Mapping and Model Space command now also allows switching from a mapping
source in Model Space to the respective mapping in a page (like it was already possible before in the reverse
direction).

-

The scenario menu has been extended by two commands: Using the Re-Enter Section command, you can
directly re-enter the section of a scenario without losing its settings. Using the Display as Zoom command, the
respective section will be displayed in maximum possible size of the screen.

-

The new Transform Objects to > Spline command can especially be used to directly convert polylines into
splines.

-

The “Draw” plug-in has accordingly been expanded with the Transform to Bézier Spline command.

-

The display modes for coordinate systems have been extended by those for the Cabinet and Cavalier
perspectives.

-

The source areas of Mappings and Scenarios with section information can now be highlighted on the screen.

-

Bitmaps can now be loaded directly from the Internet by using a URL instead of a file name. Changes to those
source files will have immediate effect when re-opening the drawing or updating all bitmaps.

-

The Drawing list now saves up to 100 drawings. Using the Remove invalid links from list command, you can
remove all links to files that no longer exist.

-

The location setting for the Autosave command wasn’t stored correctly.

-

In some few cases, newly created drawings without scenarios were reported as faulty and could not be loaded.
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CAD6 Release 2014 (April 2014)
Version of April 29, 2014:
-

With Contour Tracking Curve and Surface, the result sometimes deviated from the preview and was incorrect.

-

The Assemble Surface command did not terminate the surface properly if unused lines remained at the starting
point.

-

The commands used to create regular polyeders did not work correctly.

-

The text formatting menu in text editing dialogs did not work correctly in those cases were a value entering or
selecting dialog should have appeared, but didn’t.

-

Now you can also use the TAB key to switch to a “transparent” preview when inserting blocks and texts.

Version of April 8, 2014:
-

Scenarios make it possible for you to save and restore different element states inside a drawing. This way, you
can e.g. switch between to completely different sets of layers states with a single click. In addition to layer and
pen states, scenarios can also contain important display and output settings.
Finally, scenarios can contain output parameters for bitmap and PDF export, allowing you to automatically
create multiple outputs from one drawing, if necessary with different settings for each output.

-

When moving points, the expected result is now already displayed during input. This lets you use those
movement commands more intuitively and efficiently.

-

The display of objects during modification (especially when moving objects and large amounts of points) can
now be switched between “opaque” and “outlined only” by means of the TAB key at any time. This is mainly
useful when working with large filled surfaces.

-

Using the new Shape > Rotate Points command, you can rotate multiple definition points in the drawing
simultaneously around a common center-point.

-

The color selection dialog has been completely revised. For one thing, it now offers the possibility to generate
and store color harmonies in order to create and use sophisticated color schemes. For another thing, you now
directly mix up to four colors directly in the color selection dialog. Furthermore, the number of available
standard colors has been increased and controls have been placed more opportune.

-

In the color selection dialog’s options, you can now choose another set of predefined standard colors,
consisting of more than 650 standard process spot colors.

-

The Autosave command was extended by several new options, one of which being the possibility to include the
current date and time into the file name.

-

The new Create Backup Now command (Ctrl+B) can be used to create a backup of the current drawing at any
time, independent of the Autosave function. You can choose to place these backups either into the current
drawing’s path or into a central backup directory.

-

The new Extras > Miscellaneous > Display Smooth Fonts command allows you to easily switch between
smoothed and non-smoothed font display on the screen. This command is always accessible via the ‘+’ key.

-

The new Template > Import from Default command lets you directly import specific elements (such as layers
or hatchings) from the current standard template.

-

All operations working with Bézier Curves, Circles, and Ellipses have been re-implemented to use less
intermediate memory while yielding a higher accuracy. As a result, commands such as calculating surfaces or
perimeters of objects containing these outline elements will be much more accurate.

-

For all operations that may take a lot of time (e.g. copying huge sets of objects or resoling lots of block
instances), a progress indicator will be displayed in the status window to inform about the progress. In these
cases, the operation can be cancelled by pressing the ESC key if necessary.
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-

In reaction to that change, the program has been adapted to not be marked as “unresponsive” by the operating
system when performing extremely time-consuming tasks.

-

The maximum amount of usable RAM for each CAD6 windows has been increased from 2 GB to 3 GB on 32-bit
systems and 4 GB on 64-bit systems, resulting in up to 3.8 GB for object data and bitmaps.

-

In the printing dialog, header and footer texts are now divided into three parts for left-aligned, centered, and
right-aligned.

-

When directly opening a bitmap, CAD6 now asks whether or not to integrate that bitmap.

-

When using rotated coordinate systems, the ortho mode did not work properly.

-

Texts using internal fonts such as “DINDRAFT” could not be snapped or identified in layout mode.

-

When creating blocks in external libraries without resolving properties, some of the required line patterns
were not copied to the library, resulting in possibly wrong display of that block in other drawings.

-

The line display modes “No pattern, narrow” and “Pattern original, narrow” have been corrected to also affect
scaled lines in mappings.

-

If required fonts are missing while exporting to a file using the CAD6 PDF Printer, an error message will be
displayed, while the rest of the file will be exported correctly. Previously in these cases, the export wasn’t
possible at all.

-

In the G-Code post-processor of the CAM-Part, the commands G41 and G42 can now also be used with “open”
outlines.

-

The import and export filters for DXF and DWG have been revised and use a new library version. They can now
create and handle files up to version 2014.

-

The Unlock Program can now be called directly from within CAD6.

-

Our Live Support now uses the “TeamViewer 9” application which is part of the delivered installation data and
can be directly started from within CAD6.
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CAD6 Release 2013 Service Pack 2 (November 2013)
Version of November 26, 2013:
-

The text statements {f.X Term} and {g.X Term} did not work correctly. Among other things, this affected some
post-processors in the CAM part.

-

After choosing a command in the command bar, popup menus in dialog windows did not display correctly in
some cases.

-

When pasting from the clipboard with placement, two undo steps were inadvertently created (one for pasting,
one for moving), which upon undoing often resulted in objects remaining at unexpected locations.

-

When importing or pasting objects from different drawings, the newly added elements (layers, pens, etc.)
were not correctly marked with undo information and thus were not removed again if undoing.

-

Testing the CAD6 PDF Printer was impossible. If it was not unlocked, an error message was displayed.

Version of November 12, 2013:
-

The new Layout window automatically appears when working in layout mode with Model Space and pages. In
it, you can switch between Model Space and pages, and have access to the most frequently used commands.

-

For text formatting, you can now use nine text styles (<h1> to <h9> as in HTML). These allow defining and
using several layers of headline easily.

-

The editing of Coordinate Systems has been revised. It now uses a new dialog that shows all settings at once,
enabling you to change them without having to switch dialogs. This speeds up and simplifies the usage
significantly.

-

Using new variables of the type “Object Properties” (such as ~%p0( ID )~) you can directly access properties
of specific objects. You can, e.g., directly determine and use the surface measurement of an object. Once the
object changes, these properties will immediately adapt.

-

For easy usage of the object property variables, special commands have been created which create and store
corresponding requests in global variables. Using these, you can reference the requests by means of short
names.

-

Dimensionings in Model Space can now be scaled using a global scaling factor, allowing you to adapt them to
different scales both in Model Space and on pages, resulting in practical sizes in all worlds.

-

The Check Objects command features a new option allowing an automatic deletion all duplicate objects.

-

The sequence of events when creating Mappings has been changed: the choice of scaling and rotation is done
at a later time, as well as selecting the page. Furthermore, this choice can be changed at any time during input.

-

The CAD6 PDF Printer has been revised. Bitmaps can now be embedded into the PDF file using the highercompressing JPEG format. Optionally, the printer autonomously chooses the smallest bitmap format. Layers will
now be exported in alphabetically sorted order. Fonts can now be completely resolved into outlines to avoid
having to embed any fonts (especially protected) into the files.
In addition, a new PDF library is now being used, which fixes a lot of smaller bugs. Customers with valid
Support will receive new license data for this new version upon request.

-

An origin position stated relative to the page’s frame in a coordinate system will only be set during
initialization, i.e. it will no longer change if the page’s size changes. This avoids problems due to unintended
changes.

-

Fonts in text fields in dialog windows are now also scaled according to the scaling of dialog windows and
menus set by the user in order to fit better into the fields.

-

When using line pattern optimization, you can now determine for each object whether this optimization shall
be performed on each entire outline or separately for every outline element.

-

The line width display of individual Model Space objects can now optionally be set to zoom-independent.
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-

The display of outlines with wide line patterns and many partial lines on the screen has been accelerated.

-

When resolving texts, changes in properties (such as filling color) will now be applied correctly.

-

The coordinate display fields in the status window have been enlarged in comparison to the other fields.

-

The line pattern scaling was partly applied in a wrong way during printer output.

-

When using the “Optimize Line Patterns” mode on the screen, sometimes ghost lines appeared.

-

When pasting objects via the clipboard that were assigned to a pen being invisible on the target drawing,
those objects were inadvertently not moved along during placement.

-

When working in Layout mode and pasting objects from the clipboard, those will now automatically be
assigned to the current page.

-

Snapping of points in extended objects in mappings did not work, as well as snapping of intersection points
with construction aid objects. In addition, the current origin can now also be snapped.

-

Calling the Edit Variables dialog inadvertently deleted the Redo information for variables, even if nothing was
changed in the dialog.

-

The preview in the printing dialog did not always work correctly for area printing in layout mode.

-

Editing of single dimension texts within incremental and common datum dimensions did not work.

-

The bitmap export now uses the PNG format and a color depth of 24 bits as the default setting.

-

The conversion tools for old file formats (TVG, T4G, etc.) were not installed along with the program by mistake.

-

The import and export filters for DXF and DWG have been revised and now make full use of the new
possibilities for line width and line pattern definition.
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CAD6 Release 2013 Service Pack 1 (June 2013)
Version of June 24, 2013:
-

When editing texts, the cursor now directly jumps to the position where the text was clicked.

-

If, while searching for text, you use the possibility of editing the found text object directly, the first
occurrence of the searched text will be highlighted.

-

The new Edit Text Position-Based command displays a smaller text editing dialog close to the clicked position
for a faster workflow. As a compensation, it does not enable text property editing.

-

The new text formatting options <lmargin> and <rmargin> allow creating text indentations easily.

-

The new Update Active Database Contents command allows you to update all contents of auto-columns in the
currently active database with a single button-click. When retrieving object data, you can now comfortably edit
that object data even for multiple objects at once.

-

When printing to Windows printers and PDF creators, flags were not handled correctly within blocks.

-

Setting and index files are now being created with settings allowing them to be overwritten and deleted by
anybody. This avoids occasional conflicts between users with and without administrative rights.

-

In many situations that may require longer calculation times, an additional progress indicator will be displayed
now.

-

The import and export filters for DXF and DWG have been revised and use a new library version.

-

In the CAM Part of CAD6 Industry, the coordinate display in the export dialog has been improved, and some
small bugs in the preview have been fixed.
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CAD6 Release 2013 (May 2013)
Version of May 7, 2013:
-

The 3D Plug-In now features an export into the U3D format.

-

The CAD6 PDF Printer now allows to integrate 3D objects as genuine 3D data into the PDF file.

-

Old file formats (such as TVG or T3G) can now directly be opened in CAD6. You no longer have to start an
external conversion program.

-

The new Mapping > Aligned Rectangular Model Space Section command allows to comfortably display rotated
model space sections on a page in a straight aligned mapping.

-

When using the Move Objects > Relative command, you can now also specify the offset by stating length plus
angle.

-

In the line pattern definition, the partial line lengths can now be defined using floating point numbers.

-

When scaling objects, you can now always choose whether to scale line pattern lengths, too.

-

When nearing an object's outline during object selection with the display object type at the crosshairs option
active, the measures of the current outline elements (length, orientation, radius, etc.) will be displayed. For the
live measure display, you can choose between radius or diameter display.

-

The display of units on the user interface has been improved significantly, it is partly contrasted by using
different colors.

-

The access of internal databases has been accelerated considerably, resulting especially in shorter loading
times of drawings with lots of database entries.

-

On systems with multiple screens, some dynamic window were placed on the wrong screen.

-

When copying between drawings via the clipboard, sometimes the line patterns weren't copied correctly.

-

In the Table Plug-In, the automatic assignment to the current page did not work.

-

The Bézier Curves via Polyline command of the Draw Plug-In now features an additional “linear” end-style.

-

When creating a new drawing, you can choose between your standard template, a supplied template for
“Layout” mode, and a supplied template for “Classic” mode.

-

The import and export filters for DXF and DWG have been revised and use a new library version. They can now
create and handle files up to version 2013.

-

The Netviewer client for live support has been replaced with the more modern GoToAssist from Citrix.
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CAD6 Release 2012 Service Pack 2 (November 2012)
Version of November 20, 2012:
-

When entering arc lengths, the current arc direction is now correctly applied.

-

In the Edit Properties dialog, the element buttons could flicker.

-

Radius Dimensionings with the option “Extent to Center-Point” were partially drawn wrong.

-

When printing a section, the preview sometimes displayed object outside the section.

-

When resolving blocks or groups containing text, the program could crash.

-

A program crash was also possible when printing to a PDF file using the CAD6 PDF Printer with the “Export
objects in non-printed layers for archiving” option.

Version of October 16, 2012:
-

The complete user interface of CAD6 has been revised technically, it now automatically adapts to the userdefined resolution of the screen. It addition, it can also be scaled freely between 50% and 200% independent for menus, dialog windows, and tool windows. You can also choose the font to be used.

-

The new Calculate > Centroid command allows you to determine the centroid point of flat objects such as
polygons, circle parts, and ellipse parts.

-

The new option “Optimize Line Patterns” has been introduced. She modifies the output of line patterns in a
way that, at all line ends and all object corners, a line (and not a gap) is drawn. In addition, the “Resolve Line
Patterns” option is now also available for screen display.

-

The commands used to Copy and Cut to the clipboard are now available twice – once with a reference point and
once without. Correspondingly, when using the Paste command, you can now choose whether to use the
reference point or not.

-

The new Fit In command allows you to rotate and scale objects simultaneously to easily fit them precisely into
a given area. In addition, new variants of the Scale > Reference Distance and Rotate > Reference Points
commands work with reference points only, avoiding numeric input.

-

The orientation of the dimension arrows were often wrong in curved dimension lines.

-

The new control sequences <afill> and <aline> in texts allow changing the opacity of single text parts.

-

Some commands in the layer and pen management inadvertently deleted the flags in layers and pens.

-

Coordinate dimensions with pre- or post-texts longer than 8 characters resulted in files that could not be
loaded correctly.

-

The “Text on Path” plug-in sometimes displayed additional characters at the end of each text.

-

The line pattern handling in the import and export of DXF and DWG files has been revised.
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CAD6 Release 2012 Service Pack 1 (July 2012)
Version of July 25, 2012:
-

The line type selection button in the command bar worked only partially, and its display was not always
updated.

-

During the automatic conversion of circular arcs into elliptical arcs, an error caused an invalid internal data
sequence that prevented the respective drawing or library file from being loaded again.

Version of July 24, 2012:
-

Quick-access buttons for switching between the MKD, DXF, and DWG files types have been added to the file
selection dialog.

-

The object highlighting did not work if the line width display was set to “Minimum”.

-

Converting reference texts to standard texts did not work correctly and could even cause a program fault.

-

In some cases, the CAD6 PDF Printer exported objects that should not be printed.

Version of July 10, 2012:
-

The Save drawing as command displayed a wrong dialog in the English version and could not be executed.

-

Resolving variables in texts (e.g. when resolving block instances) could cause a program fault.

-

The installation program now better adapts to different system font sizes.

Version of July 3, 2012:
-

The new object highlighting during object identification automatically highlights the object at the crosshairs’
current position. This is especially useful when trying to identify objects that are covered by others.

-

Notifications offer a new possibility to be informed about situations and problems without interruption of the
work. They are displayed at the crosshairs and in the status window, and can be viewed at a later time in the
Drawing Manager.

-

The object properties have been extended by a line patterns lengths scale. Using it, you can freely scale the
display lengths of line patterns.

-

The toolbox can now also be placed above or below the drawing area.

-

A new options allows to choose whether the Cut, Copy and Paste commands shall work with an additional
reference point (as before) or without.

-

When generating surfaces, a preview is now displayed while entering the reference points. For assembling
curves and surfaces, the preview has been improved.

-

Parts lists can now also be written to both internal and external databases.

-

When resolving a clipping, the clipping contour now keeps it original properties.

-

The display of the duplicate setting at the crosshairs has been optimized to be active only when duplicate is
actually effective. In addition, the position grid and area selection mode state can now also be displayed.
Some new options allow you to better customize the display according to your liking.

-

Buttons in the Toolbox, Panel, or Command Bar can now also be assigned to line widths, line colors, filling
colors, and filling modes.

-

Buttons in the Toolbox, Panel, or Command Bar that are assigned to layers or pens now store the element’s
name instead of only the internal number to always show the correct element even in different drawings.

-

Displaying curves and surfaces with circular arcs larger than 90 degree in the screen could be incorrect for
very high zoom factors.

-

The 3D Plug-In now detects and reports possible runtime problems with complex set operations in advance.

Version History

-

The Table Plug-In has been reworked. Tables can now be filled from the bottom upwards. Tables based on
databases will automatically be updated if those databases change.

-

The CAD6 PDF Printer now allows exporting all layers with their respective states (visible/not visible,
printed/not printed). Thus the created PDF file reproduces the structure of the original drawing much more
completely.
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CAD6 Release 2012 (May 2012)
Version of May 2, 2012:
-

The output of transparent object fillings via the CAD6 PDF Printer sometimes did not work.

-

If the “Resolve line patterns when exporting EMF data” option was active, copying EMF data to the clipboard
sometimes resulted in a crash.

-

The display of settings such as multiline, arc mode, and arc direction at the crosshairs has been optimized to
display only those settings that are currently effective. In addition, the ortho mode is now being displayed.

Version of April 24, 2012:
-

The command Zoom > From Mapping to Model Space is now an interrupting command, i.e. the previous
command will be reactivated automatically after identifying the mapping and displaying the model space.

-

The arrangement of the Toolbox and Panel buttons no longer depends of the height and width of the
respective window. As a result, changing the window height no longer causes a rearrangement of the buttons.
The required data reorganization may however result in a one-time shift in the buttons’ positions.

-

The automatic opening of menus in the Command Bar will be suppressed right after choosing a command from
the menu bar.

-

In some cases, the printing of circles and circular arcs did not work.

-

Drawing and library files saved in CAD6 2011 format or older could not be opened using the corresponding
CAD6 versions (message “The file is faulty.”).

-

The display of element information in the drawing area did not work if the scales were hidden.

-

For the angle dimensioning commands, an active “Duplicate / Multiple Line” input mode was not correctly
visualized as an arc variant.

-

In the 3D Plug-In, some simple situations could result in extremely long calculation time.

-

A proportional 2D scaling can now directly be applied to 3D objects.

Version of April 3, 2012:
-

Completely new is the Command Bar above the drawing window. By means of automatic menus is offers an
extremely fast access to numerous frequently used commands and settings. The command bar is completely
customizable. In addition to many predefined button groups, you can add custom buttons, gaps, and
separators.
All previous methods of command selection (menu, popup, panel, toolbox, and keyboard) still work unchanged!

-

The previous Program Status command has been replaced by the Drawing Manager. It enables you to inspect a
drawing’s structure including all blocks, references, bitmaps, fonts, and libraries with a comprehensive tree-view
control, thus to easily locate and fix errors.

-

The Print Drawing dialog has been revised and now features a real preview of the pages to be printed. The
preview can be displayed for each single page to be printed.

-

Instances of blocks can now be embedded, i.e. the block’s data will be embedded into the instance, allowing
for the instance to be displayed unchanged even if the block or library is no longer available or has been
changed in the meantime. This is especially useful when storing specific revision states of a drawing securely
and permanently without having to give up the reference to the library.

-

Blocks and instances now feature a comment field that can e.g. be used to store version information.

-

Drawing files may now contain multiple internal databases. This enables you to comfortably store and use
extensive amounts of additional data.

-

The new Find in Database command allows you to search for objects that are linked to specific values or codomains in databases. In addition, such values and co-domains can be used as criteria in the selection filter.
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-

When using Clean Up Internal Block List, you will be offered the option to delete the undo information
beforehand if that would be necessary to reach an optimum result.

-

The Panel has been redesigned. It now integrates all settings into a few clearly designed buttons. The new
menu button allows you to access the complete menu from the panel. As a result, you can optionally hide the
standard menu bar completely without losing any option.

-

The look of all buttons in the various windows has been carefully revised to get the focus onto the most
important information. In addition, the currently hovered button is now optically highlighted.

-

A magnifier can be displayed at the lower edge of the panel, displaying the crosshairs’ surroundings magnified
live by a factor of 3. This makes pinpointing specific locations easier, especially in crowded areas.

-

For a better overview, the currently active snapping modes will be displayed directly at the crosshairs. In the
same way, current settings such as arc mode, arc direction, selection filter, and extended identification will
be displayed at the crosshairs during the respective input state.

-

Three new commands have been added to switch comfortably between pages and model space: Switch to Model
Space, Switch to Model Space based on a Mapping, and Recently Active Page.

-

When switching between pages, each page now saves its own active view area, so that on return, the previous
working area will be immediately visible.

-

Layers and pens now both feature 4 individually switchable flags as additional properties. These flags can e.g.
be used during print-out to determine different layer and pen subsets to be printed. To do so, simply specify
the flags that shall not be printed in the printing dialog. In addition, these flags can be used as a filter
criterion when selecting layers and pens in the corresponding configuration dialogs.

-

The layer and pen editing dialogs now offer an additional Complete List > submenu that enables you to quickly
apply settings to all layers or pens, respectively, without having to first select them.

-

At all commands that expect a numerical input at the end (such as Shape > Move > Relative), leaving the
respective dialog while keeping the CTRL key pressed can be used to toggle the duplicate state.

-

The display accuracy of circles and circular arcs has been increased significantly, resulting in a display that is
exact to one pixel even at highest zoom factors.

-

CAD6 Industry now includes several unilinear fonts for milling and engraving.

-

For objects created by means of the Text on Path plug-in, the display of font type and properties at the
crosshairs did not work correctly.

-

The CAD6 PDF Printer used a new major version of the PDFlib program library. This version fixes several problems
and features a lot of adaptations for the current standards. Whoever still uses an older license of the CAD6 PDF
Printer can request an updated license for free if his Support & Updates did not yet expire.

-

The import and export filters for DXF and DWG have been revised and use a new library version. They can now
create and handle files up to version 2012.

-

The maximum number of internal blocks in a drawing has been increased from 20,000 to 100,000.

-

The maximum number of internal fonts been increased from 10 to 20.

-

The placement of dialogs and menus on multiple monitor systems has been improved.

-

All icons used in Windows were revised, they now also contain the 64×64 and 256×256 pixels format.
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CAD6 Release 2011 Service Pack 1 (June 2011)
Version of June 1, 2011:
-

The screen display functions have been thoroughly redesigned and optimized. As a result, all drawings will now
be displayed faster by a factor of 2 to 4 (depending on the drawings’ complexity).

-

Snapping of intersection points within complex curves and surfaces with lots of circular arcs has been
accelerated significantly, partially by a factor of 30 and more.

-

The “3D” Plug-In has also been revised and optimized, resulting in a much faster recalculation of complex 3D
parts. Opening drawings with such parts has in most cases been accelerated by a factor of 20 and more (using
the same hardware). Calculating new views has been accelerated by a factor of 10 and more.
In addition, the plug-in can now use up to 16 processors simultaneously, additionally accelerating both
operations even more on appropriate hardware.

-

New Statements in Texts for concatenated variable names {§ } and formatted text output {s } offer new
possibilities for automation and output via postprocessors.

-

When using Line > Bisector, the line’s start-point could not be placed freely.

-

When opening a drawing for the first time, the display zoom was sometimes not initialized correctly.

-

In the dialog Configuration > Page > Edit, the selection is maintained after multiple pages have been moved
concurrently.

-

The object size information for extended objects (3D parts, color gradients) at Shape > Edit Properties was
incorrect.

-

The import and export filters for DXF and DWG have been revised. When importing a file using the option
“Import only objects from model space”, no changes are applied to the page settings any more.

-

Some changes extensions and corrections were applied to the CAM Part of CAD6 Industry:
- An option was added to the CAM > Open CAM Project command which now allows importing the tool list only
without changing the global CAM settings or the settings of the active postprocessor. In addition, you can now
move multiple items in the tool list concurrently.
- The preview in the dialog CAM > Export with Postprocessor wasn't complete if a non-active tool was on top of
the list while the option “Sort export” was selected. Furthermore, the CAM > Output Order > Check Order
command did not work correctly and could even cause a crash under specific circumstances.

-

New system requirements: CAD6 requires Windows XP with Service Pack 2, Windows Vista, Windows 7 or
higher. Older systems with Windows 2000 and Windows XP without Service Pack 2 are no longer supported!
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CAD6 Release 2011 (February 2011)
Version of February 22, 2011:
-

The “3D” Plug-In has been revised and extended by new commands and standard parts. The most important
new features are:
- Using 11 new standard parts, you can easily create parametrical profiles and regular shapes.
- The new Measure submenu features 9 new commands that can be used to measure the 3D parts.
- The Orbit function has been reworked and now works much more intuitively.
- 3D Markings can now also be placed as perpendicular points onto edges and surfaces.
- When creating multiple extrusions, rotations, and paths, their position relative to each other is retained to
allow easy transition from a 2D drawing to a 3D model.

-

The CAM Part in CAD6 Industry and the universal postprocessor have been revised. The most important new
features are:
- Using postprocessor chains, you can call multiple postprocessors subsequently with the same drawing data.
The resulting files can either be stored separately or automatically be concatenated.
- The use of the Sort Objects Manually command has been improved.
- New variables allow accessing axes movements, incremental coordinates, and object properties during export.
- Circles and circular arcs can optionally be resolved into quadrants.

-

The import and export filters for DXF and DWG have been revised. They work with files up to version 2011.

-

Creating Mappings based on outlines (both in Model Space and Page) did often not work.

-

Now you can already determine the layer visibility of the mapping to be created while creating Mappings (not
only afterwards).

-

The default layer for Bitmaps was ignored.

-

The “Lettering” plug-in did not always set the page assignment of its objects correctly, resulting in incorrect
visibility of partial elements.

-

Moving and scaling of the file selection dialog now works much more smoothly and reliably.

-

We now use a new generation of the Netviewer client which features higher security and better encryption.
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CAD6 Release 2010 Service Pack 2 (December 2010)
Version of December 1, 2010:
-

The new Trimming > Remove Chamfer / Rounding allows removing a chamfer or rounding within a curve /
surface by a single mouse click.

-

The new Trimming > Surface / Curve > Detach one Outline allows detaching a single, specific outline from a
complex surface, curve, or hatching directly.

-

The Trimming > Check Objects command has been extended to detect partially identical lines and arcs, too.

-

The Trimming > Round Corner and Trimming > Correct Corner commands have been rearranged. In addition, a
new correction option has been added.

-

In all situations where line widths can be automatically scaled during display (block instances, clippings,
references, mappings), it is now possible to also scale the lengths of the line patterns.

-

During the text search, the “Use upper/lower case” option was partially handled the wrong way round.

-

The evaluation of the objects’ page assignments in blocks in connection with inheritance did not work
properly, sometimes causing visibility problems.

-

In the dialogs for Layers and Pens, it is now possible to filter the selection for specific states (such as
“visible”).

-

The dialogs for text editing have been extended. They now feature nine new buttons that allow moving the
dialog across the screen by key shortcuts to have an unobstructed view of the desired part of the screen. In
addition, the new “Apply” button allows applying and controlling the current changes without having to close
the dialog.

-

The display of object properties at the crosshairs during the object selection has been extended by a color
display. Also, the properties are now separated into multiple lines for a better overview.

-

The display of screen and output properties in the Layers dialog now corresponds to the transmission
information, i.e. only those properties that are actually transmitted are displayed.

-

The import and export filters for DXF and DWG have been revised. They now work with transparencies,
correctly support object and page ordering, and can handle additional object types (Inventor, Wipeout, etc.).

-

Starting with this version, CAD6 is delivered on DVD instead of CD-ROM.
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CAD6 Release 2010 Service Pack 1 (August 2010)
Version of August 2, 2010:
-

When creating a new block instance in a specific page, it could be initially invisible.

-

Depending on the display settings, snapping of points and identification of reference objects in mappings
sometimes did not work properly.

-

When changing the current page while creating a mapping, the last point entry could be misinterpreted.

-

Printing of markings did not work correctly in scaled mappings.

-

When exporting DXF and DWG files, blocks in nested structures were sometimes not exported completely.

Version of June 17, 2010:
-

The display of folder names in the layer dialog was incorrect.

-

Some intersection points of circles and lines within curves and surfaces were ignored.

-

In the “Lettering” plug-in, changes to parameters made during the commands’ execution were ignored.

Version of June 4, 2010:
-

The calculation of intersection points between circles and ellipses has been redesigned and is now faster and
even more accurate. This mainly effects snapping.

-

In the toolbox window and the panel, the buttons can now alternatively be assigned directly to a pen or layer.

-

The options for page display during output have been extended by a “Like on the Screen” setting.

-

In the “Extras” menu, three new commands for switching on and off the display of point marking, direction
arrows, and object numbers have been added. Those commands are directly accessible via keys ( , . - ).

-

When editing attributes, all attributes can be browsed directly. When creating new attributes, their name,
contents, and parameters can be entered in a single dialog. In addition, multiple attributes can be created in
one run.

-

When editing the properties of instances, it is now possible to reinitialize all local attributes of the chosen
instances with the default attributes of the referenced blocks.

-

The respective active element in dialogs for layers, pens, etc. is now being highlighted to be easier to locate.

-

The work flow when creating a mapping was improved.

-

When working a long time with the program, the memory requirement could increase steadily until the system
was blocked.

-

When printing, construction aid lines assigned to specific pages were partly not printed.

-

In the Block Window and the Toolbox Window, the number of dynamic columns could not be set to “1”.

-

The Shape > Align Objects > Vertical, Top command did not work correctly.

-

When moving the window content using the middle mouse button, an ongoing extended selection was
cancelled by mistake.

-

In some cases, the “Extend to center-point” option for radius and diameter dimensionings created unwanted
results.

-

When changing the “Changeable” option for a specific library subsequently in different windows, it was
possible to create a state were the library was locked but no longer changeable for anybody.

-

When working with a lot of mapping objects, the memory consumption could raise until display problems
occurred.

Version History

37

-

The dimension line preview of the “Dimensioning” plug-in’s Common Datum Dimension, Staggered commend
was wrong. In addition, the snapping will automatically be deactivated when placing the dimensioning line, if
necessary.

-

When creating an extrusion or rotation in the “3D” plug-in, you can now select markings to create axes and
planes in the resulting 3D parts. The optional display of part axes is now positioned correctly at the part’s
origin.

-

A new command for optimizing the running direction (orientation) with regard to the tool path was added to
the “CAM” plug-in. In addition to that the bidirectional control of Zünd plotters via a serial connection is now
supported.

-

The “DXF Import/Export” and “DWG Import/Export” plug-ins were slightly improved and updated. For
example, DXF and DWG Export could crash when objects using block line patterns were involved.
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CAD6 Release 2010 (February 2010)
Version of February 12, 2010:
-

The calculation of areas sometimes did not work (no result).

-

When multiple instances of CAD6 were open, changing the library list in one instance could result in display
problems or a program crash in the other instances.

-

The icons in the movable tool window were by default arranged in the wrong order, i.e. from right to left.

-

Selecting the Infos command of a plug-in could cause a program crash.

-

Support of additional milling cycles for the creation of slots in the CAM Part.

-

CAM Introduction with additional and extended samples.

Version of January 27, 2010:
-

The CAM Part in CAD6 Industry and the accompanying, universal postprocessor have been revised and
extended fundamentally. The most important new features are:
- Use of automatic cutter compensation (G41/G42) with optional tangential approaching/leaving.
- Improved support of milling, drilling and turning cycles.
- Creation of contour subprograms used in SL cycles for roughing and finishing.
- The export of NC data can now be sorted according to the tools’ positions in the tool list.
- An object can be assigned to multiple tools concurrently, resulting in the same object being output multiple
times.
- Optional material feed and outline clipping according to an adjustable working area for large-scale cutters.
- Markings can be exported as points (simple drilling).
- Access to databases during the NC export.
- New CAM variables for the postprocessor’s dynamic control texts make a more extensive support of various
machine controllers possible.
- Revised postprocessors for Heidenhain and Universal DIN-ISO, plus a new postprocessor for ZÜND cutters.

-

Together with the new comprehensive online help, the new CAM introduction and its accompanying sample
drawings enable you to create your custom postprocessors.

-

The optional scroll bars have been replaced with a “Joystick” button in the panel. Using it, the window
content can be moved much more precise than with those scroll bars that also wasted a lot of screen space. You
can either click the button for defined movements or drag for fluid motion.

-

If multiple CAD6 windows are open concurrently, they now exchange all relevant settings in the background,
resulting in synchronous settings in all windows. This avoids operating errors.

-

Using new settings in the Configuration > Options > Windows dialog, it is now possible to display
comprehensive live information on the object currently at the crosshairs’ position during any object selection
(e.g. attributes, database references, properties, font type, etc.).

-

A new command allows creating an additional window with a new drawing directly from within CAD6.

-

Markings can now be displayed in different colors and sizes.

-

The CAD6 PDF Printer got new options. Using “Page Arrangement”, you can determine how the PDF file shall be
displayed. Using “Permissions”, you can e.g. determine whether the PDF file shall be printable or changeable.

-

A new reference text option allows you to create an outlined frame for the text (known as a “halo” in most
graphic programs). This way, you can easily highlight text that is placed on top of restless backgrounds.

-

Two new commands can be used to convert standard texts into reference texts and vice versa.
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-

When pasting objects from the clipboard, you will now (if applicable) be asked if the new objects shall
automatically be assigned to the current page. As a result, you can e.g. copy objects from one page of a
drawing to another.

-

Objects within a mapping can now be identified, e.g. in order to apply dimensionings or to use them as
references for perpendiculars or snapping functions.

-

You can now create new pages directly in the Edit Pages dialog.

-

The parameter dialog that appears when creating a mapping has been improved, it now offers a direct selection
of a coordinate system to initialize the scaling factor with its scale.

-

In the Configuration > Options > General dialog, the monitor size is now defined by its diagonal only.

-

The commands for smooth rounding did not work correctly in some cases with extremely small radii.

-

The commands for chamfering now offer an option for symmetric chamfers (without an explicit angle).

-

The layer defaults have been extended by an entry for “Bitmaps”, the pen defaults by “Generated
Surfaces/Curves”.

-

In order to improve the overview, the display of the current elements (layer, pen, coordinate system,
hatching, and page) is now by default located directly next to the corresponding buttons in the panel.

-

Objects pasted from the clipboard can now directly be assigned to the active page, depending on the page
display mode.

-

The Trimming > Check Objects sometimes reported identical start- and end-points of a single outline as a
problem.

-

The CAD6 PDF Printer did not work properly with different layers assignments in multiple pages. Furthermore,
there were small errors in transparency and in page and property transmission in instances.

-

Some trimming commands did not work correctly due to incorrect handling of Model Space / Page assignment.

-

Some object types could not automatically be assigned to the currently active page.

-

Changeable libraries are now locked once they are loaded, i.e. they can only be changeable in one program at
a time. This avoids synchronization errors.

-

If elements (layers, pens, etc.) in libraries were changed, the library was not marked as “changed”.

-

Multiple Copy > Rotation sometimes created a surplus copy when stating an incremental angle.

-

Creating a JPG or GIF bitmap by means of File > Save as... sometimes did not work since some parameters
were not initialized correctly. The direct export using File > Export > Bitmap, however, always worked.

-

In some situations, not all stored paths were searched, resulting in some files not being found.

-

The “Auto-Converter” plug-in displayed incorrect texts and error messages when using the CAD6 PDF Printer.
The resulting files were correct, though.

-

The “DXF Export” and “DWG Export” plug-ins now work much faster when exporting drawings with a lot of
mappings.

-

The “DXF Import/Export” and “DWG Import/Export” plug-ins now support file formats up to Version 2010.

-

The “3D” plug-in could crash during preview when creating standard parts with senseless parameters.
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CAD6 Release 2009 Service Pack 1 (July 2009)
Version of July 20, 2009:
-

The “Auto-Assign New Objects to Active Page” option is now inactive by default.

-

Size and position of the file selection dialog are now saved permanently.

-

In Windows Vista, the PDF Viewer could not automatically be installed by the setup program if necessary.

Version of July 7, 2009:
-

Objects within a mapping can now be snapped.

-

Using Configuration > Options > Mouse / Keys, you can now set the vertical mouse wheel’s function.

-

When selecting Configuration > Pages > Move, the model space was offered for selection although it cannot be
moved.

-

The Trimming > Check Objects command did not detect some identical objects as such.

-

When switching the active page, the screen was redrawn twice.

-

The Equidistant could cause an endless loop when used with huge coordinates.

-

Color Gradients with the “radial” mode did not work properly.

-

The “On click” mode for automatic buttons did not work correctly in some cases.

-

In the DXF and DWG import filters, some small problems with bitmap handling have been fixed. In addition,
the handling of Asian fonts has been improved.

-

If a newly create page will be invisible due to the current display options, a warning will now appear.

-

The number of predefined monitor sizes has been increased.

-

A fill color opacity inherited by layers way ignored.

-

The icons for “Position Grid” and “Display Grid” were exchanged in most skins.

Version of June 10, 2009:
-

All objects that are not assigned to any page now form the Model Space. This can be used separately from the
Pages in order to separate model and pager space. Using customizable display and output modes for model
space and page, you can use different modes of application based on your requirements and your personal
linking.

-

The new mapping object allows you to dynamically map parts of the drawing’s model space to another location
within a page of the drawing without creating a physical copy. A change in the original will directly affect the
mapping, too.

-

Using the new Trimming > Check Objects command, you can check the drawing’s objects for frequent logical
errors such as zero lengths, duplicate points, duplicate outline elements, self-intersecting objects, empty texts,
etc.

-

The import and export filters for DXF and DWG have been thoroughly redesigned. Model space and all layouts
from DXF and DWG files are now directly adopted and can be switched and edited directly in CAD6. During
export, pages are converted directly to layouts and the model space is maintained.

-

The display mode for the new automatic buttons can now be set separately for each of the six buttons.

-

To save screen space, the Plug-In-Window is automatically hidden if it contains no buttons.

-

When scaling the widths of non-solid lines by a factor of 1000+, the line sometimes disappeared.

-

Hidden layers in clippings were accidentally output during PDF export.

-

The “Edit tolerances” option did not work when creating area or perimeter dimensionings.
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The selection dialog in Edit Pens and Edit Layers now offers to search for comment contents.

-

The size of the clickable area for element activation in the element dialogs has been increased.

-

Modifying the properties of a complete sub-tree using 3D > Edit Part Tree did not work properly.

-

The 3D > Move / Copy 3D Parts > Point - Point command did not work correctly.
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CAD6 Release 2009 (April 2009)
Version of April 28, 2009:
-

Newly created hatchings without a default pen could cause corrupt files when saving.

-

If only a single layer, pen, hatching, or coordinate system existed, it was not possible to create a new one.

-

When deleting pages multiple times with closing the pages dialog in between, the page assignment of affected
objects could get confused.

-

SHP Import and Export can now handle “empty” databases or create them, respectively.

-

The SHP Export now filters duplicate points in polylines.

Version of April 7, 2009:
-

The display of direction arrows did not take the current coordinate system’s rotation angle into account.

-

In Layer Management > Edit, the chosen layer was not automatically displayed in the visible range of the layer
list.

-

When resolving block instances, a separate error message was displayed for each instance that could not be
resolved, resulting in a lot of messages in huge object sets. Still, the resolving was taken back if at least one
error occurred.

-

Using the automatic buttons could cause problems with drag & drop in other applications.

-

When creating PDF files using the Adobe Acrobat Distiller with separate output files for each page, the files’
indexes were offset by 1, resulting in the first page missing.

-

When importing SHP files with automatic creation of layers, the first object’s layer name was assigned to all
layers.

-

The SHP export created polygons with a reversed orientation, resulting in negative results of area calculations
in some other programs. Additionally, the last edge of polygons was sometimes not displayed.

Version of March 30, 2009:
-

The CAD6 PDF Printer allows you to create high-quality and high-resolution PDF files with transparencies,
layers, CMYK and LAB colors. The maximum internal resolution is 0.005 µm, which is by about factor 2000 more
accurate than with standard PDF printer drivers.
Optional creation of PDF files compliant with PDF/A-1b (ISO 19005-1 Level B, long-term archiving), PDF/X3:2003 (ISO 15930-6, offset printing), and PDF/X-1a:2003 (ISO 15930-4, offset printing).

-

All objects in CAD6 (outlines, fillings, texts, and bitmaps) can be displayed partially transparent (0 to 100 %
opacity). For bitmaps, you can state an alternative transparency color.

-

Colors can be defined in the CMYK, RGB, HSB, LAB, and grayscale color spaces. When creating a PDF file using
the CAD6 PDF Printer, these color spaces will be preserved.

-

Several hundred predefined printing colors in CMYK simplify the creation of prepress-ready drawings.

-

Six new automatic buttons in the panel offer fast and intuitive access to all frequently used drawing elements
(layers, pens, coordinate systems, hatchings, and pages) and to the list of recently used command. Simply move
the cursor the button, and the corresponding dialog appears - move away and it disappears.
All dialogs have been redesigned to be more flexible, and like the pen and layer dialogs, the new dialogs for
coordinate systems, hatchings, and pages can now also remain permanently open (e.g. when using two
monitors).

-

Using the new database commands Add Object Data, Find an Object’s Data, and Set Permanent Selection, you
can assign extended data to individual objects, create links between databases and object groups, search for
objects based on their extended data, and set the permanent selection automatically based a database’s
content.
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-

Each drawing file now contains an internal database in additional to the object data. Using this internal
database, you can use the extended database commands (such as assigning extended data to individual objects)
without having to care about archiving external database files.

-

Import and export of DBF database files in addition to the CSV format.

-

Import and Export of ESRI® Shapefiles with points, lines, and areas (SHP file). The attributes are imported
from the orresponding dBASE® file (DBF) and can be managed using CAD6's database commands.

-

When printing, you can now enter the desired page numbers arbitrarily with intervals, e.g. „1, 3, 5-8, 12“.

-

The dialog for object selection during ambiguous identification displays much more information (such as page
assignment, line style, colors, block names, etc.).

-

The default texts for tolerances in dimensionings can now be edited explicitly in the dimension parameters
dialogs.

-

The toolbox window can now also be docked on the right window edge.

-

Rounding, chamfering and notching is now possible at the transition of two curves or of a curve and line.

-

The new control sequences &shy; and &nbsp; allow a better control of word-wrap in frame texts.

-

Several commands such as Open in New Window have been equipped with standard shortcuts.

-

A scroll bar in the Navigator dialog allows easy scrolling through all drawings.

-

The Zigzag Line did not work properly.

-

Comments with an empty caption were not displayed correctly.

-

Block, layer, and pen names that begin with a backslash or that contain two consecutive backslashes caused
display problems in the corresponding dialogs.

-

The Copy Properties dialog was not initialized correctly, resulting in some check boxes being displayed wrong.

-

If blocks contain construction aid lines, those lines will no longer be used during the surrounding frame
calculation to avoid infinite frames.

-

When editing the properties of area or perimeter dimensionings, the dialog showed two tabs, the first of
which was without function.

-

Frame Texts had problems with word-wrap and justified alignment if text formatting was used within the text.

-

The Assemble Surface and Assemble Curve commands had problems with transitions from circular arcs to
elliptical arcs and vice versa.

-

If a drawing contained multiple identical pages, all but the first were ignored.

-

When creating a new drawing, variables from the previous drawing were maintained.

-

Shape and Position Tolerances can now also be edited using the Edit Text / Attributes command.

-

Import of point coordinates from CSV files (databases) and G-Code files (CAM programs).

-

The Drawing plug-in was extended with a command for drawing Archimedean and logarithmic spirals.

-

The Texture / Color Gradient plug-in now features an outline-based color gradient following a curve or surface
outline.

-

A new option in the 3D plug-in allows hiding all inside faces, reducing the number of faces to handle by
approx. 50%. This improves the overall performance and reduces the memory demand.

-

The 3D > Move / Copy 3D Parts > Point - Point did not work correctly when entering absolute coordinates.

-

The triangulation in the 3D plug-in work incorrectly in some rare situations.

-

A possibly very time-consuming operation in the 3D plug-in will be detected earlier, and a prompt will allow
cancelling it.
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CAD6 Release 2008 Service Pack 1 (July 2008)
Version of July 31, 2008:
-

The Draw > Circle > Circumcircle command and all corresponding commands did not work correctly.

-

The Trimming > Surface / Curve > Simplify command produced obviously wrong commands for huge
tolerances.

-

The Library > Replace Block Name and Library > Replace Library Name commands did not work correctly if
the source library name was “*Internal Blocks”.

-

When changing the file type in the file selection dialog, the extensions were not correctly initialized.

-

The dialog of the command Print Section could not be exited in case the specified (but disabled) start or end
page did not exist in the current drawing.

-

The Tool Path Offset command in the “CAM” plug-in now offers an automatic repetition options.

-

The “Text on Path” plug-in did not accept objects as path that were only filled.

Version of July 22, 2008:
-

The “3D” Plug-In has been revised and extended by 25 new commands. The most important new features are:
- 3D parts can now be combined using the “operators” union, intersection and difference. With these operators,
any imaginable part can now be created as a combination of multiple simple parts.
- As an equivalent to the construction aid in 2D, the 3D construction with points, lines, and planes has been
introduced. This allows to realize complex arrangements in space.
- Using the new Edit Parts Tree command, it now possible to view and selectively edit the complete hierarchy of
a complex 3D part.
- When importing STL files, the automatic edge and corner detection results in 3D parts that allow further
handling like any other 3D part.
If an STL file contains color information, it is now possible to apply those colors to the created 3D parts. Both
common color formats (RGB and BGR) are supported.
- When exporting STL files, many possible types of errors in the raw data will automatically be fixed.
Color information can optionally be exported in both common color formats (RGB and BGR).
- 3D blocks have been improved, they now offer the same transmission capabilities as 2D blocks.
- The calculation of the 2D surfaces for the display of 3D parts has been accelerated by a factor of 3 - 4 in
average. For complex parts, a factor of 10 and more is possible.
- If an operation should take an unexpected long time (which is well possible with 100,000 facets and more), this
operation can now be interrupted.
- A comprehensive 3D Introduction with numerous examples, screen shots and figures is available.

-

Using the new Trimming > Surface / Curve > Simplify command, you can automatically simplify surfaces and
curves, i.e. unnecessary definition points in outlines will be removed based on custom-defined tolerances by
combining neighboring lines or circular arcs.
This simplification can automatically be performed with all important commands used to create curves or
surfaces (Generate Surface, Assemble Surface, Assemble Curve, Equidistant, Contour Tracking).

-

All dialogs used to create, choose or edit blocks have been redesigned. The preview area has been enlarged,
and it is now possible to show a preview of the block’s attributes, too.
When replacing an existing block, the old block’s attributes can be automatically copied to the new block in
order to keep them.
The block editing dialog now also offers commands for attribute copying.
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-

The standard template has been completely revised, it now contains an extended set of pens and hatching
types. The line type have been better adapted to the standard, and seldom used layers have been removed.

-

The standard library has also been revised, it now contains new title blocks and drawing frames complying
with standards, in addition to the older versions of the title blocks and drawing frames, and the hatching types
according to DIN.

-

In the Configuration > Pages > Edit dialog you can now choose whether all newly created objects shall
automatically be assigned to the currently active page. For each page you can choose whether a scaling of the
page shall affect the output objects’ line widths or not.

-

When switching between pages using Zoom > Next Page and Zoom > Previous Page, or when jumping directly
to a page, the zoom factor was not initialized correctly in case of rotated pages.

-

The vertical alignment of frame texts did not work correctly if the text fit only narrowly regarding its height.
Problems also occurred when vertically aligning texts using the DINDRAFT or DINLQ font.

-

There is a new dimension line option “Extent to Center-Point” available for radius dimensionings.

-

The commands used to show and hide windows have been moved to a new “Window” menu.

-

It was not possible to snap points on a clipping surface’s outline.

-

Pen settings in hatching types are now correctly transmitted to the created hatchings.

-

When pasting bitmaps, WMF data, or EMF data from the clipboard, they can now be placed immediately.

-

Objects that were invisible due to their assignment to a page frame could still be chosen. If such a drawing
was printed, these actually invisible objects were printed in gray.

-

The area to be printed was sometimes miscalculated in rotated page frames, resulting in objects near the
page’s border being printed only partially or not at all.

-

When editing a dimension number, the “Recalculate Dimension Automatically” option will automatically be
deactivated.

-

If blocks contained dimensionings with an erased dimension background, the eraser used for the background
deletion was misplaced in most cases.

-

When resolving nested blocks with the “Scale Line Widths” option set, this option got lost.

-

When resolving a clipping surface, its filling mode was inadvertently transmitted to the subordinate objects.

-

When moving the drawing window’s content using the middle mouse button while selecting multiple objects
with the CTRL key pressed, it was possible to have the duplicate function permanently active afterwards.

-

The highlighting of possible results to be chosen did not work for some circle commands.

-

The import and export filters for DXF and DWG now also work with the 2009 file format.

-

When saving a named color gradient in the “Texture / Color Gradient” plug-in, not all parameters were saved.

-

The pen button display in the panel is now being initialized correctly after each import.

-

Loading and saving bitmaps uses a completely new programming library which is more stable and reduces the
program’s file size by more than 500 KB.

-

In the support section of www.CAD6.com, you can now find Training Videos for CAD6 in English and German.
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CAD6 Release 2008 (March 2008)
Version of March 28, 2008:
-

When updating from CAD6 Release 2007, the tool window assignment was lost in some cases.

-

The scanning process for cached libraries has been optimized.

-

The “Table” plug-in did not work correctly, resulting in disappearing or empty tables.

Version of March 18, 2008:
-

The “CAM” plug-in tried to load the current CAM project’s postprocessor settings from the wrong location,
resulting in an error message and incorrectly initialized postprocessor settings.

-

When using command buttons in the panel, no tooltips were displayed for these buttons.

-

The digitizer settings were not saved correctly.

-

If less than 20 buttons were defined in the tool window, the missing button were always initialized with the
respective default buttons instead of remaining undefined.

-

If the program detects a difference in the height/width ratio of the set monitor size and the screen resolution
it will prompt the user once to change the monitor size accordingly (instead of automatically using the default
size).

Version of March 7, 2008:
-

On some machines, Windows does not report correct system folder locations such as “Program Data” and
“User Data” to the installation program, resulting in an abort of the installation process. This behavior is now
handled better, and if necessary, the user is given the opportunity to enter these locations manually.

-

The layer visibility options in clipping surfaces were not correctly read from files, resulting in layers
sometimes being hidden unintentionally.

-

If an outdated skin (such as Windows 95, 98, ME, or NT) was selected at Options > Skins before updating to
Release 2008, the screen display was incorrect afterwards. Now, the program will automatically switch to the
default skin.

Version of March 5, 2008:
-

The complete user interface (consisting of menus and dialog windows) has been technically revised and can
now be scaled in multiple steps (from 80% to 140%). Especially on the high-resolution screens (24 inch or 30
inch TFT) that are more and more used for CAD applications, a setting of, e.g., 125% increases the overall
legibility significantly.

-

Settings for windows such as the panel, block list, toolbox, etc. can now be modified by means of clearly
arranged context menus accessibly by right-clicking into the respective window. This significantly clears out
the previously confusing Options > Windows dialog.

-

The tool window can now have multiple columns even it is docked on the left edge of the screen. You can
choose between permanently visible and dynamically appearing columns. A total of 200 commands can be
spread over up to 10 columns. The buttons of the tool windows can be manually rearranged.

-

The block list can now have multiple columns. If docked, you can choose between permanently visible and
dynamically appearing columns. A total of 200 blocks can be spread over up to 10 columns. The buttons of the
block list can be completely sorted or manually rearranged.

-

In addition to pens and layers, the panel can now also contain command buttons (like the tool window). If you
do not use the pen or layer selection in the panel, you can replace those buttons by command buttons and
subsequently switch off the tool window to increase the free drawing space.

-

The menu display has been completely redesigned to increase the legibility of the menu entries. Optionally,
each menu entry can be prefixed with the corresponding command’s icon.
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-

At the lower left end of the scales in each drawing window, you can display selection buttons for the
elements (layers, pens, hatchings, coordinate systems, and pages). Next to these buttons, each active
element’s name will be transparently blended over the drawing area. This allows a fast overview over all selected
elements, and it usually makes the property windows unnecessary so that you can hide it – resulting in more
free space for the drawing area. (Long term users might remember a similar feature from the first versions...)

-

In the multi-level popup menus used to select layers and pens, the current modes of the respective layer or
pen are now displayed using icons within the menu entry. This way you can easily see which layer is, e.g.,
currently being output or shaded.

-

In all text objects and dimensionings, you can now adjust the vertical text alignment in addition to the
horizontal text alignment and the text reading order.

-

Displayed bitmaps can now be image-processed “live”, i.e. gamma, brightness, contrast, and intensity can be
adjusted independently for each instance of a bitmap. This way, you can e.g. match different photos and fade
out maps being displayed in the drawing’s background.

-

Pages can “hide” specific layers, i.e. the specified layers will be ignored when the respective page is being
output and will optionally be hidden, shaded or normally displayed on the screen. This allows you to switch off,
e.g., layers containing detailed views when printing an overview page.

-

Objects can be assigned to a specific page, i.e. these objects will only be output along with the assigned
page (but not when printing a different page or when printing a section) and will optionally be hidden, shaded
or normally displayed on the screen if the assigned page is currently not active. This way, it is e.g. easily
possible to assign a different drawing frame to each page.

-

Clipping surfaces can “hide” specific layers, i.e. some of their contained objects will not be displayed based
on their layer assignment.

-

The new option “Color Conversion” in the Drawing Settings > Output dialog allows to optionally output a
colored drawing in either grayscale or black & white. This affects all objects and bitmaps.

-

The new option “Resolve Line Patterns” in the Drawing Settings > Output dialog allows to optionally resolve
all line patterns and to output them in form of single solid lines. This is necessary for some printer drivers and
PDF tools that do not handle line patterns in printing data correctly.

-

The skins “DarkBlue” and “DarkGray” that are available at Options > Skins have been redesigned to work better
in combination with a black drawing window background. To this end, the display of command icons in the
toolbox’s buttons and in the popup menu has been improved.

-

In addition to the standard colors for white drawing window background, the Drawing Settings > Colors dialog
now offers an additional predefined color set for a black drawing window background.

-

Besides the conventional narrow crosshairs, you can now, by means of the Options > Windows command,
choose three pixels wide crosshairs which can better be made out on high resolutions. In addition, the
crosshairs’ opacity can be adjusted. The display of filled objects while moving can be switched between opaque
and pseudo-transparent.

-

The file selection dialog now stores the display settings of the respective list view.

-

In the Options > File Options dialog, you now separately edit the file options for opening a drawing and for
importing a drawing. When importing, general settings stored in the drawing will not be loaded by default.

-

The “3D” plug-in now allows to create and use 3D blocks. 3D blocks work similar to 2D blocks and can be
stored and managed in normal libraries.

-

The “Texture / Color Gradient” plug-in has been revised. The data stored per texture or color gradient has
been significantly reduced, resulting in less required memory and smaller file sizes. The recalculation while
opening has been sped up. Named textures and color gradients are now stored independently from the current
drawing.

-

The “DXF Import” and “DWG Import” plug-ins have been revised. They now handle line widths in LWPOLYLINE
objects correctly in all cases.
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-

The overall management of data in extended objects (color gradients, 3D components, etc.) has been
completely changed to allow faster opening of drawings and handling of these objects.

-

Frequent problems with the screen redraw when moving by means of the arrow keys or during extensive object
selection operations have been fixed.

-

If multiple drawing windows were active, the display of the selected object during multiple object selection
was faulty.

-

When deleting a block within the Edit Blocks dialog while the next block to be selected originally used that
deleted block, the program crashed while trying to show the preview of that block.

-

The Construction Aid > Line > Perpendicular command obviously did not work correctly in some situations.

-

The installation process for CAD6 has been completely revised. During installation, you can now choose
whether settings shall be stored separately for each user, or globally for all users alike. Program data is now
stored in the Windows program directory, global settings in the application data directory, user data and
settings in the user-dependent document directories.
On the one hand, this new storage principle makes it easier to backup all user data, on the other hand, it is
more compatible with the new user access control in Windows Vista. In addition, storing settings globally for all
users makes it easier for administrators to manage the system on computers in multi-user environments (such
as schools and universities).

-

In order to make the system more portable, and to bypass problems with limited access rights to the registry
database in Windows Vista, all settings stored by the application itself are now stored in configuration files
instead of the registry database. Due to this change, the normal user does not require administration rights at
any time, and the loading and saving process of those settings is significantly faster. In addition, it is much
easier to transport settings from one computer to another.

-

For users that frequently have to switch the application language, we now offer language packs that replace all
language-dependent files in an existing installation. This way, switching languages is a matter of mere seconds.

-

Unlocking the program and possible plug-ins must now always be done by means of the unlock program
MKUnlock.exe and requires administrator rights.

-

The service-based dongle server MKDongleService.exe and its help file have been revised. The dongle server is
now much easier to install, and works fine on Windows Vista.

-

The MKTools (MKZip, MKUnzip, etc.) have been extended by a new option that allows a better integration into
file explorer applications. This way, creating and extracting ZIP archives is easier to use.
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CAD6 Release 2007 Service Pack 1 (November 2007)
Version of November 5, 2007:
-

The display of rotated monochrome bitmaps was sometimes inverted.

-

When printing rotated page frames, sometimes only parts of the page were visible.

-

When printing a section, sometimes one copy per existing page frame was printed.

-

Printing of Construction Aid lines did not work.

-

When changing a bitmap’s display size, the entry for the vertical scaling was used as horizontal scaling, and
the entry for horizontal scaling was ignored.

-

The dialog for simultaneous editing of multiple dimensioning objects with lines did not display the current
state of the radio button correctly.

-

The Dongle Server software is now also available as a service-based application for background operation on a
server.

Version of September 28, 2007:
-

The Import and Export Filters for DXF and DWG have been revised, they use a new library version. Objects of
type “MTEXT” are now resolved by default which results in more precise placement of multi-lined texts.

-

In some cases, the Equidistant command could issue an error message even though the result would have been
correct, resulting in no object being created.

-

Setting some dimensioning parameters in the Edit Text / Attributes dialog still did not function.

Version of September 25, 2007:
-

In printing mode “All objects (ignore pages)”, it was not possible to switch between landscape and portrait
paper format.

-

Setting dimensioning parameters in the Edit Text / Attributes dialog did not function.

-

The optional “0” in common datum dimensionings with a single line was placed incorrectly.

-

After importing DXF and DWG drawings, not all window contents were redrawn immediately.

Version of September 19, 2007:
-

Some dimensioning types displayed their extension lines by mistake off angle.

-

During program start, deactivated old plug-ins could result in a Windows error prompt.

-

CAD6 Eco and CAD6 Viewer could enter an endless loop when opening drawings containing 3D components.
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Version of September 18, 2007:
-

Some time-consuming functions, such as the complete recalculation of all objects after opening a drawing, now
use up to 8 processors concurrently, if available.

-

The functions for the complete recalculation of complex drawings with numerous blocks and texts have been
completely redesigned, resulting in the recalculation to be up to factor 20 faster.

-

Many dialogs that require a non-integer numerical input (e.g. scaling, moving, rotation, etc.) now store the
previous input in text form instead of numerical form. After entering “2/3” once, the dialog will now display
“2/3” when opening next time instead of “0.6666”. This increases both accuracy and usability.

-

The screen redraw engine has been optimized to avoid any unnecessary screen redraw. Especially the
highlighting of selected objects (and its subsequent removal) has been sped up significantly.

-

The Shape > Scale Objects > Factors dialog now offers the “Proportional” option. As a result, only one factor
has to be entered.

-

The crosshairs are now being displayed with transparency. As a result, vertical and horizontal lines are now
visible during input.

-

In addition to the page frame’s number, the page frame display now also includes the comment (if any). The
display will now be adapted to the page’s rotation.

-

The printing options “Print on multiple sheets”, “Fit onto one sheet”, and “Adjust paper size” are now also
available when printing page frames.

-

The “3D” plug-in has been extended:
- The new Data Exchange submenu allows to import and export 3D date from STL files. The STL format is a
simple exchange format for 3D data. It only features colorless solids consisting of triangles in 3D space. Almost
any 3D system supports this format.
Objects from STL files are imported as “Freeform Parts” that can be handled like any other 3D component, i.e.
they can be modified, combined, and resolved into 2D surfaces.
For the STL export, all previously defined 3D parts were revised so that all created cover and side surfaces are
now oriented correctly, i.e. consistent regarding “inside” and “outside”.
- A new option can be used to determine which side of a 3D surface is “inside” or “outside” by highlighting the
inside of these 3D surfaces with a defined color. This is useful to check if an imported STL file is correct.
- Using Shape > Edit Text / Attributes, you can now assign a name to all 3D components. This name will e.g. be
used for the STL export.
- The recalculation of the 3D components display lists now uses up to 8 processors concurrently, if available.

-

The number of storable paths was increased from 8 to 20 for each file type.

-

All dimension lines and dimensionings now offer the additional dimension line end-symbol „large unfilled
circle“. In the “Options” dialog of the dimension parameters, you can now set the extension line overhang
(previously always 1 mm).

-

In some situations, the capitalization of the variable names was taken into account by mistake.

-

The Shape > Scale Objects > Reference Line dialog did not correctly take the current scale into account.

-

Line patterns with partial lengths in 1/100 mm were displayed wrong in scaled blocks.

-

Scaled line widths in scaled block instances were exported wrong.

-

Setting the display size with Configuration > Options > General did not work.

-

The simultaneous editing of multiple blocks containing extended objects (such as color gradients) could cause
a program crash.
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-

When using file names in hyperlinks and attributes, all standard drawing paths and project paths will be
searched for the file, if necessary.

-

The Configuration > Windows > Enlarge Window X commands did not work correctly.

-

The plug-in “Dimension” has been extended. Common datum dimensionings can now (either one-by-one or
completely) be edited and supplied with tolerances.

-

The Import and Export Filters for DXF and DWG have been revised, they use a new library version. They now
support long layer names, proxy objects, layouts, and many previously ignored object types.

-

The plug-in “Auto Converter” now allows to create custom index files for any converted file based on
variables. This way, you can e.g. create SAP-compatible index files for all your drawings while converting them
to a standard archive format such as PDF or TIFF.
The auto converter no longer stops the conversion process with an error message if it encounters an “empty”
drawing file.

-

The plug-in “HP-GL/2 Import” is now able to handle PE commands (complex polygons) that are larger than
250 KBytes.

-

The plug-in “SVG Export” now correctly handles all type of referenced and embedded bitmaps.

-

The Open CAD Interface has been switched from a standard C interface to a C++ based interface. This made it
possible to realize intrinsic methods for basic types such as point, rectangle, and matrix as class-internal
methods and provide them directly to all plug-ins.
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CAD6 Release 2007 (May 2007)
Version of May 15, 2007:
-

The snapping function will now be automatically disabled in situations where it is obviously not required.

-

When opening files by double-clicking in the Explorer, the subsequent screen redraw could be extremely slow.

-

The Contour Tracking Curve and Contour Tracking Surface commands now handle “invalid” point entries
correctly by discarding them and displaying a temporary message.

-

The commands Draw > Line > Center and Construction Aid > Line > Center Cross now want a point entry first
instead of a circle or ellipse identification. This makes these commands more flexible.

-

The “Scale Line Widths” and “Scale Dimension Texts” options are now available directly in the Shape > Scale
Objects > Reference Line dialog.

-

When changing the scale setting in a coordinate system, not all dimensionings were updated automatically.

-

After selecting a different coordinate system, the screen display was not updated immediately in some cases.

-

It was not possible to divide or multiple-copy along a construction aid circle.

-

The Dimensioning > Angle, Line - Line command now switches the dimension extension lines off
automatically if the according edge is a construction aid line.

-

Tabulator distances with non-integer values such as 1.62 were not always handled correctly.

-

Some texts were interpreted completely wrong when importing WMF files. In additional, the position of the
text objects was incorrect in many cases.

-

Problems with clippings in the SVG export filters were corrected. The file header now conforms to the standard.

-

When exporting to bitmaps, the resolution information in the created bitmap was incorrect.

-

If editing texts using the “Font Size” formatting option, only the opening <size ...> control tag was created
automatically, but not the closing </size> control tag.

-

In the “Options > General” dialog, you can now choose between different screen display modes. Try a different
setting here if your crosshairs seems to be moving slow.

Version of May 4, 2007:
-

Opening of monochrome bitmaps was very slow and resulted in too much memory being allocated.

-

When importing a drawing, the values of variables were overwritten even if the “Add” file option was active.
Variables were only found if their name was matched exactly in case.

-

The display of small icons in the toolbox was very rough.

-

When saving an “empty” drawing, an error message appeared.

-

When opening a drawing in a version activated by means of a dongle, the error message “The file contains an
expired validity date” could appear in some cases.

Version of April 27, 2007:
-

New system requirements: CAD6 now requires Windows 2000, Windows XP, Windows Server 2003, or
Windows Vista. Older systems with Windows 95, Windows 98, and Windows ME are no longer supported.
Due to our tests, we recommend a computer with a dual-core processor (1 GHz) and 1 GB of RAM for working
with Windows Vista. For all older Windows versions, a simple processor (500 MHz) with 256 MB RAM will suffice.
The minimum screen resolution is 1024 × 768 pixels with a color depth of 24 bits and 32 MB of video RAM.

-

The screen redraw engine has been completely revised. The screen refresh is much smoother, and it offers
several new possibilities for interaction with the user.
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This has the main advantage that the window content is now buffered. As a result, no screen refresh is
necessary when switching between windows or even applications. The same applies to moving windows in front
of the application, which is now completely smooth and flicker-free.
Another advantage is being able to blend screen elements such as the crosshairs, the coordinate display, and
all kinds of messages for the user transparently over the drawing.
-

All newly created drawings now contain a preview that is displayed in the file selection dialogs. This makes it a
lot easier to find a specific drawing in a huge set of files.
This preview in the file selection dialogs is also available when opening and saving bitmaps.

-

The import and export of bitmaps has been completely recoded using Microsoft® image libraries. The import
speed has been increased, and some additional sub-formats are supported. The export now offers an automatic
smoothing option (“anti-aliasing”) that results in bitmaps with much more detail.

-

The CAM Part has been revised. Each CAM project can now be linked to a drawing. An additional, customizable
tool type has been added to the previous, predefined tool types. The postprocessor now has its own machine
unit setting. The internal procedures have been optimized.

-

The “DXF Export Filter” and “DWG Export Filter” plug-ins have been revised, they now use a new library
version. The handling of line types has been optimized.

-

The maximum number of variables in drawings has been increased from 100 to 1000. In addition, all access
functions to them have been optimized to increase the performance for drawings with many variables.

-

The external reference option “Use only elements from referenced file” now also applies to variables, i.e.
only the variables defined in the referenced drawing and their values will be used.

-

The monitor size setting (for a screen display true to scale) has been revised in order to automatically detect
and adapt to wide-screen displays. The maximum supported screen width and height has been increased from 1
meter to 10 meters due to larger display sizes.

-

The maximum number of concurrently administrated printers has been increased from 4 to 8 for even more
comfort.

-

The calculation of the Computer ID has been modified so that minor changes in the hardware will not result in
a different Computer ID. And if a new activation is necessary anyway, you now usually have a 5 days grace
period.
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CAD6 Release 2006 Service Pack 3 (March 2007)
Version of March 9, 2007:
-

The scale display could cause a program hang for extreme zoom factors above 100,000,000 : 1.

-

The “Print Drawing” dialog could be deadlocked with an invalid scaling factor of “0” if the number of
fractional digits was set too small in the current coordinate system.

Version of February 19, 2007:
-

Switching between printers did not work on some machines, and sometimes caused the program to crash.

-

The Auto Converter has been extended with bitmap export.

-

Even if the Dongle Server reports “out of licenses”, it is now still possible to save changes to avoid possible
data loss.

Version of January 16, 2007:
-

The selection filter criteria “Font Height” and “Text Rotation” could cause a crash with some kinds of text.

-

On Windows 98 and Windows ME systems, some of the CAD6 Studio and CAD6 Industry plug-ins did not start
correctly.

Version of January 8, 2007:
-

In Windows 98, ME, and 2000, the font display in some dialog windows was incorrect.

-

The “Zoom Views” plug-in caused a program crash if the program was terminated or the drawing was saved
after a new view had been created.

-

The “DXF Export Filter” and “DWG Export Filter” plug-ins have a new option allowing to suppress 24bit RGB
color use. This is necessary to support automatic adaptation to black and white background.

-

On some machines, the CAD6 Setup did not detect the “Program Files” directory correctly, and the file selection
dialog did not work.

Version of December 28, 2006:
-

CAD6 is now fully compatible with Windows Vista. Therefore, several improvements were implemented:
- All help files have been translated to compiled HTML format. This also allows better handling and printing.
- All installation and program files are now digitally signed. This way, you can check if downloaded files are
authentic, i.e. if they actually were created by us and are unaltered.
- All icons have been redesigned with transparency and an additional 48 × 48 pixels version.

-

The printing function has been extended:
- A new option allows to create one output file per printed sheet. This is especially useful when archiving
multi-page drawings.
- The direct PDF output now also works with Adobe Acrobat (in addition to eDocPrinter PDF Pro).

-

The Auto Converter has been completely revised. If now offers the possibility to print drawing files
automatically or to convert them to PDF files. This way, a complete project directly can the plotted or archived
in PDF files over-night.

-

Printing of large bitmaps in blocks or clippings sometimes failed.

-

Errors in the WMF and EMF import functions have been fixed, such of which could cause a program crash.

-

Now using the latest FreeImage library in version 3.9.2. It is now possible to import and export LZW
compressed GIF files. Some smalls bugs when importing bitmaps have been fixed.

-

All relevant documents were changed from 16% VAT to 19% VAT. They are valid from January 1, 2007.

Version History

55

CAD6 Release 2006 Service Pack 2 (October 2006)
Version of October 26, 2006:
-

The generation of surfaces (also during hatching) and other surface operations could work incorrectly if
circular arcs with huge radii were involved. Problems could also occur if multiple outlines were generated
simultaneously.

-

The word wrap in frame texts did not work correctly if these texts contained positioning information.

-

Changing the text properties (color etc.) using tags could cause unwanted spacing within the text.

-

The setup program has been revised. It no longer offers a client/server installation mode.

Version of October 11, 2006:
-

When editing dimensionings using the Lettering > Edit Dimension commands, the changes were not visible
until those dimensions were modified again (e.g. moved), or the drawing was reloaded.

-

Frame Texts with formatting commands such as <dy -.5> were not output completely.

-

The default layer for equidistants was not always assigned correctly.

-

The Milling Cutter Compensation command in the CAM Part did not work correctly with circular arcs.

-

Copy and Paste via clipboard did not work properly and could cause the program to crash.

-

The creation of indexes of large libraries (e.g. at program start) is much faster now.

-

Block-based line patterns were partially not printed.

Version of October 2, 2006:
-

The “3D” plug-in has been extended:
- The new “Standard Parts” command allows to create 18 different, frequently used standard parts such as
cuboid, cylinder, pipe, and sphere parametrically. All parameters of these standard parts can be edited
numerically afterwards.
- The new “Orbit” function allows to rotate the current 3D space freely using the mouse while executing another
command (similar to the “Zoom > Section” command in 2D). Analogously, selected components can be rotated
freely in 3D space using the mouse.
- The selection of edges and corner-points in 3D components has been revised. It is now possible to snap endpoints of rotation axes and paths. Furthermore, markings can be used to creation auxiliary axes in extrusion
objects onto which other components can be placed alter on.

-

The printing function has been revised and extended:
- Four different output devices can be defined and saved including their corresponding settings. This way, you
can easily switch between different device settings for specific tasks such as laser printing, plotting, PDF
export, faxing, etc.
- The new printing mode “Adjust paper size” automatically selects a paper size large enough for the complete
drawing.
- New output options allow different modes of printing to file, especially for simple PDF export.

-

Loading of large MKD drawings and libraries has been accelerated by up to factor 2.

-

When using the Library > Replace Block Name command, you can now enter the source library and block name
directly in order to replace blocks that do not longer exist. When replacing library or block names, the number
of successful replacements will now be displayed afterwards.

-

The Trimming > Transform Objects to > Circular Arc always created a segment instead of an arc.

-

The Keyboard and Toolbox assignment is now being saved in a new format that maintains links to plug-in
commands even if the number and/or order of the plug-ins changes.
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-

When working with Yard / Foot / Inch as length unit, some rounding errors occurred (such as 13'12" instead
of 14'0"), and the display of such values in dialog windows sometimes did not handle scales different from 1:1
correctly.

-

The “DXF Export Filter” and “DWG Export Filter” plug-ins have been revised. They can now natively write DXF
and DWG files up to Version 2007. Bitmaps can be exported, Texts with formatting information will be converted
more precisely.

-

The “DXF Import Filter” and “DWG Import Filter” plug-ins have been revised. They now support DXF and DWG
formats up to Version 2007. Files, especially with lots of huge polylines and splines, are loaded much faster (up
to factor 20). Bitmaps can be imported.

-

The “HP-GL/2 Export Filter” plug-in has been revised. Texts with formatting information will now be
converted more precisely.

-

The “SVG Export Filter” plug-in has been revised. Texts with formatting information will now be converted
more precisely.
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CAD6 Release 2006 Service Pack 1 (July 2006)
Version of July 18, 2006:
-

The “3D” plug-in has been completely revised and extended:
- The new component types “Rotation” and “Path” allow to create almost any standard part:
Sphere, Cylinder, Cone, Pyramid, Pipe, Elbow, Channel, Spiral, Helix, Spring, etc.
- 25 new manipulation commands (moving, scaling, rotating, aligning).
- In all cases where points or values have to be defined in 3D space, a numerical coordinate entry with values
in 3D space is available via F8.
- Single components may now penetrate each other arbitrarily.
- The recalculation of 3D components has been accelerated by another factor 4 and more.

-

The selection filter can now also filter for specific, extended object types (e.g. 3D components, color
gradients, texts on path, incremental dimensions, etc.).

-

The additional dimension texts (pre-text, middle-text, post-text, tolerances) can now be multi-line texts. The
ALT+T combination for inserting a TAB character now also works inside the dimension text dialogs.

-

The “DXF Export Filter” and “DWG Export Filter” plug-ins can now optionally export 3D components.
Therefore, a new export option has been introduced that allows to switch between 2D and 3D export. In
addition, all colors will always be exported as 24-bit color values, too.

-

The “DXF Import Filter” and “DWG Import Filter” plug-ins can now read 24-bit color values and additional
line width information. In the plug-ins’ options, the setting “Ignore Empty Texts” could not be changed.
Furthermore, it is now possible to choose whether the filter may adapt the program’s display settings for
optimum display or not.

-

When exporting to WMF files, surfaces with filling mode “Eraser” were sometimes exported in black (instead of
white).

-

When cleaning up coordinate systems, those systems referenced only by page frames were accidentally
deleted.
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CAD6 Release 2006 (May 2006)
Version of May 12, 2006:
-

The Trimming > Trim Object > Resolve Completely command now has a set of options that control how farreaching the chosen objects will be resolved. Dimensions and text objects can now also be resolved.

-

The recalculation of 3D components in the “3D” plug-in has been accelerated by factor 2 and more.

-

The colored highlighting of filled surfaces and compressed texts did not work during a search.

-

When exporting objects with wide lines and line patterns (e.g. to a WMF file), the partial line lengths were
not calculated correctly.

-

The “DXF Export Filter” and “DWG Export Filter” plug-ins could create invalid files if the original files
contained layer or line types with invalid or duplicate names (e.g. starting with a “*”).

-

In the “DXF Import Filter” and “DWG Import Filter” plug-ins, the options for handling duplicate layers and
line types were revised and unitized.

-

References to bitmaps located inside external libraries were partially not resolved immediately after loading,
but only after the block was manually re-inserted or modified.

Version of May 5, 2006:
-

The “DXF Export Filter” and “DWG Export Filter” plug-ins could enter a endless loop if several different fonts
were used in texts.

-

The “DXF Import Filter” and “DWG Import Filter” plug-ins can now open drawings that define more than the
CAD6 maximum of 2,000 layers or 1,000 line types. All references to surplus layers and line types will be
modified, a warning is displayed.

-

The uninstall program forgot to delete the CAM setting file “mkcam1.cpd”, resulting in the base directory
“mkcad6” not being deleted during uninstall.

Version of May 2, 2006:
-

The new CAD6 Navigator offers an even simpler first entry to CAD6. At each program start, the Navigator
window offers some of the most frequently used commands to start with for the user to select from. Besides
opening and creating drawings, the Navigator allows to browse through the sample drawing with a preview, and
offers a direct link to the CAD6 Tutorial and the CAD6 Reference.

-

The new Trim > Notch Corner and Trim > Notch Edge commands offer all essential functions required to create
notchings as used especially in sheet metal forming.

-

The completely new “3D” plug-in replaced the previous “3D Perspective” plug-in. In addition to the previous
projection functions, it now offers “real” 3D components in 3D space with lighting effects.
All 3D components are created from 2D objects and remain visible in 2D space, but are editable in 3D space.
Multiple concurrent 3D spaces allow working with different models at a time, and the 3D components can at any
time be resolved into 2D objects.
A new toolbar offers direct access to essential functions of the 3D plug-in.

-

Using Configuration > Options > Windows, you can now determine in detail which buttons shall be displayed
in the Property Window and in the Panel. Also new is the possibility to have a Page Frame button in the
Property Window, and to display Pen and Layer buttons simultaneously in the Panel.

-

It is now possible to include hyperlink texts into any text search or selection filter criterion. In addition, it is
possible to restrict the text search to visible objects.

-

The maximum text length in text objects (standard text, frame text, reference text) has been increased from
8,000 characters to 32,000 characters.

-

The Trim > Clipping > Resolve command now allows to select and resolve multiple clipping at once.
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-

For dimensionings, it is now possible to enter a negative distance of the dimension extension lines to the
object so that they intersect the object.

-

When creating new layers, these layer were not by default marked as “printed” in the existing page frames.

-

CAD6 will search for Online News from the CAD6 website once a day and display any available news to the user
unless this option is deactivated using the CAD6 Online Update command.

-

The search for CAD6 updates using CAD6 Online Update will only be performed if a connection to the Internet
is already established.

-

The “DXF Export Filter” and “DWG Export Filter” plug-ins have been completely revised. They can now
natively write DXF and DWG files in R14 format, which is up to 2× faster than before. Inheritance and filled
surfaces are converted much better. Further available export formats are R12 and R15.

-

The “DXF Import Filter” and “DWG Import Filter” plug-ins have been completely revised. They now support
DXF and DWG formats up to Version 2006, and read up to 2× faster. Hatchings and filled surfaces are converted
completely.

-

The “HP-GL/2 Import Filter” plug-in has been revised. It now supports the PE mode 9 (“rectangle mode”)
used especially by modern plotter drivers, can convert the input window (command IW) to a clipping surface,
and can handle additional rectangle (EA, ER, RA, RR) and wedge (EG, WG) commands.

-

In the “Dimensioning” plug-in, the later editing of standard object properties (Layer, Pen, etc.) did not work
properly, the original properties were not permanently overwritten and partially reinitialized when loading the
drawing. Editing the text component properties was not possible at all.
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CAD6 Release 2005 Service Pack 2 (December 2005)
Version of December 2, 2005:
-

From now on, two new editions of CAD6 are available: “CAD6 Industry” and “CAD6 Studio”.
CAD6 Industry is the comprehensive CAD/CAM solution for industrial use. It includes all functions, all plugins, the CAM part, and a universal, script-based postprocessor for flexible and powerful NC programming.
CAD6 Studio includes all kernel functions and all essential plug-ins for planning, construction, and design;
especially import and export filters for DXF, DWG, and HP-GL/2, plus export filters for SVG and bitmaps.
As a result, the previous editions “CAD6 Workstation CAM” and “CAD6 Workstation“ are no longer available, all
affected licenses will be converted to the new editions automatically.

-

The formatting options for statements in texts have been extended by some options for floating point,
exponential, integer, hexadecimal, and binary numbers.

-

The Trimming > Trim Objects > Automatic Cutout command did not work correctly with circles and ellipses, it
always removed the opposite arc.

-

When opening a drawing that contained the ~%X3~ variable (number of used external blocks), the program
could crash in some cases.

-

Block-based line patterns using external block from libraries were not correctly converted when using File >
Miscellaneous > Archive Drawing or Library > Convert External Blocks.

-

When generating surfaces using Trimming > Surface / Curve > Generate Surface, block-based line patterns
where regarded as potential contour element, making the result unusable in most cases.

-

When importing bitmaps with the “Embed into the drawing” option, the name of the bitmaps was not
created right, resulting in all bitmaps having the same name. Therefore, the first bitmap was displayed at all
instances.

-

When loading old T4G files, all page frames were erroneously assigned to the coordinate system “*Standard”,
causing the program to switch to this coordinate system once Zoom > Active Page was called.

-

In the “Table” plug-in, the default settings for “Automatic Cell Width Adaptation” and “Automatic Cell Height
Adaptation” were not correctly applied to new tables. Furthermore, the cell size calculation was too tight in
some cases, resulting in unnecessary word wraps and missing last lines.

-

In the “Dimensioning” plug-in, the Resolve Dimension command did not work.

-

The options for Import/Export of DXF and DWG have been revised and extended.

-

In the CAM Part, the Milling Direction > Set to Left-Oriented and Milling Direction > Set to Right-Oriented
commands now also apply to single lines and zigzag lines.
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CAD6 Release 2005 Service Pack 1 (October 2005)
Version of October 12, 2005:
-

It is now possible to search for texts in all text input fields. The standard search is started by means of the
CTRL + F key combination. Using F3 and SHIFT + F3, the search is continued in forward and backward direction.
For detailed information, please refer to the new chapter “Text Input” in the reference.

-

When creating a NC program using a postprocessor, the scale and rotation of the current coordinate system
will now be taken into account. Furthermore, you can now force empty lines within the NC program.

-

The following new postprocessors have been extended or added:
Universal DIN-ISO
Siemens DIN-ISO (Milling) and Siemens DIN-ISO (Turning) with the SINUMERIK 8XX controller
Heidenhain DIN-ISO (Milling) and Heidenhain DIN-ISO (Turning) with the TNC 4XX controller
Heidenhain Plaintext (Milling) with the TNC 4XX controller
- Minimal HP-GL (using PU and PD only)

-

When adding a new block to an external library, already existing references to this library in the drawing
could temporarily (only until program restart) point to the wrong blocks.

-

Some trimming commands could cause undefined system behavior and sometimes even a crash when used with
complex curves or surfaces (with about 100 contour elements or more).

-

When copying text objects to the Clipboard, or exporting them to EMF or WMF files, the control text <fill> had
no effect on the text’s color.

-

Opening a non-MKD-file by double-clicking sometimes caused the DWG or DXF import filter to display an
unwanted error message dialog, making the automatic file type detection impossible.

-

If the list of least recently input texts (see the new chapter “Text Input” in the reference) exceeded about
500 characters, it was accidentally cleared when restart the application.

-

On computers with a dial-in connection, a connection was in some cases established even if the CAD6 Online
Update was deactivated.

Version of September 30, 2005:
-

When opening a drawing that contains references to blocks that are no longer available in an existing library,
it was possible that CAD6 ended in a permanent loop.

-

When opening a drawing that contains “empty” blocks, is was possible that CAD6 crashed.

-

The following new postprocessors have been added:
Heidenhain DIN-ISO (Milling) with the TNC 4XX controller
- DATRON milling machine CAT3D
In the universal postprocessor, the variables ~Q200:~ to ~Q399:~ and ~T20:~ to ~T39:~ were not initialized
with the comment on the Q and T variables, but with their values.

Version of September 28, 2005:
-

The new CAD6 Online Update command allows you to check online whether updates for the installed CAD6 are
available, and if they can be used with the current license. In addition, all required files are offered for
immediate download. This works without any data from your computer being transmitted to the Internet!

-

The new object type “Hyperlink” allows to insert links to other files or URLs into a drawing. The hyperlink
object itself is based on a surface and can be filled, framed, or both. It is also possible to create invisible
hyperlinks. Once the crosshairs are above a hyperlink, its target is displayed and the hyperlink can be activated
by pressing ALT + Left Mouse Button.

-

The new Construction Aid > Contour Tracking Curve and Construction Aid > Contour Tracking Surface
commands allow to easily track simple and complex contours in the construction aid with a few mouse clicks,
either as curve (i.e. an open contour) or as surface (i.e. a closed surface).
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-

Texts, dimensionings and variables can now contain instructions and conditions. Those are enclosed by curly
brackets and allow to include conditional texts, combined texts, and the results of mathematical terms within
any kind of text. Please refer to the chapter “Text Formatting and Unicode” in the CAD6 reference for details.

-

Texts, dimensionings and variables can now contain the new control codes <fill>, <line>, <mode>, and
<width>. They can be used to control the filling color, line color, filling mode, and line width of the text
locally. All control codes can either be entered manually or by means of the “Format >” button in all text
editing dialogs. Please refer to the chapter “Instructions and Conditions in Texts” in the CAD6 reference for
details.

-

The new serial printing option allows to print a drawing multiple times based on a serial printing database. To
support this option, the new variables ~%n0~ through ~%n3~ have been introduced.

-

In addition, the new printing rules allow to modify variables each time a drawing has been printed. This allows
to handle serial numbers or unique print job numbers.

-

The CAM Extension has been completely revised, it now supports cycles. The new, script-based universal
postprocessor allows the user to create custom postprocessors without having to actually code. And the new
CAM project files make it possible to save and load the complete settings of CAM Extension and Postprocessor
in a single file, making it simple to switch between different machines.

-

The new variables ~%d3~ through ~%d8~ allow to use the components of the current date and of the current
time separately.

-

The new variables ~%v0~ and ~%v1~ for dimension values allow to calculate directly within dimensionings,
and to use conditional texts. You can e.g. define a pretext that will only show if the dimension value if larger
than a specified value.

-

Due to unnecessary calculations, the Coordinate Entry dialog took quite some time to display if a huge number
of objects were present. Those calculations are no longer performed, so that the dialog appears instantly.

-

For the Edit > Find Properties command, the optical highlighting of the respective object found did not work.
When closing the dialog, a message always stated that the search was not successful, even if it was.

-

The highlighting of the respective object found at Edit > Find Text and Edit > Find Properties has been
changed to use as far as possible the original zoom factor that was active when the search started.

-

The Library > Convert External Blocks command was without function.

-

The Library > Clean Up Internal Block List command deleted blocks that were only used in block line types.

-

When using the File > Miscellaneous > Archive Drawing command, some unnecessary blocks from external
libraries where stored in the archive.

-

The Trimming > Surface / Curve > Combine Outlines command now also works with “open” objects and
curves.

-

The Draw > Regular Polygon > Side Length - Center command did not work correctly in CAD6 Economy.

-

The determination of used layers and pens (e.g. when cleaning up or at the management functions) ignored
all layers and pens that were used only in instances.

-

In some cases, the “Edit Pens” Dialog and the “Edit Layers” Dialog did not display the folder names.

-

The priorities of the snapping modes have been rearranged so that snapping edges, center-points and
quadrant-points have a lower priority than intersections, corners, marking, etc.

-

The “Construction Aid in Background” option is now also effective for printing.

-

When cleaning up coordinate systems in the corresponding dialog, and choosing to immediately delete the
unused coordinate systems, a rather random set of coordinate systems was deleted. The selection of unused
coordinate systems, however, was correct.

-

CAD6 now supports the two additional mouse buttons available on many modern mice. Check Configuration >
Options > Mouse/Keys for options.
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-

In the toolbox window, the mouse button pressing time required to show the additional submenu was 0.15
instead of 0.3 seconds, making it appear too easily.

-

The “Edit Geometry Data” plug-in did not work correctly when editing the length or angle of a simple line.

-

In the “Table” plug-in, the highlighting of the selected row / column / cell did not properly. The automatic
height and width calculation was too tight, sometimes cutting the text.

-

Many plug-ins did not assign the current layer and current pen to newly created objects.

-

A new version of the USB Dongles and the according handling in CAD6 allows you to use these dongles
without having to install a special driver. This makes the use of the dongles much simpler.
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CAD6 Release 2005 (April 2005)
Version of April 28, 2004:
-

The Draw > Regular Polygon > commands did not work correctly with triangles.

-

When saving a drawing that contained groups not being used, it was possible that more than these unused
groups were excluded from saving (and where thus lost).

-

When opening drawings that contained dimensionings that were not to be updated, they were updated
anyway, overwriting the original content.

-

When editing dimensionings by means of the Lettering > Edit Dimension > commands, the result was not
visible immediately, but only after the objects was e.g. moved or saved and reloaded.

-

When opening drawings with underlined texts, the program reported the according font as “missing” although
it was in fact available.

-

In some Windows 95 and Windows 98 installations, the improved file selection dialog did not work.

-

All skins except the Windows XP skin had misaligned icons.

Version of April 18, 2004:
-

From now on, users of multiple licenses can use a free Dongle Server software. This is a program that runs on a
single computer in the local network, using a single or multiple dongles. All instances of CAD6 request their
licenses from this dongle server.
As a result, it is sufficient to have a single dongle with the corresponding number of licenses to run multiple
licenses in a local network environment. But you may, however, distribute you licenses over multiple dongles to
be more flexible. For instance:
A company owns 5 licenses for CAD6. Usually, all 5 licenses are used at the company headquarters, so all CAD6
versions installed there use the dongle server. Two field representatives, however, often need to use a license of
CAD6 on their notebooks without having access the company’s local network. In this case, it is best to order
one dongle with 3 licenses and two dongles with one license each.
Since the dongle server is capable of handling several dongles simultaneously, all 5 licenses can be offered
company-wide, if necessary, by connecting all three dongles to the dongle server.
Site licenses, campus licenses, and classroom licenses now include one free USB dongle that contains all
purchased licenses and that can be connected to the dongle server. Therefore, it is no longer necessary to
activate a huge number of computers manually.
The technical requirement is that all computers that want to license CAD6 via the dongle server must have a
TCP/IP connection to the computer running the dongle server, and must at least run Windows 2000 or Windows
XP. The dongle server requires very little CPU time and resources, so it can easily be installed to an arbitrary
workstation running Windows 2000, Windows XP or Windows 2003.
The dongle server software itself is free of charge, and can even be used with a dongle containing “only” a
single license.

-

Along with CAD6 Release 2005, a new price structure has been introduced. The prices for buying licenses
(single, additional, and site licenses) have been raised by up to 20%. As a compensation, the prices for leasing
licenses and for Support & Updates renewals have been reduced by up to 31%. Furthermore, it is now possible
to renew at a lower price once Support & Updates has expired.
The prices for educational licenses (single, classroom, and campus licenses) have not changed, the
corresponding prices for Support & Updates have been reduced by 40%.
For detailed prices and conditions, please refer to the latest Malz++Kassner Product Information.

-

Also along with CAD6 Release 2005, the new License 60+ has been introduced. Similar to the educational
license, users at the age of 60 years and above can purchase and use CAD6 at educational conditions. This
explicitly excludes any commercial use!
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Drawing References allow to use external drawing files similar to blocks in a drawing. Using these references,
it is very easy to create overview drawings out of multiple detail drawings, or to create complex standard parts
that shall not be organized in libraries.
All information in the referenced drawing is available, including information about layers, pens, line patterns,
and coordinate systems. Usually, these element can be mapped to the current drawing’s elements. Use the “Use
only elements from library” option to avoid this.
Construction aid objects in the referenced drawing can be selectively hidden by means of the “Don’t display
construction aid” option.

-

The new Find Text command allows to search arbitrary texts throughout the current drawing. The search is
highly flexible since it can also find texts in attributes, block names, library names, dimensionings, and font
names. The result of the search is highlighted in color.
If, during the search, a command is active that expects an object selection, the respective search result can be
selected using a button. In cooperation with the extended selection (or pressed CTRL key), multiple objects can
be selected successively by direct clicking and different successive searches.
The text search is available in all editions, even in the CAD6 Viewer. As a result, your customers can easily
browse your drawings for specific items or elements.

-

The new Find Properties command allows to search for arbitrary properties or property combinations
throughout the current drawing. The property search can handle a combination up to 5 different search criteria
which can each consist of multiple single values or intervals. You can e.g. chose an arbitrary number of layers,
pens, line patters, or coordinate systems within the scope of one criterion. So you can e.g. search for all
dimensionings that are assigned to either layer “Detail A” or layer “Detail B”.
One criterion of the property search can be a text search, so that you can e.g. search all texts that use the
“DINDRAFT” font in size “5.0 mm” and that assigned to the layer “Lettering”.
If, during the search, a command is active that expects an object selection, the respective search result can be
selected using a button. In cooperation with the extended selection (or pressed CTRL key), multiple objects can
be selected successively by direct clicking and different successive searches.
The property search is available in all editions, even in the CAD6 Viewer. As a result, your customers can easily
browse your drawings for specific object sets.

-

The former Selection Filter has been replaced completely by a new one based on the property search. As a
result, all combination possibilities of the property and text search (see above) are now available to the
selection filter.
To honor the increased power of the selection filter, the maximum number of saved filters has been increased to
50.

-

The management of page frames has been revised. The new Page Frames > Edit command offers a central
dialog in which all essential page frame settings can be edited. In addition, page frames can now have a
comment, making it easier to work with complex drawings containing many page frames.
The number of predefined page sizes has been extended by some smaller DIN sizes.

-

The Printing Dialog has been redesigned, it is now more clearly arranged.
A new “Page Size Offset” option has been added for printing in the “Page Frames” mode. The constant page
size offset will be added to the page size defined in the drawing. This allows to choose between printing a
drawing to a printer with or without a non-printable margin, without having to adapt the page size settings.

-

A new option is the dynamic display of coordinates and information texts at the crosshairs. This way, you
have all the information your need at the right place. Beginners might want to display all information
(including guiding texts and current input), whereas experienced users might display only the current
coordinates.
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The numeric coordinate entry (F8) is now done in a dynamic dialog that appears at the current crosshairs’
position. This is much easier to handle than the direct editing in the status window. The fundamental
functionality of the coordinate entry did not change.

-

When opening a drawing or library, CAD6 automatically checks if all elements required by the drawing or
library are available at the moment. This check includes whole libraries, single external blocks, drawing
references, bitmap files, and font types.
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If elements are not available, a dialog appears. It lists all missing elements in detail, and gives some advice on
how to make these elements available.
-

The library handling has been improved. It is now possible to explicitly copy elements such as layers, pens,
and line patterns from the current drawing to a library. Elements no longer used within a library can be deleted.
When copying blocks between libraries, all required elements will now automatically be copied, too. The
handling of extremely large libraries with a huge amount of texts has been sped up by factor 10 and more.

-

Block Instances now have the “Use only elements from reference file” and “Don’t display construction aid”
options (analogous to the new drawing references, see above).

-

All objects that directly or indirectly contain texts (standard texts, block instances, bitmaps, and drawing
references) have got the new “Adapt rotation / scaling to currently active page frame” option. This allows
to create objects and blocks that have a predetermined behavior when used in rotated and/or scaled page
frames, e.g. always display horizontally or vertically.

-

The snap result can now optionally be display directly inside the drawing window (along with the resulting
coordinates, if requested). The display period is adjustable.

-

The Configuration > Options > Paths dialog now offers a list of up to eight “project directories”. These project
directories will be searched whenever a referenced file (such as drawing reference or bitmap) cannot be found
at its original location or other standard paths. This search includes all subdirectories!

-

The list of predefined monitor sizes at Options > General > Monitor has been extended by several new standard
monitor sizes (TFT displays, 16:9 displays).

-

Three new variables are available:
%p8
- Comment of the page frame (this object lies in)
%z5
- File name of the drawing (without path and extension)
%x4
- Number of used bitmaps

-

The CAM Extension has been revised and extended by several new commands:
- A complete set of objects can now be sorted according to their position so that they are displayed (and thus
output to the machine) from top to bottom, from left to right, or vice versa. This allows a simple and fast,
significant milling time reduction.
- The orientation of a complete set of objects can be automatically set to “left-oriented” or “right-oriented”.
- All settings concerning tools, cycles, and global parameters can now be stored centrally to CAM Projects which
can reloaded at a later time.
- A possible Z-infeed is now also displayed in the post processors’ preview window.

-

The DXF and DWG import/export filters have been revised to fix several minor problems.

-

The “Lettering” plug-in did in some cases display the “ISO 1302” object type incorrectly when the “A” field
was empty.

-

The saved position of the overview window has not been interpreted correctly upon start of CAD6, resulting in
the overview window always being displayed in the upper left corner of the monitor in minimum size.

-

CAD6 Release 2005 does no longer officially support graphics cards with a color depth of 8 bits and less. The
new system requirements state a minimum of 800 × 600 pixels and a color depth of 15 bits (32,768 colors), we
recommend 1280 × 1024 pixels.
The program will, however, still run on standard VGA graphics cards, but with some limitations.
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CAD6 Release 2004 Service Pack 2 (November 2004)
-

From now on, you can choose between two licensing models when purchasing CAD6:
- The CAD6 buying license is available for all editions of CAD6. With a buying license, you acquire the right to
use the product indefinitely. Additionally, each buying license includes 12 months of Support & Updates.
- The CAD6 leasing license is available only for the products CAD6 Workstation and CAD6 Workstation CAM (each
as single, additional, and company license). With a leasing license, you acquire the right to use the product for
24 months. Additionally, each leasing license includes 24 months of Support & Updates. For commercial users,
the leasing license is even available with payment by installments.
For further information on the licensing models, please refer to the current CAD6 Product Information.

-

In the CAM extension, the preview dialog now acts as a command center that allows calling the milling
program, exporting the data to a preset output file, and viewing the output file in a text editor. In addition to
the graphical preview, the corresponding, absolute milling position in output coordinates is displayed
numerically. If CAM commands (such as the working cycle “G81”) are inserted as blocks from a CAM library,
these will be displayed in the preview window as uniform symbols along with the block name. Additionally, the
workpiece coordinate origin is now displayed in the preview.

-

The HP-GL/2 import filter had problems with extremely large polygons (more than 10,000 vertexes). In
addition, some inconsistencies in the handling of scales were fixed.

-

Both the HP-GL/2 export filter and the HP-GL/2 3D (MultiCAM) postprocessor now offer the option to
choose “1 mm” as output unit.

-

Both the G-Code (DIN 66025) postprocessor and the NCP (isel intermediate format) postprocessor now
offer the option to export either the X or Y coordinate as Z coordinate.

-

Under certain circumstances, the “Texture / Color Gradient” plug-in could create empty clippings that were
only visible at specific views, and that were not easy to handle.

-

The SVG Export had problems with integrated bitmaps.

-

If bitmaps were integrated that had already been integrated before, but had changed meanwhile, then in
some cases the old bitmap’s state was saved as integrated bitmap.

-

In the Help > Activation / Dongle dialog, the “Activate” button was sometimes not available although a valid
activation key had been entered.

-

When printing to a file, CAD6 now displays a warning if the output file already exists.

-

The six new variables “%s2”, “%s3”, “%p4”, “%p5”, “%p6”, and “%p7” can be used to display various
information about page frames.

-

When editing the properties of multiple instances or bitmap references, you can now modify the values for
horizontal scaling, vertical scaling, rotation, and distortion independently.

-

An “empty” line pattern without partial lines and block references was always remove when cleaning up line
patterns, no matter if it was used.

-

All objects created by the “Lettering” plug-in were assigned to layer “*Standard” and pen “*Standard”,
without regarding the current settings. By mistake, surface tolerances (not perpendicular) were already drawn
to the internal coordinate origin.

-

The hiding of layers during output using page frames did not work for the first page.

-

When inserting a block into the drawing, its local attributes were in principle not copied to the drawing, no
matter if the according option was set.

-

When using the activated application without a dongle, a CPU usage of 99% was displayed while the system
was still behaving normally.

-

The use of layers, pens, line types, and coordinate systems in libraries only worked for changeable libraries.
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-

An activation key entered by the administrator was sometimes not detected when the application was
subsequently started by another user.

-

Some printer driver settings were not applied correctly, instead the default settings were used.

-

When printing rotated page frames, the pages’ content was partially offset by ¼ to ½ of the pages’ size.

-

When using the coordinate system setting “*Current” in dimensioning parameters of a drawing, it was always
reset to “*Standard” when reloading the drawing.

-

If Support & Updates had expired before Service Pack 1 was released, and the Service Pack was installed
despite the installation program’s warning, the application detected this correctly, but displayed a message that
did not give any hint on why it was no longer fully operational. This message has been improved.

-

When using internal fonts (e.g. “DINDRAFT”), some special characters where no longer displayed.

-

The DXF and DWG import filters had problems with “empty” hatches - now they are correctly ignored. Another
problem occurred with frame texts: The line distances were partially twice as large as stated, and the last line of
a frame text was sometimes exported twice.

-

The positioning of tolerances in dimensionings was wrong.

-

By mistake, the previous version included an outdated edition of the Reference and the User’s Manual.

-

The setup program now checks for paths being too long (> 260 characters).
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CAD6 Release 2004 Service Pack 1 (September 2004)
-

The new command File > Open in New Window can be used to open the specified drawing in a new instance of
CAD6. Accordingly, the drawing list now offers the option to open a file in a new window.

-

The new command Shape > Move Points > Set to Position Grid allows to align a set of points to the current
position grid, i.e. each point will be moved to the closest position grid point.

-

Page Frames have been extended. They now offer the following, new options:
- Each page frame can be assigned to a coordinate system which will automatically be activated when displayed
the specific page frame, and from which the rotation angle will be applied to the page frame.
- When printing in „Page Frames“ mode, the size of the page frame can optionally be used to select a fitting
form size from the printer.
- And finally, layers can be hidden during printout in order not to print parts of the model when printing
specific page frames.

-

In order to better support working in rotated page frames and coordinate systems, the Configuration > Zoom >
Area and Configuration > Zoom > Page commands have been revised to fully adapt to this rotation, thus using
a non-rotated rectangular on the screen. Same applies to area selection.

-

When importing MKD files, layer settings, or pen settings, you now have the choice between three different
import modes for elements: “Replace” (replacing all elements), “Merge” (Updating existing, adding non-existing
elements), and “Add” (only adding non-existing elements).

-

When creating texts (Lettering > Text > Standard and Lettering > Text > Reference), a preview is visible
while placing the text. The same applies when creating coordinate dimensionings.

-

Text formatting in text objects, dimensionings, attributes and variables has been extended by the <frac> ...
<sep> ... </frac> tags that can be used to display inline fractions.

-

The File > Miscellaneous > Autosave command now offers the additional option to autosave to a specified
directory.

-

The system menu of the Toolbox Window now features the “Small Icons” option that reduces the command
icons’ size from 40×40 pixels to 24×24 pixels.

-

Configuration > Layers > Defaults and Configuration > Pens > Defaults now both feature an entry for
equidistants.

-

Libraries can now contain their own set of pens, line patterns, layers, and coordinate systems. When
creating a block without the „Resolve Properties“ option set, all pens, line patterns, layers, and coordinate
systems used by the block will automatically be copied to the respective library unless they already exist.
When later inserting this block into a drawing, all pens, line patterns, layers, and coordinate systems used by
that block will automatically be copied back to the drawing unless they already exist. This process assures that
the block’s structure is maintained in any drawing.

-

The Library > Block > Insert dialog now offers the „Resolve Block Immediately“ option that results in the block
being resolved into its parts once inserted.

-

CAD6 now knows the “-w” command line switch (or “/w”), followed by four comma-separated values that
specify the position and size of the main window. “-w50,10,800,600” e.g. means that CAD6 is displayed on the
screen at coordinate (50,10) with a width of 800 pixels and a height of 600 pixels.

-

The Status Window display has been moved to its own process. As a result, the display is now regularly being
updated, even during time-consuming operations. Especially the memory requirement is already updated during
operations such as loading or copying.

-

The “Lettering” plug-in had an error in the object property handling - after reloading a drawing, all objects of
that plug-in were always reassigned to the standard layers and pens.
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-

The DXF and DWG import/export filters have been revised, mainly in order to speed up the import of complex
DXF and DWG drawing files, but also to fix some minor problems.

-

Now using the latest FreeImage library in version 3.4.0. It is now possible to import LZW compressed TIFF
files and GIF files. Furthermore, TIFF files (optionally compressed) can now be exported. Some smalls bugs
when importing bitmaps have been fixed.

-

The hardware key (“dongle”) handling has been modified to allow reinserting the dongle after removing it to
reactivate the application later on without having to restart the application.

Version History

72

CAD6 Release 2004 (June 2004)
Version of June 4, 2004:
-

If the Layer and/or Pen dialog was open when exiting the program, they were not displayed again upon restart.
They could then only be displayed by switching them off and on again my means of the Configuration >
Options > Windows command.

-

When using the “Simplified Display” mode in the overview window, the line types used actually in the drawing
were accidentally overwritten with a standard line type.

-

When emptying the input history during coordinate input, the confirmation prompt occasionally appeared
multiple times.

Version of June 2, 2004:
-

For activation of CAD6, an optional hardware key (“dongle”) is available now. When using the dongle, you
are free to install CAD6 on multiple computers (at the office, at home, on the notebook) and use it at any one
time on that computer which has the dongle installed. A computer-specific activation key is no longer required
if you use a dongle!
For further information on the dongle, please refer to our latest product information, or call us!

-

By using the new Library > Databases command it is now possible to directly access files that contain database
content in ANSI text files, such as database tables or Excel sheets exported to text files. The content of such
databases can directly be used by means of variables in texts, but also indirectly by plug-ins such as the new
“Table” plug-in (see below).

-

The new “Table” plug-in allows easy and fast creation of tables that are fully editable. The content of the
tables can either be entered manually or be imported from databases.

-

In all edit fields, a history of the previous entries (up to 8000 characters) is available now. In single-line edit
fields, it is called by pressing the “Arrow Down” key, in multi-line edit fields, it is called by pressing the CTRL +
“Arrow Down” key combination.

-

In all edit fields expecting numeric input, it is now possible to use variables defined in the current drawing.

-

In all edit fields, the current input can be evaluated numerically without closing the dialog. In single-line
edit fields, the evaluation is started by pressing the “Arrow Up” key, in multi-line edit fields, it is started by
pressing the CTRL + “Arrow Up” key combination.

-

The DXF and DWG import/export filters have been revised, as a result it is now possible to import AutoCAD
2004 format.

-

When exporting EMF files (also to the clipboard), you can select the “Resolve Line Patterns” options (see
Configuration > Options > File Options).

-

The File > Miscellaneous > Archive Drawing command did not archive external blocks used in block-based line
patterns.

-

If the “Point Markings” option is set at Configuration > Drawing Settings > Screen, those points lying in
ignored layers are now displayed in gray.

-

When entering color values via RGB value, you can now choose between entering percent values (0..100) or
internal units (0..255). In addition, the color selection dialog has been enlarged to make its easier to use.

-

In the Configuration > Pens > Line Patterns dialog, you now have the option to clean up the line patterns
(the same function is already available for layers and pens), i.e. to automatically remove all currently unused
line patterns.

-

If the number of line patterns was very large, they could not all be selected from the respective selection lists
since those lists were limited to at most 50 entries.

-

The commands Trimming > Trim Object > Trim / Cut Out, Trimming > Trim Object > Split, and Trimming >
Trim Object > Insert Margin did not work correctly with hatchings.
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-

In the dialog used to edit multiple instances’ properties, the check boxes next to the actual edit fields could
not be set or cleared manually.

-

The internal memory management has been optimized, it now runs up to 10% faster. In addition, a bug
known but unresolved for almost eight years has finally been fixed.

-

When automatically loading nested blocks from a library, the frame calculation could be wrong depending on
their order in the file. As a result, parts of the block disappeared depending from the visible drawing area.

-

Due to an error in the library management, the program could crash when switching a library’s state from
“Changeable” to “Not changeable”.

-

Rotated bitmaps that were rotated by exactly 90, 180, or 270 degrees were sometimes neither displayed nor
printed.

-

The “Lettering” plug-in had an error at the creation of shape/position tolerances with reference line and of
tolerance data: If more than one object of that type existed in a drawing, or was moved, the reference was
faulty and arbitrary lines were drawn. Unfortunately, objects created with the faulty plug-in cannot be repaired!

-

The “Texture / Color Gradient” plug-in had an error in the management of user-defined settings. When
opening the list with all saved settings, the program usually crashed.

-

The “Automatic Archive” plug-in mishandled all files that were created with CAD6, i.e. it copied them without
resolving external references.

-

When unintentionally clicking onto another window (e.g. the toolbox) during coordinate entry, the edit
window could get into the background and thus become invisible, giving the impression the application hangs.

-

The display of a snapping result via tooltip window sometimes remained permanently visible after moving the
drawing window content.

-

The CAD6 Logo has been redesigned, all icons and graphics were adapted accordingly. All command icons have
been slightly modified and are now available with full color depth.

-

The CAD6 Setup has been completely revised, it now uses a new, simpler user interface.

-

Now using the latest FreeImage library in version 3.2.1. This version fixed several smalls bugs when importing
bitmaps. In addition, it is now completely integrated into the program.
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CAD6 Release 2003 Service Pack 4 (December 2003)
-

The Undo and Redo structure has been extended so that now also those commands that modify drawing
elements (layers, pen, hatchings, line sequences, line patterns, coordinate systems, page frames, and variables)
can be undone / redone. When Undo or Redo is completed (i.e. no further Undo or Redo step is available), a
temporary message appears.

-

The Trimming > Connect Objects command now works correctly in all situations.

-

Display problem with horizontal construction aid lines fixed.

-

The import of pen setting files did not work properly, this has been corrected.

-

When exporting to WMF files, optional dimension texts background deletions were exported black instead of
white.

-

The DXF/DWG Import and Export filter has been extended and redesigned in many parts. The same applies to
the SVG Export filter.

-

The Auto Converter plug-in has been completely revised. It is now also possible to automatically combine MKD
drawings with drawing templates.

-

The Color Gradient / Texture plug-in did not work correctly in Fill with Block, Generated Surface mode.

-

Changing settings in the Text on Path plug-in’s parameter dialog did not affect the next object created, but
only subsequent objects.

-

When creating a new page frame the screen display was offset by a half or full page size.

-

After starting CAD6 by double-clicking a drawing file in the Explorer sometimes the icons of plug-ins in the
graphical popup menu were invisible.

-

The support of the new Windows XP styles has been completed.

-

From now on, the file format MKD is used in Version 6.10. This file format allows to identify any object and
any block in a drawing with a unique identifier which can subsequently be referenced from another point (e.g.
by a special plug-in or a database). Users who use an “older” version of CAD6 can download Service Pack 4 for
free to be able to read and write this format.

-

You can now enter several activation keys at once (separated by semicolon) in the dialog window of the
command Help > Activation. This is necessary if for example the network access of a notebook changes
frequently (Ethernet / Wireless LAN). CAD6 automatically selects the matching activation key from the list of
entered keys.
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CAD6 Release 2003 Service Pack 3 (July 2003)
-

CAD6 now support the new Windows XP styles. The command Configuration > Options > Skin allows you to
switch back to the classic display.

-

The display and output of bitmaps has been completely revised. Especially working with very large bitmaps is
faster and more reliable. In addition, it is now possible to display rotated bitmaps on Windows 95/98/ME
systems. Printing rotated bitmaps on such a system is still impossible.

-

Libraries can now also be saved in CAD 5 format to allow complete data exchange with previous program
versions.

-

In the Configuration > Options > General dialog, it is now possible to choose between two different methods
to display selected objects.

-

When renaming folders in libraries, it was possible to accidentally create block names longer than allowed. In
some cases, this lead to a program crash or an error when trying to load such a library again.

-

Exporting block line types with the DXF/DWG Export Filter did not work. In addition, the program could crash
during complex export operations under Windows NT 4.0 in a limited memory situation.

-

The DXF/DWG Import Filter has been improved in many details. For example, some dimensioning types were
interpreted as incomplete and thus discarded. In addition, Splines and NURBS are now being imported
completely.

-

The plug-In Text on Path could crash when using variables whose names were considerably shorter than their
resolved content.

-

The creation of blocks with color gradients or other “extended objects” could result in an application error.

-

Under certain circumstances the toolbox window was only displayed partially on Windows XP.
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CAD6 Release 2003 Service Pack 2 (May 2003)
-

The automatic trimming commands did not work properly with dashed or dotted outlines. In extreme cases
(e.g. with lots of dashed construction aid lines) the command could take a very long time to complete. In
addition in some situations intersection points and tangential points were not applied properly.

-

Dimensions created with the Lettering > Incremental and Common Datum Dimension plug-in sometimes
contained illegal values causing the application to crash when loading a drawing containing these objects. In
addition, the coordinate system setting “*Current” always resulted in dimensions using the coordinate system
“*Standard” instead of the currently active coordinate system.

-

Architectural dimensions with a fixed number of fractional digits (e.g. 2) sometimes displayed the value 1 m
as “1” instead of the correct “1.00”.

-

The “Edit Layers” and “Edit Pens” dialogs did not show the correct selection of the selected layer or pen when
being called by right mouse-click into the property window or panel.

-

When saving drawings in CAD 5 format, faulty layer and pen numbers could be created. These caused a system
crash when loading the drawing again. The original saving bug has been fixed, and these defective files can
now be loaded without a crash. Saving them again will repair the drawing file.

-

When selecting some specific printer drivers in Windows 95 / 98, the application crashed during the next
screen refresh. This was caused by some non-initialized parameters, which is now handled correctly.

-

The DXF/DWG Import Filter has been improved in many details. For example, there is the new import option
“Ignore Paper Space Objects”.

-

The export option “Create Objects in Model Space Only” has been added to the DXF/DWG Export Filter.

-

When running under Windows NT 4.0, the Computer ID calculation of Service Pack 1 sometimes had a problem
resulting in a different Computer ID, making the application request a new activation key.
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CAD6 Release 2003 Service Pack 1 (April 2003)
-

When applying block line patterns to open outlines (curves and hatchings) the final outline element was
ignored. In addition, the block line pattern was usually only applied to the first outline in nested surfaces or
hatchings.

-

The display of selected object outlines did not work properly on many Windows 95/98/ME systems, so it had
to be redesigned.

-

The filling mode “Eraser” did only work on the screen if it was displayed dyed. Output to printer, clipboard or
file was correct, anyway.

-

On some computers using Windows NT4 / 2000 / XP, rotated bitmaps were not visible at all, on other
computers, only one rotated bitmap was possible at a time. This has been fixed.

-

The Text on Path plug-in sometimes stated “Invalid selection” although obviously the right object types were
selected.

-

When switching between multiple drawing windows, the Coordinate System Display was not updated correctly.

-

When loading the default template during program start, the coordinate system and grid settings were not
applied correctly.

-

Sometimes, CAD6 accidentally displayed the text “Educational Version” in headers of drawings created by full
versions.
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CAD6 Release 2003 (April 2003)
-

Due to several requests, the graphical display of object selection, permanent selection and multiple selection
has been completely revised with the main focus on best visibility. Objects are now displayed in full color while
being moved, i.e. all objects (optionally bitmaps too) are being moved in their original, slightly tinted colors.

-

Texts in text objects, dimensionings, attributes and variables can now contain Unicode characters and format
information. This is achieved by using control sequences similar to HTML. For example bold text can be
switched on and off using <b> and </b>. Together with the possibility to change the font and text size within a
single text all features of a standard text processing software are available now.
All edit controls used to enter texts, attributes, and variables are completely Unicode-enabled and can, e.g.,
exchange Unicode texts via the clipboard.

-

The new command File > Miscellaneous > Archive Secured Drawing can be used to archive a drawing in
„secured“ mode, i.e. to resolve all external references and to secure the drawing against specific ways of use
like printing, exporting, saving and modification. A drawing secured in that way can then be passed on to third
parties.

-

In addition to line-based line patterns, you can now define block-based line patterns. Using such line
patterns, you can directly create complex line patterns for standard floor plans (PlanzV 90).

-

The command Draw > Polygon > Rectangle via 3 Points is especially useful when manually digitizing scanned
plans that frequently contain rotated, rectangular elements.

-

The commands Trim > Trim Objects > Automatic Trim / Cut Out and Trim > Trim Objects > Automatic
Lengthen can be used to lengthen or trim most types of objects, or to cut out a segment, with just a single
mouse click.

-

Page frames can now be rotated and/or scaled. This makes it easier to create and manage complex multi-page
drawings, especially in GIS applications.

-

The Multiple Copy > Rotation commands now offers new options to rotate with an incremental angle, and
copying along a defined total angle.

-

The new commands Draw > Circular Arc > Tangential Append, Radius and Draw > Circular Arc >
Perpendicular Append, Radius extend the construction possibilities of circular arcs.

-

When editing layers, you now have the possibility to copy or move complete folder structures containing
layers, optionally with adaptation of all layer references in objects and internal blocks.

-

When editing pens, you now have the possibility to copy or move complete folder structures containing pens,
optionally with adaptation of all pen references in objects and internal blocks.

-

When editing texts or dimensionings, you can now simultaneously edit all text or dimension parameters in the
same dialog, thus saving one command call in many cases.

-

The import and export filters for DWG, DXF, HP-GL/2 files have been revised.

-

The printing routine has been completed revised. It now prints all pages of a drawing in a single print job,
allowing duplex printing and export of multi-page drawing into a PDF file using Adobe® Acrobat®. In addition, a
problem with print settings has been fixed that caused some user settings (e.g. for paper tray selection or
printing quality) to be ignored.

-

The new plug-in Auto Converter allows to automatically convert directory structures with DWG, DXF, HP-GL/2,
and CAD6 files. In addition, these directory structures can be converted to libraries and vice versa (requires the
respective filters).

-

The plug-in Draw > Texture / Color Gradient now uses extended objects. This results in all parameters of the
texture and color gradient being viewable and editable subsequently using Shape > Edit Properties.

-

The plug-in Lettering > Lettering now uses extended objects. This results in all parameters and texts of all
symbols being viewable and editable subsequently using Shape > Edit Properties.
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-

The plug-in Lettering > Align Text to Path now uses extended objects. This results in all parameters being
viewable and editable subsequently using Shape > Edit Properties, and the text being editable subsequently
using Shape > Edit Text.

-

The version number of the file format was changed from 5.0 to 6.0. This new file format can only be read and
written by Malz++Kassner CAD6. But of course CAD6 can also read all older MKD and even T4G files. In addition,
you can explicitly save CAD 5 files to allow file exchange with older versions.

-

Along with each license of Malz++Kassner CAD6 you purchase support & updates for the next 12 months. The
support covers all questions and problems related to the respective program, i.e. installation, configuration,
data exchange, construction, development of custom plug-ins, etc. Updates include both bug fixes (service
packs) and completely new program versions. Both can be downloaded from www.CAD6.com for free.
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Version 5 Service Pack 6 (December 2002)
-

Loading huge files in Windows XP was extremely slow due its modified memory management. This has been
fixed.

-

An MKD file created with Edit > Comment > Export... could not be loaded directly using File > Open because it
was incomplete.

-

A curved dimension line reacted incorrectly when being distorted or non-proportionally scaled.

-

Each undo or redo step caused a double screen refresh taking unnecessary time.

-

The import and export filters for DXF and DWG now support viewports. Viewports that have been imported
from a DXF/DWG file can be exported again correctly. By interpreting the $LTSCALE header variable, line widths
are now always scaled correctly.

-

The HP-GL/2 import filter now also handles files correctly that end with an “IN” command. In addition, it now
handles a null byte in the files like a line feed instead of end-of-file.
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Version 5 Service Pack 5 (August 2002)
-

The new CAM extension offers an enhanced tool list management and improved commands, but most of all, it
now includes configurable post processors for G-Code (DIN 66025), isel intermediate format (NCP) and 3D HPGL/2 (MultiCAM). It is available as option for CAD 5 Professional and CAD 5 Workstation.

-

From this version on, all commands in the Lettering > Determine Values (except for Area / Perimeter) are
also available in Economy edition and in the free viewer. In addition, the viewer now includes the Edit Texts
command which can access both texts and attributes in read-only mode.

-

The Equidistant command now also works with construction aid objects. In case of straight construction lines,
the result is also a straight construction line. The calculation of the equidistant has been optimized to deliver
better results in some extreme cases.

-

All numerical modifications of objects (Move, Rotate, Scale) are now automatically adapted to the current
view (Cartesian, Dimetric, Isometric).

-

In Configuration > Options > File Options you now have an additional option for Clipboard operations: „CAD 5
format only“.

-

In Configuration > Options > Windows, the font size for the panel and the status window can now be chosen
from three sizes.

-

Variables can now be nested up to 25 levels, i.e. one variable can contain another one. In addition, variables
can now contain mathematical terms that will be resolved if the variable’s text begins with an equality sign
(e.g. “=25 + ~Var1~ + ~Var2~”). Term evaluation can be switched on and off using the Configuration > Drawing
Settings > Screen dialog. This setting is drawing dependent.

-

The new variable “%p3” can be used to display the current page frame number.

-

Using the new attribute type “URL” you can link drawing files, text documents or internet URLs to a block. A
new, dedicated set of standard paths enables you to easily manage the files references by these attributes.

-

When copying blocks from external libraries into the drawing using Library > Edit Block, these blocks
sometimes disappeared after trying to insert an instance of such a block.

-

The dimension line option “Automatic” (switching between horizontal and vertical mode using the CTRL key)
did not work when the angle of the distance to measure was exactly 45 or 135 degrees.

-

Export of angle or arc length dimensionings to exchange formats such as DXF, DWG, or WMF caused a program
error if the option “Erase Background” was active.

-

The import and export of WBMP bitmaps now works correctly.

-

The selection filter now has a dedicated switch for clipping objects.

-

When working with surfaces (Generation, Union, etc.), the optimized routine for object splitting creates less
“unnecessary” intermediate points.

-

The frame calculation of deeply nested blocks did not work correctly when loading the drawing. This caused
some blocks to disappear or become inaccessible without reason.

-

The maximum number of layers, pens and line types has been increased from 500 to 1000.

-

The import and export filter for DXF and DWG now work with all formats up to AutoCAD 2002, and have been
extended by the following functions:
- Import and export of filled surfaces using the DXF object “HATCH”
- Import and export of TrueType font information
In addition, multiple line type names are now detected and removed more reliably.

-

The HP-GL/2 import filter now handles the “PE” (Polyline Encoded) command. This completes the list of
supported geometry commands. Continuing outlines consisting of single objects are now imported as a single
curve.
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The new option “Adjust Line Width” in the HP-GL/2 export filter allows to scale the line widths according to
the output scaling. In addition, the export now considers line end styles.

-

The coordinate display now shows up to 12 digits in front of the point (instead of only 6 before).

-

Now using the FreeImage Library in version 2.5.2.
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Version 5 Service Pack 4 (January 2002)
-

The new SVG Export Filter allows professional export of vector graphics to the Internet. Using the SVG format,
you can easily export all CAD 5 drawings to a vector graphic format that is supported by all major Internet
browsers for displaying and printing through use of a free plug-in. Displaying and printing with user scaling and
scrolling is supported. The resulting quality is comparable to that of Postscript or PDF. The SVG Export Filter is
enclosed with any CAD 5 Workstation, and is available as an optional extra for CAD 5 Professional.

-

CAD 5 Professional and above now include the new commands Draw > Polygon > Centered Rectangle and Draw
> Polygon > Rotated Rectangle.

-

The commands for rounding edges have been extended by the three new commands Trim > Round Edge, Baggy
> Object - Object, Trim > Round Edge, Baggy > One Corner and Trim > Round Edge, Baggy > Complete. The
other rounding commands have been renamed to be more distinguishable.

-

When copying objects via the clipboard, a reference point can be chosen on Copy and the objects can later be
placed relatively to it when Pasting.

-

When selecting points for Shape > Move Points you can now choose between points with similar or identical
coordinates (like when selecting objects). This does not apply to Move Single Point, which always moves ALL
points at a given coordinate.

-

The command Trim > Surface / Curve > Generate Surface was unreliable when at least one reference object
was a circular arc. Even in other cases it is possible that the result is technically “correct” but not the expected
one.

-

The command Trim > Connect Objects could cause a system fault if e.g. two circles were identified as source
objects

-

Saving a complete drawing as a bitmap using Save Drawing as failed in most case with a write error (“Disk
full?”) being reported.

-

Right-click on a ruler now displays a list of coordinate systems (like it did before). When closing windows of
multiple visible windows, one of the remaining windows will automatically be activated.

-

When setting the object size in Configuration > Options > General was set to “Large” or “Maximum” in
Windows 95/98/ME, some outlined fonts could be displayed correctly.

-

The Library Management caused an error if a library currently being created was also marked for “saving”. An
empty library could not be loaded as “non-changeable”.

-

A frame text can now also be selected by clicking its frame. This is especially useful for “empty” frame texts
acting as placeholders in forms.

-

The font selection sometimes did not work correctly when switching between “normal” and “symbol” fonts.

-

The FreeImage library is now available in version 2.4.2 which fixes some problems with loading newer BMP
formats. In addition pasting bitmaps from the clipboard now always works correctly.

-

Some calculation routines have been optimized so that screen output and internal operations are up to 10%
faster.
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Version 5 Service Pack 3 (August 2001)
-

All editions of CAD 5 now include the library “Hatchings DIN 201”.

-

In addition to Windows Bitmaps (*.BMP), you can now import the following bitmap types: JPEG (*.JPG), Photo
CD (*.PCD), PaintBrush (*.PCX), PNG (*.PNG), Sun Rasterfile (*.RAS), Targa (*TGA), uncompressed TIFF (*.TIF),
Wireless Bitmap (*.WBMP). The import of GIF and compressed TIFF files is not possible due to licensing reasons.

-

In addition to Windows Bitmaps (*.BMP), you can now export the following bitmap types: JPEG (*.JPG), PNG
(*.PNG), uncompressed TIFF (*.TIF), Wireless Bitmap (*.WBMP). For bitmaps with 8-bit color depth new
optimized palettes are available. The export of GIF and compressed TIFF files is not possible due to licensing
reasons.

-

When creating large surfaces or curves using the Assemble commands, the resulting object could be invalid,
resulting in a faulty file when saved.

-

Block instances now have a “virtual” definition point (at the block insertion point), which can be moved using
the usual point movement commands.

-

When inserting blocks from the block list, the option “Retain Block Scaling” has been taken from the global
“Insert Block” command, so changing the local option in the block list had no effect.

-

In all dialogs where fonts are selected, you can now select the character set (e.g. “Turkish” or “Cyrillic”) in
addition to the font name and style.

-

When using the dimension line orientation mode “Automatic” with edges of exactly 45 degrees, it was in some
cases not possible to switch between horizontal and vertical using the CTRL key.

-

When scaling frame texts, the text size itself did not change, only the size of the surrounding frame.

-

Calculating an equidistant to ellipse parts with an arc angle of more than 180 degree often caused a program
crash.

-

The Configuration > Options > General dialog now offers an option to choose if bitmaps shall be displayed
normally or replaced by a placeholder during manipulation.

-

Text output has been optimized, it is now 20% to 50% faster than before.

-

The maximum number of undo steps has been increased from 100 to 1000.

-

Numerical output to parts lists now uses the maximum precision of 14 fractional digits.

-

Display and output of complex hatchings and surfaces did not work in some cases due to a temporary memory
area that was allocated to small.

-

When importing drawings with custom color definitions, duplicate color definitions were not detected. In
addition, some separate settings were being overwritten even if the “Add” mode was active.

-

Note: the HP-GL/2 import filter does not yet process the “PE” command. As soon as this feature is available, we
will make the updated HP-GL/2 import filter available for download on our web site.
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Version 5 Service Pack 2 (March 2001)
-

The option “Graphic Menu / Standard Menu” in Configuration > Options > Mouse Button Assignment has been
extended to work like the right mouse button did in CAD 4.7: When a command entry has already been started,
the command will be cancelled or finished, respectively. Otherwise, the “Graphic Menu / Standard Menu” will be
opened immediately.

-

In Windows 95 and Windows 98, the system resources have not been released correctly. As a result, no more
than 3 or 4 instances of Malz++Kassner CAD 5 could be open simultaneously. In addition, after a longer working
period, the resources could have been used up.

-

The dimension line option “Automatic” (automatic switching between horizontal and vertical dimension) has
been extended allowing manual switching by keeping the CTRL-key pressed. So it is now no longer necessary to
manually switch between “Horizontal”, “Vertical” and “Automatic” mode.

-

The “Line Type” button in the property windows did not work.

-

When loading several drawings with partially identical page frames, some of these page frame were not loaded
and displayed correctly.

-

The input of a coordinate dimension with active reference line did not work correctly in some cases.

-

The commands Circle > Object - Point - Point, Circle > Object - Object - Point, and Circle > Object - Object Object could end in endless loops in some situations.

-

The command Configuration > Options > File Options now offers special options for pasting from clipboard.
When copying to clipboard, you can now select whether you want WMF or EMF data in addition to the CAD 5
data format (which is always created). When exporting WMF files, you can determine whether the WMF file shall
include a placeable header or not (this option replaces the prompt that previously popped up for every export).

-

The inheritation of properties via block instances to the block's objects had an error that could lead to objects
remaining visible although the higher instance was assigned to an invisible layer.

-

When inserting variables of type “Local Attribute” into a text, a wrong variable name (e.g. “~%00~” instead of
“~*00~”) was generated. As a result, the display of these attributes did not work.

-

Coordinate values in parts lists are now always according to the coordinate system that is active while creating
the parts list.

-

Markings have not been colored when being identified or permanently selected.

-

Single delimiters of variables (‚~‘) inside a text have been misinterpreted and could cause a program crash when
loading a drawing files with such a text.

-

The ortho mode by mistake influenced the commands Lettering > Edit Dimension > Dimension Line Position
und Lettering > Edit Dimension > Extension Line End-Point which caused incorrect results.

-

When erasing the background of a dimension text, a possible fractional value was not taken into account.

-

The automatic elimination of identical objects during identification now also works with a dimensioning
commands.

-

If both the “Multiply By 2” and “Edit Tolerance” dimension options were active, the dialog for tolerance editing
still showed the original, not multiplied dimension value.

-

The dimension line itself and possible line end symbols did not reflect line type and line width correctly.

-

The maximum number of outline elements that the commands Assemble Surface and Assemble Curve can
handle has been increased from 2000 to 10,000. In some cases, if one of these commands was cancelled and
restarted multiple times, the program could crash. There were also some situations in which using elliptical arcs
with an arc angle of more than 90 degrees could cause errors or even a program crash.

-

Configuration > Pens > Defaults now offers a separate default setting for mid-perpendiculars.

-

The resolving of block instances has been speed up significantly.
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-

The live display of Shape > Reflect Objects > Point on Line has not been correct. In addition, the command
terminated after entering the first destination point even if the control key (Duplicate) was pressed.

-

The keyboard assignment now accepts all characters (even space, dot, comma, etc.) starting with the second
character. In the text menu that is used to select a command to be assigned to a key, inactive commands could
not be selected.

-

When a library is not available during program start it won’t be removed from the library list automatically.
Instead it will be listed in all library and block dialogs with its file name but can’t be changed. Once the library
is available again during startup it will be fully accessible again.

-

Configuration > Drawing Settings > Screen now offers an option to display only permanently selected objects.

-

The plug-in “Text on Path” did not work with Construction Aid objects.

-

When printing an area, activating the “Print Output Area” option will result in a frame being printed around the
area.

-

Archived drawings were not saved correctly. As a result, under certain circumstances, these files couldn’t be
opened again. In case of emergency, these files can be fixed manually, please contact us.

-

If the control key was pressed while the multiple identification dialog was appearing, the duplicate mode was
permanently switched on or off by mistake.

-

The ACI color tables of the “DXF Import” and “DWG Import” plug-ins contained two errors which have been
fixed. Additionally, some errors with circular and elliptical arcs have also been fixed.

-

In the “Dimension” plug-in, you can now specify the “dimension text placement option” for all dimension
types. In addition, the plug-in creates extended objects, allowing the user to handle the complete dimension as
a single object. Three new commands allow the user to move, add, and remove single measure points in such a
compound dimension.

Version History

87

Version 5 Service Pack 1 (November 2000)
-

An application error (floating-point exception) on Windows 98 during the input of a definition point of some
drawing commands (e.g. Circle > Circumcircle) has been fixed.

-

The application’s caption now shows the current window’s zoom factor next to the drawing file name.

-

The command Configuration > Pens > Defaults now offers a separate default value for center crosses.

-

When inserting block instances, the option ”Scale Line Widths” was not correctly applied to the created
instance but had to be set manually. Additionally, this option was not applied to the preview.

-

In the dialog of the command Block > Edit the properties of libraries can now be edited separately for block
heads and block objects.

-

Reference texts with the frame type “None” were calculated with a wrong surrounding frame, resulting in partial
texts not being displayed.

-

Coordinate dimensions imported from “old” drawings that were arbitrarily rotated were displayed incorrectly
(although the internal data was still correct).

-

After the auto-save of drawings the stored objects for “Previous Selection” are now retained. In order to avoid
an unintentionally cancellation the progress indication window isn’t displayed any more.

-

While a parameter dialog of a plug-in was displayed, it was still possible to select another command from the
toolbox that again opened a dialog, and so on.

-

The plug-ins “DXF Import” and “DWG Import” have been revised. They now read objects of type ELLIPSE and
LEADER. Objects of type SPLINE are interpolated and multi-line texts of type MTEXT are now converted correctly.

-

The plug-ins “DXF Import”, “DXF Export”, “DWG Import”, and “DWG Export” had problems with line type and
layer names that contained an underscore. These names were not handled correctly and possibly created twice.

-

In the plug-in “Texture / Color Gradient” the commands using generated surfaces did not work correctly - they
only produced “empty” clippings.

-

When using the “Page up” / “Page down” option with a Logitech Wheel Mouse, sometimes the crosshairs were
not deactivated and redrawn correctly.

-

The plug-in “Function Plotter” crashed due to an error in its internal memory management.

-

In case of a limited license, the expiry date of the license is now displayed in the Help > About Malz++Kassner
CAD dialog.
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Version 5 (September 2000)
-

The new Workflow Manager, being activated by right mouse button click, offers a list of useful commands
depending on the current command and input status. By this means, the user can easily access these commands
without having to go through the menu. In addition, this menu offers an overview of all available options.
The Workflow Manager also offers an “Extended Identification” mode. In this mode, single objects or object
groups can be identified serially until the “Extended Identification” mode is switched off again. This allows
users to efficiently identify arbitrary object sets without using the keyboard.

-

The dimensioning parameters have been extended considerably: the end-points of dimension extension lines
can now be edited (using Text > Edit Dimension > Extension Line End-Point). Dimension texts can be placed
rotated by 90 degrees at one end of the dimension extension lines. An additional mode allows automatic
switching between horizontal and vertical dimensions. For half dimensions, the dimension value can
automatically be multiplied by 2. The automatic dimension text rotation according to DIN can now be switched
off, allowing rotation of the dimension text freely if necessary. Coordinate dimensions can be supplied with a
frame and/or arrow (like reference texts). An eraser can be placed behind the dimension text. If a dimension
text is placed close to the dimension line, but not centered, the dimension line will automatically be extended
up until the end of the dimension text, if necessary.

-

The user interface has been revised, in that all program icons have been redesigned in color. Due to a
consistent use of color it is now easier to distinguish similar looking command icons. Using the new
Configuration > Options > Skin command you can choose from several different skins. And you can create your
own skin!

-

When moving or modifying objects (e.g. using the Move / Copy Objects, Scale Objects or Rotate Objects
command), as well as inserting blocks, the objects are now being displayed “live” in the specified input color
depending on the current cursor position, making those commands more straight forward.

-

The redesigned command Configuration > Zoom > Pan now allows direct panning of the window content with
the mouse. If this command is assigned to a mouse button (default is the middle mouse button), a single click
will suffice!

-

Libraries using the cache are now handled in a completely different manner. When opened for the first time, an
index file is created that allows fast access to each single block in the library. As a result, blocks can now be
selected directly and viewed in all block selection dialogs without time-consuming hard disk accesses and
without loading the complete library into memory.

-

The former Library > Resolve Instances command is now named Library > Block > Resolve Block Instances.
As a result, it now available in the submenu for block handling (key 'Y').

-

The possibility of using multiple page frames within one drawing has been extended. Using the new commands
Configuration > Zoom > Next Page, Configuration > Zoom > Previous Page, and Configuration > Zoom > Go
To Page, you can easily navigate through the existing page frames. Using the new Configuration > Page
Frames > Reset Status command, you can delete all page frames and replace them with a single standard page
frame.

-

All text objects (“Standard”, “Frame” and “Reference”) now have a new option for the reading order of the text.
Using this option, it is now possible to display Arabic, Hebrew, Japanese and Chinese texts in the correct
reading order.

-

Standard texts now have a “virtual” definition point (at the text insertion point), which can be moved using the
usual point movement commands.

-

Two new reference text parameters allow display without frame and/or arrow, and a new frame mode “Rounded
Rectangle” has been added.

-

All dialogs used to enter or modify texts now include a preview of the selected font.

-

The former “Assistant Geometry” or “Geometry” has been renamed “Construction Aid”.

-

The former command Draw > Circle > Line - Line - Line and the identical command for Construction Aid have
been split into the new commands Circle > Object - Point - Point, Circle > Object - Object - Point and Circle
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> Object - Object - Object. In all cases, it is now possible to identify either lines, Construction Aid lines, or
circles as reference objects.
-

The commands for curve and surface trimming have been combined in the new Trimming > Surface / Curve >
submenu. The Edit command now allows editing both surfaces and curves, and more editing options are
available. The command Cut Curve has been removed, the same function is provided by the Trimming > Trim
Objects > Split command.

-

The new command Trimming > Connect Objects Tangentially connects two circles and/or ellipses
automatically with two tangential lines and trims the original circles / ellipses to arcs accordingly.

-

The new command Trimming > Trim Surface > Split Non-Overlapping allows splitting of two overlapping
surfaces to non-overlapping separate surfaces in a single step.

-

The new command Trimming > Clipping > Create, Both offers a one-step method to create two clippings of the
same object set - once inside, once outside. This results in the “inner” part of the objects being “cut out”, i.e.
it can be move independently of the rest.

-

The commands Configuration > Options > Change Key Assignment and Configuration > Options > View Key
Assignment have been combined to Configuration > Options > Key Assignment. The new command allows
editing of edit multiple assignments while viewing the complete list of current key assignments.
In addition to single-key shortcuts, commands can now be assigned to multiple-key shortcuts with up to 7 keys.
A possible assignment would be “C”-“L”-“V” for Construction Aid > Line > Vertical. Using these multiple-key
shortcuts, you can create more individual shortcuts that are also easier to remember.

-

When scaling objects using the Shape > Scale Objects > commands, new options allow users to scale line
widths and/or dimension texts accordingly. In addition, instances now have a “Scale Line Widths” option that
means that the line widths of the displayed block are scaled according to the display matrix.

-

The commands Construction Aid > Division > Object and Construction Aid > Multiple Copy > Object now
work with complete curves / surfaces. The maximum number of divisions has been increased to 10,000.

-

The new command Configuration > Restore Default Values allows users to basically reset the program to the
original state after installation. The new command Configuration > Register File Extension registers the file
extension *.MKD in the system. This is useful if the program was started via a network without a local
installation, or if the registration has been tempered by another application.

-

In error situations, a text message appears in addition to the acoustical signal. The text message window pops
up near the mouse position and informs about the type of error.

-

If the identification of an object is ambiguous, or if a calculation has multiple results, the different alternatives
are now analyzed and possible duplicates are removed, before the user is prompted to make a selection.
If two lines, for example, lie exactly on top of each other, the program recognizes this and the user is not
prompted to make a selection because it makes no difference for the calculation of the perpendicular which line
is used.

-

The dialog used to select the desired object from an ambiguous identification now appears near the current
mouse position. When possible, it now offers an additional “Delete” button to delete unneeded objects
immediately.

-

The effect of the ortho mode is now visualized by showing the respective direction by means of a straight line.
Intersections of this straight line with other objects can be snapped if the “Intersection” snap mode is active.

-

The new angle unit “Geographic” [geo] allows angle entries according to the compass rose, i.e. one rotation is
360 degrees, angles go clockwise, and the angle origin is at 12 o'clock.

-

Objects of type “Clipping” and “Extended Objects” now use a completely new data structure that doesn't contain
groups anymore. The result is a much faster management and display of these object types. In addition,
clippings and extended objects can now be part of blocks in external libraries.

-

The version number of the file format was changed from 4.6 to 5.0. This new file format can only be read and
written by Malz++Kassner CAD 5. But of course CAD 5 can also read all older MKD and even T4G files.
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From now on, a DWG import and export filter is available.
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Version 4.7 Service Pack 8 (June 2000)
-

The snap modes “Quadrant” and “Center” can now easily be used simultaneously. A quadrant point of a circle
will only be snapped if the user clicks near it. Otherwise, the circle's center will be snapped.

-

Some problems during generating and editing curves and surfaces have been solved.

-

When importing layer or pen settings in the corresponding dialogs, the existing elements could be mixed up
with the new ones.

-

An additional option in the DXF import filter allows an automatic adaptation of the transmission structure
which assures that subsequent changes of layer properties will be correctly applied to all objects.

-

In the options dialog of the DXF export filter you can now specify that screen properties be used for output.

Version 4.7 Service Pack 7 (January 2000)
-

An error in the hatching algorithm which under certain conditions resulted in wrong hatchings and in rare cases
in crashes has been fixed.

-

An architectural dimensioning with a value of almost one meter was displayed as “100” (cm) instead of “1” (m)
when being rounded.

-

You can now use the command Library > Block > Edit to edit the header and the objects of a block separately.

-

Zooming with the mouse wheel is now smoother.

-

When entering values for the scale or grid now five decimal places are stored.

-

Reflected groups and instances that were exported to a DXF file were sometimes rotated incorrectly, i.e. they
had a wrong rotation angle in the DXF file.

-

On graphic cards using the TNT2 chip some hatchings were not displayed correctly - only the first line of the
hatching was visible. This problem is caused by a graphic card driver inadequacy. We have fixed this problem by
using a different drawing mechanism for hatching.

-

Small problems with the interface to Wacom-Digitizern have been fixed. In addition to all CalComp and
Summagraphics digitizers, the current Digitizer plug-in now also supports all Wacom “Intuos” digitizers. All
further WINTAB-capable digitizers (Genius, Aristo, etc.) are also supported, but have not been tested yet.

Version 4.7 Service Pack 6 (August 1999)
-

On Windows 95 / 98 the check next to the item “Save Position and Size” in system menus of placeable windows
wasn't displayed at all.

-

The command Geometry > Geometry Line > Perpendicular didn't work correctly if the identification point was
positioned exactly on the reference line.

-

During the execution of the command Options > Open on Windows 95 / 98 an unrecoverable program error
occurred.

-

Loading a layer settings file in the Layers > Edit dialog did not work properly.

-

When editing a block's properties using Library > Block > Edit, the corresponding library was not marked as
“modified”.

-

Creating a new drawing used the file options for “Open Drawing” instead of “Create New Drawing”, and the pen
display in the panel was sometimes not adapted according to the new drawing's pen definitions.
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Version 4.7 Service Pack 5 (July 1999)
-

A problem with the command selection by clicking an icon on a WINTAB digitizer has been fixed.

-

The command Configuration > Zoom > Area is no longer cancelled by other direct commands like
Configuration > Zoom > Overview but remain active.

Version 4.7 Service Pack 4 (June 1999)
-

If the “Add” option of the MKD drawing import options was permanently stored using “Save as Default”, this
option also affected the normal “Open Drawing” command. As a result, the number of elements (Layers, Pens,
etc.) could be lost when opening and saving a drawing several times. This will now be avoided. In addition, all
elements loaded are tested in order to assure that each element name exists only once.

-

When loading layer or pen status from within the according dialog window, existing layers or pens will no
longer be replaced, but both sets will be combined in a save manner. As a result, elements defined after the last
saving of the status file will be maintained.

-

In many cases, creating clippings that contained extended objects and resolving such clippings later did not
work at all or only partially.

-

The commands Line > Perpendicular and Circle > Tangential did not work correctly if the reference object was
a circle or ellipse and the identification point was placed exactly on that object's outline. In those cases, a
tangent instead of a perpendicular was calculated.

-

When importing WMF files, some texts were imported incompletely.

-

Markings were sometimes included in exports even if the “Output Markings” was explicitly disabled.

-

The DXF import now handles entities of type MTEXT correctly which are created by AutoCAD 12 and higher.

-

When exporting objects by means of export filters, the object selection defined there was not available as
“Previous Selection” afterwards.

-

When copying pens or layers, a new option allows users to copy a complete folder structure with all nested subfolders.

-

The interface to WINTAB digitizers has been revised again to allow problem-free working with Wacom digitizers.
In the process, the unit used for coordinates on the digitizer was reduced from 1/10000” to 1/1000” since some
drivers had problems with the higher resolution. Furthermore, coordinate tracking is now always relative to the
current drawing's origin. For further information please refer to the chapter “Using Digitizers” in the
application's reference.
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Version 4.7 Service Pack 3 (March 1999)
-

The commands Trimming > Trim Objects > Cut Out and Trimming > Trim Objects > Split now also work with
surfaces, curves and hatchings. If an object consists of multiple outlines, only the one outline determined by
the identification point will be modified.

-

The commands Assemble Surface and Assemble Curve now work correctly if ellipse parts are involved.

-

The Configuration > Layers > Edit and Configuration > Pens > Edit dialogs now display folders graphically
highlighted. In addition, complete folders can be selected and edited at once. The new “Copy” button allows
simultaneous copying of multiple elements. The dialog itself can now be resized in height, allowing viewing of a
maximum number of entries concurrently.

-

The automatic placement procedure for dimension texts has been revised so that some dimension texts in
existing drawings may switch to the opposite side of the dimension line.

-

A dimension being located inside a block was sometimes updated even though that option was explicitly
disabled.

-

When resolving blocks or groups, the resulting single objects received the correct pen and layer assignment, but
could still “remember” their previous assignment, resulting in objects being hidden, visible, frozen, or grayed
that should not be.

-

The wheel of a Microsoft Intellimouse or a similar input device is now supported. Used for zooming, each step
reduces or enlarges the display by a factor of square-root(2).

-

The Library > Block > Insert dialog has three new options for layer and pen handling.

-

The file options have been extended by a separate set of options for “New Drawing”.

-

When transforming a surface into a curve, the resulting curve will remain “closed”, i.e. an additional edge will
be inserted automatically.

-

The calculation of a distance to a Bézier curve and dropping a perpendicular onto a Bézier curve did not work
properly in some cases.

-

New options in the snap parameters allow users to keep a possible ortho mode and grid active while snapping a
point.

-

Some problems with the equidistant calculation have been resolved. In addition, the parameter dialog has been
extended by a “Round Edges” option which avoids a prompt appearing each time.

-

A problem was fixed that could cause the program to terminate without warning when a clipping surface (e.g. a
color gradient) was identified.

-

The interface to WINTAB digitizers has been revised and comprehensively tested with the latest drivers. For
further information please refer to the chapter “Using Digitizers” in the application's reference.

-

The options files created and read with Configuration > Options > Open and Configuration > Options > Save
As (extension .INF) have been completely revised. They now use the Windows-internal format for settings and
are much more flexible. In addition, they now really contain all settings and remain valid in later versions.
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Version 4.7 Service Pack 2 (December 1998)
-

Drawings files are now being locked while they are open, so that they cannot be haphazardly modified by other
users in the network. Locked drawing files can only be opened for reading by other applications or users.

-

The commands Text > Calculate > Area and Text > Determine Values > Area / Perimeter are now able to
directly calculate the area of surfaces with nested outlines as long as those outlines do not cross each other.

-

An additional small mouse position indicator appears if the crosshairs position differs from the actual mouse
position due to snap or ortho modes. This allows easier navigation in these situations.

-

The ortho mode has been extended by a new mode for multiples of 5 degrees. In addition, you can now state a
tolerance that determines how “near” the cursor must be to a given angle before it snaps to it.

-

A new option at Shape > Copy Properties Defaults prevents the property dialog from popping up after each
object selection.

-

When rounding all edges of a curve, this curve was by mistake converted into a surface.

-

When placing a coordinate system's origin relative to a page frame, some options did not work properly. The
system's origin is now always placed relative to the first page frame!

-

When trying to delete a non-visible layer or non-visible pen, no warning appeared if objects were still assigned
to it.

-

Configuration > Options > File Options now offers separate file options for drawings and templates.

-

A new option in the snap parameters allows conflicting snap modes to be avoided. If selected, the snap mode
selection works like it did in version 4.5, buffering the latest set of non-conflicting snap modes selected.

-

The Extra > Selection Filter Parameters dialog has been completely revised. It is now more consistent in its
layout, and the new buttons “Filters” and “Reset All” allow users to save and restore named filter settings and
to reset all settings, respectively.

-

Using variables in the header or footer of print-outs only worked if the variable was at the beginning of the
text.

-

The Viewer inadvertently listed the file types “EMF”, “WMF”, and “BMP” during File > Open although it is not
able to open such files.

Version 4.7 Service Pack 1 (November 1998)
-

When using the “Output Grid” option during print-out, the output area was sometimes not completely covered
with grid points.

-

When printing using “Fit to Page” or “Multiple Pages” option, the result was unnecessarily printed as often as
the number of selected page frames.
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Version 4.7 (October 1998)
-

A new edition of Malz++Kassner CAD, called “Viewer”, is available now. This viewer is a -free- program that
allows users to open, view, print and export any MKD drawing file created by Malz++Kassner CAD. In addition,
comments can be created and edited for drawing revision. The viewer is available on any Malz++Kassner CAD 4.7
CD as well as on our Web Site at www.malz-kassner.com. Feel free to pass on the viewer to anyone!

-

The maximum size of an object can now be determined by the user at Configuration > Options > General.
Larger objects are especially useful when creating and modifying complex surfaces.

-

The maximum number of elements per outline in a curve, surface, or hatching has been increased from 4,000 to
10,000; the maximum number of outlines in a curve, surface, or hatching has been increased from 1,000 to
10,000.

-

The new commands Trimming > Curve > Assemble and Trimming > Surface > Assemble offer a new way to
easily assemble curves and surfaces from given partial objects. (CAD Professional only)

-

Four new commands were added to the Lettering > Determine Values > submenu: Distance Object - Point,
Distance Object - Object, Radius, and Relative Angle. (CAD Professional only)

-

The new submenu Configuration > Pen Management > offers numerous commands for pen handling analogous
to the already existing submenu Configuration > Layer Management >. In addition, an Undo function is now
available for pen properties. (CAD Professional only)

-

The following commands were added to the Draw menu: Line > Tangential Append, Line > Perpendicular
Append, Circular Arc > Tangential Append, and Circular Arc > Perpendicular Append. (CAD Professional only)

-

The following commands were added to the Geometry menu (if available): Geometry Line > Tangential Append
and Geometry Line > Perpendicular Append. (CAD Professional only)

-

The new command Geometry > Delete Objects allows to specifically delete geometry objects.

-

The new submenu Draw > Bézier Curve allows users to easily draw single Bézier curves in three different ways.
(CAD Professional only)

-

The number of commands for comment creating and management has been increased along with the number of
parameters. All these commands are now available in all editions of Malz++Kassner CAD, i.e. also in Economy.
For a complete overview, please take a tour through the Edit > Comment > submenu.

-

The command Trimming > Trim Object > Resolve Completely now allows users to choose whether or not to
resolves Bézier curves into polylines.

-

All commands for surface creation and manipulation in the Trimming Surface > submenu now fully support
Bézier curves, i.e. Bézier curves will no longer be resolved into polylines during calculations. This results in
higher accuracy and reduced memory requirement.

-

Drawing can now contain so-called “global variables”, which can be referenced in any text or dimension object.
Using such variables, it is easy to alter the textual appearance of a drawing by simply editing a couple of
variables. Use the new command Edit > Edit Variables to define, edit and delete variables.

-

The command Shape > Copy Properties has been accompanied with a new command, Shape > Copy Properties
Defaults which allows the default set of properties to be copied during the Copy Properties command.

-

For some commands in the Draw > Line > submenu, the display of the end-point's relative coordinates was
wrong.

-

The maximum number of line types has been increased from 100 to 500.

-

A possible ortho mode will no longer effect the Configuration > Zoom > Section command. In addition, the
ortho mode will now be automatically deactivated when a point is snapped.

-

The selection filter is no longer edited implicitly via the parameters of the active command, but can now be
directly switched on and off using the new Extra > Selection Filter command and edited using the Extra >
Selection Filter Parameters command.
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-

When selecting a special template during File > New, groups and instances contained in that template were not
initialized correctly.

-

The command File > Print Section is now available in all editions of Malz++Kassner CAD, i.e. also in Economy.

-

The maximum number of copies during print-out has been increased from 250 to 10000.

-

When hatching with multi-lines, the global offset was accidentally not applied.

-

The accuracy of equidistant calculation of Bézier curves has been significantly enhanced.

-

The DXF import filter has a new option that allows users to resolve polylines of the DXF file automatically into
lines and circular arcs during import.

-

The DXF export filter has a new option that allows users to create DXF files that use only positive coordinates
for objects. This was necessary since some graphic programs cannot correctly import DXF files with negative
coordinates.

-

During DXF export, position numbers and texts containing local block attributes as variables were not resolved
correctly.

-

During DXF export, geometry objects were sometimes exported when this was not wanted.
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Version 4.6 Service Pack 4 (August 1998)
-

The commands Shape > Align Objects > Page did not work properly under certain circumstances.

-

Due to an internal mix-up, objects could be excluded for snapping although there were assigned neither to an
ignored layer nor to an ignored pen.

-

The surface operations “Union”, “Intersection” and “Difference” did not work correctly in some rare cases,
resulting in “weird” lines.

-

The EMF import from file and clipboard had problems with some types of filled polygons.

Version 4.6 Service Pack 3 (July 1998)
-

Under certain circumstances the saving of a compressed drawing (File > Save) was unnecessarily cancelled by
an error message.

-

The display of layer buttons in the panel disappeared sometimes when editing layer settings.

-

For the command Shape > Group > Create Group, additional parameters are now available which allow you for
example to resolve the properties of all objects in that group.

-

A new set of variables called “drawing attributes” is now available for use in any text. For further details, please
refer to the Text Variables and Attribute Display chapter in the online reference.

-

The new command Shape > Copy Properties allows properties to be copied from one object to others.

-

The new command Geometry > Delete Completely allows deletion of all geometry objects at once.

-

The selection filter and its parameters is now directly available in the Extra menu, where it can be directly
switched on and off. In addition, there is a new button in the panel that has the same function. A right click
on that button calls the “Selection Filter Parameters” dialog.

-

The multiline parameters can now be directly edited using a command from the Extra menu. In addition, a right
click on the corresponding button in the panel calls the “Multiline Parameters” dialog.

-

When printing areas, the area has unnecessarily been printed as often as the number of existing of page frames.

-

The maximum page size has been increased from 4 x 4 Meters to 25 x 25 Meters.

-

Using the printing mode “Page Frames” it is now again possible to state a scaling factor.

-

During scaled printing, you can now choose whether or not to scale the line widths.

-

The EMF export to file and clipboard has been revised to create accurate object sizes.

-

Under certain circumstances the point of intersection of a circular arc and a temporary reference line was not
recognized by the snap function.

-

The command Geometry > Line > Perpendicular did not work correctly.

-

The command Shape > Rotate Objects > Reference Points did not work correctly when the final angle was
entered numerically.

-

When modifying an “ignored” object the resulting object was no longer ignored for some time.

-

When using one of the “Architectural” number modes in the active coordinate system, some dialog box entry
fields behaved incorrectly, resulting in unpredictably changing values.

-

Dimensions of diameters and radii can now be aligned horizontally and vertically.

-

The selection of a special template during File > New did not work properly.

-

A larger number of settings are now stored with each drawing (and thus with each template).

-

The program has been optimized for use on multi-processor systems.
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Version 4.6 Service Pack 2 (June 1998)
-

The command Configuration > Windows > Rearrange now also rearranges the view window and the guide
window.

-

The commands in Determine Values > delivered partially wrong values if the scale was not 1:1 or if the
architectural dimension mode was used.

-

The commands Chamfer Edge > One Edge and Chamfer Edge > Complete now allow users to choose which of
the two affected edges the angle and length of the chamfer shall be calculated relative to.

-

The settings stored in the default template were completely loaded during program start-up, but not fully
activated (e.g. screen background color).

-

When saving the default template, objects and internal blocks were always saved, independent on how the
question was answered.

-

The surface operations “Union”, “Intersection” and “Difference” now work more reliably in those cases where
the two surfaces have common edges.

-

The snapping mode “Edge” and most “Perpendicular” commands now also work with Bézier curves.

-

The display of direction arrows and object numbers did not work properly in large drawings.

-

It was not possible to add blocks to an empty (newly created) library. Such blocks were always added to the
internal blocks without notice.

-

Line end style and line joint mode are now fully supported on Windows 95.

-

The default Digitizer assignment files delivered with the Professional and Workstation edition did not contain
any valid command assignment.

Version 4.6 Service Pack 1 (May 1998)
-

Printing in “Fit to Page” mode ignored the page orientation selected by the user and used the page orientation
of the current page frame instead.

-

The snapping mode “Edge” did not work with geometry lines.

-

When saving templates, you will now be prompted whether or not to save objects and internal blocks with the
template.

-

It was not possible to save compressed drawing since this option was not available in the file type list.

Version History

99

Version 4.6 (May 1998)
-

Drawing templates were introduced. Use Configure > Template > Save As to create a drawing template, and
call File > New Drawing to open a drawing template.

-

It is now possible to maintain multiple pages within one drawing. Six new commands in the Configuration >
Page Frames submenu replace the previous Configuration > Page Format command. They allow users to add,
alter and remove page frames.
Due to these new possibilities, several additional options are available for printing, in order to print for
example, a single page or all pages at once. In addition, there is new command Configuration > Zoom > All
Pages.

-

The snapping function was totally revised. The new implementation allows users to have any combination of
snapping modes active concurrently. If multiple possible snapping points lie within the snapping radius, a set
of priorities determines which point to use. After a point is snapped, a “snap guide” window appears for a short
period, displaying the snapping mode that was used to snap the point. This allows you to see whether you
snapped for example, a mid-point or an intersection.
The command Extra > Snap Modes > Edit Radius was renamed Parameters. It now also allows users to edit the
snap guide display period.
The new command Extra > Snap Modes > Dialog allows the snap mode settings to e changed in a dialog. This
is especially useful if that dialog is assigned to the middle mouse button.

-

The submenu Lettering > Edit Dimension was extended with the new command Edit Texts which can be used
to edit dimensions (and tolerances). Dimensions can however still be edited using the command Shape > Edit
Text.

-

Using the command Library >Block > Edit, the operations “Properties” in both cases no longer effect the
block's header only, but also all objects that the block consists of. This now allows to assign specific properties
to complete libraries or single blocks within them.

-

The command Extra > Control Keys > Edit Step was removed.

-

Pens now have the same attributes that layers have, i.e. they can be hidden, grayed, idle, etc.

-

In length dimensions with architectural number display, superscript values are now only displayed if they are
non-zero. Furthermore you can now change the number display directly in the dialog Dimension Parameters.

-

The commands in the submenu Text > Determine Values now allow you to determine and display values for
coordinates, distance, area / perimeter. If necessary you can also copy these values to the clipboard.

-

The middle mouse button can now be assigned to any command in addition to the “shift” and “control” key
emulation. This is especially useful when assigning the command Configuration > Zoom > Section or Extra >
Snap Modes > Dialog to it.

-

The command Configuration > Zoom > Section is now “transparent”, i.e. it can be called and executed without
canceling the currently active command. It can now for example, be used during the input of a complex
contour.

-

Within the File > Print dialog the display of the scaling factor will now be updated correctly even if the “Adjust
Size” option is active. In addition, it is now possible to print directly to a file which can be chosen from within
the printing dialog.

-

The command Move Single Point was moved into the Move Points submenu in order to be accessible via the
keyboard (U-5).

-

The command Trimming > Trim Curve > Extend had a problem when connecting two curves that in some cases
could result in doubled fragments.

-

When archiving a drawing, instances in internal blocks and groups were not adapted correctly.

-

The HP-GL/2 import and export filter were completely revised and new functions were added.
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-

The version number of the file format was changed from 4.5 to 4.6, and from now on, the file extension is
*.MKD for drawings and *.MKL for libraries. This new file format can only be read and written by Malz++Kassner
CAD 4.6. But of course CAD 4.6 can still read T4G files. Users of Malz++Kassner 4.5 can get an update to version
4.6 for free from our web site at www.malz-kassner.com or order the Malz++Kassner CD that contains the
update.

-

The number of fractional digits stored in the MKD 4.6 file format was increased from 13 to 14. In some cases,
the use of only 13 digits caused minimal deviation from the internal value. In addition, the internal precision
was increased from 64 to 80 bits where possible.

-

The descriptions of the programming interface and the file format was combined into a single new file titled
MKAPI4.HLP. For a better overview, data types and structures are now always described for both the interface
and the file format at the same location.
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Version 4.54 (January 1998)
-

The HP-GL/2 import filter is now part of Malz++Kassner CAD 4.5 Workstation and is also available separately.

-

Due to the request of numerous users, both grid and snap are disabled during the execution of the command
Configuration > Zoom > Section.

-

The maximum number of blocks in a drawing was increased from 10,000 to 20,000 since some users reached the
former limit. The limit of 1000 blocks in each folder has been removed, each folder may now contain as many
blocks as required.

-

Some parts of the block handling routines have been completely revised for better performance. As a result, the
overall performance of the program is much better when a huge number of blocks is involved. Loading a sample
drawing with 10,000 blocks is now faster by a factor of 8.

-

Elements of blocks that were assigned to non-visible layers could still be selected.

-

In length dimensions using the architectural number display, all decimal places starting with the third digit
(sub-centimeter values) are now displayed in smaller, superscript letters.

-

Further distributor-specific entries have been added to the order form.

Version 4.53 (December 1997)
-

The maximum number of elements in curves and surfaces has been doubled. This allows more complex curves
and surfaces to be created and manipulated.

-

The file format description and the programming interface documentation have been slightly revised.

-

The order form has been extended by distributor-specific entries. Malz++Kassner CAD is now being offered by
numerous distributors in Europe and around the world. Of course you can still order directly from Malz++Kassner.

Version 4.52 (November 1997)
-

The new command Geometry > Geometry in Background allows users to force the program to display all
geometry objects in the background of “normal” objects.

-

The new command Configuration > Layer Management > Hide All Except enables you to hide all layers at
once except those used by the selected objects at once. The command Configuration > Layer Management >
Undo was moved to the Configuration > Layers submenu and is now available in CAD 4.5 Economy, too.

-

Using the command Configuration > Options > General, you can now choose whether or not you have the
ability to print rotated bitmaps or not. If you choose not to, the memory required to store each bitmap is
significantly reduced.

-

The HPGL export filter was extended by a correction function for cut plotters with trailing cutters.

-

The middle mouse button was not recognized correctly in all cases when set to emulate the SHIFT key.

-

The printing resolution in Windows 95 has been increased by factor 10 for small drawings and by factor 4 for
larger drawings.

-

The hatching with multiple lines left some areas non-hatched.

-

The equidistant calculation had some problems with closed curves.

-

When including the display grid in an output to printer or clipboard, that grid has always been calculated in
Millimeters instead of the current length unit.

Version History

Version 4.51 (September 1997)
-

Self-running tour has been included.

Version 4.50 (August 1997)
-

Initial version directly distributed by Malz++Kassner.
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